Jump to content
Satyr604

Problem: sound chopping abruptly

Recommended Posts

Hi all, 

 

Recently got a Helix and I'm loving every second of working with it. But, unfortunately I'm plagued by one major issue. 

 

I have my Helix connected to my PC through the USB connection. It's not going through hubs, into a USB3 port. At regular intervals, every few minutes or so, the sound of my DAW will just seemingly cut out completely and only play back in stutters with a few seconds between each said stutter. That'll go on for a while until it's done fussing and it'll go back to normal for a few minutes. One way to stop the stuttering is to switch the playback device to my systems own soundcard. But even if I switch back to the Helix, it'll still stutter for a bit. It's also worth noting I can still play guitar, it's just the sound from my PC that lags. 

 

Funny thing is, the reason I got the Helix in the first place was to get rid of that exact problem. I've had it with the Line 6 PodXT (yeah, the way old one) and thought it was busted. Instead, the problem seems to be something in my computer although I can't figure out what. 

 

Does anyone have any idea what could be causing this? 

Share this post


Link to post
Share on other sites

Most likely you have some other devices that have bad drivers and which interrupt audio devices that need the cooperation of the rest of the system to obtain low latency. You can try latency measuring software like LatencyMon or DPC Latency Checker to see if any particular devices are causing problems, and then upgrade the drivers or disable them. You might also check generally for background services and tasks which could just be using a lot of CPU. Also try updating the drivers for your USB ports, your motherboard, etc.

Share this post


Link to post
Share on other sites

Without knowing which kind of DAW you're using, this type of behavior often relates to the buffer size being too small, or potentially to background processes on your PC interrupting the processing of your DAW.

Share this post


Link to post
Share on other sites

How old is your computer? What CPU? How much memory? What OS?

What DAW? Is anything else running while you're using your DAW?

Have you ever performed the basic steps for optimizing it for use with a DAW? (GOOGLE it)

Share this post


Link to post
Share on other sites

Thanks for the replies and the help all. :) 
 

21 hours ago, kylotan said:

Most likely you have some other devices that have bad drivers and which interrupt audio devices that need the cooperation of the rest of the system to obtain low latency. You can try latency measuring software like LatencyMon or DPC Latency Checker to see if any particular devices are causing problems, and then upgrade the drivers or disable them. You might also check generally for background services and tasks which could just be using a lot of CPU. Also try updating the drivers for your USB ports, your motherboard, etc.

 

Will check for latency on the ports and check back. 

 

3 hours ago, rd2rk said:

How old is your computer? What CPU? How much memory? What OS?

What DAW? Is anything else running while you're using your DAW?

Have you ever performed the basic steps for optimizing it for use with a DAW? (GOOGLE it)

 

The computer itself isn't too old. The CPU in there is a AMD FX 8350, an eight core at 4hz. 16 gigabytes of RAM. The DAW itself is FL Studio 11. All running on Windows 10. I do have some stuff running alongside my DAW, but nothing demanding. Google Chrome and the like. Shouldn't really be anything the CPU can't handle. Thing is, CPU handles it fine as long as it's running through the 'internal' soundcard, the trouble starts when using the soundcard in the Helix (or PodXT for that matter). 

 

Also, just want to point out this doesn't sound like the latency issue of loading too many plugins or something. Then it's 'stuttery', kind of jittery. But this is reeeaaally chopped, like a chop of sound of a half a second to a second, interspersed by a few seconds of nothing. 

 

It doesn't just do it with FL Studio either. It'll do the same thing when running other audio (soundfiles, YouTube etc.) through the external soundcard. 

 

EDIT:

 

Checking back already. Ran DPC Latency Checker and it showed extreme latency in the system. I tried disabling/enabling a few devices and one of the usb-ports was disabled. When I enabled it, latency dropped dramatically. Now, it doesn't seem to matter if it's on or off. It stays medium latency, spiking into high at times. Can't really find another device that affects latency. 

Share this post


Link to post
Share on other sites
7 minutes ago, Satyr604 said:

Google Chrome and the like

 

If you're connected by wireless, disable wireless. That's one of the first steps in optimizing for audio use.

Make sure all of the MB drivers are up to date.

Kylotan mentioned DPC Latency Checker. Run that.

OPTIMIZE THE SYSTEM FOR AUDIO/DAW USE.

I'm emphasizing that because your reply didn't mention that you did it, or what steps you followed or chose to ignore because you didn't think that could be the problem.

You don't know what the problem is, so follow ALL of the steps.

Share this post


Link to post
Share on other sites
37 minutes ago, rd2rk said:

 

If you're connected by wireless, disable wireless. That's one of the first steps in optimizing for audio use.

Make sure all of the MB drivers are up to date.

Kylotan mentioned DPC Latency Checker. Run that.

OPTIMIZE THE SYSTEM FOR AUDIO/DAW USE.

I'm emphasizing that because your reply didn't mention that you did it, or what steps you followed or chose to ignore because you didn't think that could be the problem.

You don't know what the problem is, so follow ALL of the steps.

 

I followed an article, detailing 20 steps to optimize your PC for use with a DAW. Turning off or removing the wireless Belkin adapter did not seem to make a difference. 

 

Ran the DPC Latency Checker, as per the edit in my previous post. It picked up a lot of latency. Enabling one of the seemed USB devices in device manager seemed to stabilize it at a lower latency level. Right now, it doesn't seem to matter whether it's on or off. Tried disabling and re-enabling several devices with no further results. It did go from 16.000µs to 1.000µs, so that's a big improvement. The drop in latency does seem to have a big effect on the problem. It's still there, but way less frequent and the glitches take shorter to disappear when occuring. 

Share this post


Link to post
Share on other sites

This is gonna sound dumb I'm sure, but are you using the Helix ASIO drivers from Line 6 or ASIO4All? I've seen more than a few issues over the years with people assuming because ASIO4ALL can load a device, that its the correct driver. A4A will see the Helix, but its function will be quite erratic. 

Share this post


Link to post
Share on other sites
3 minutes ago, gunpointmetal said:

This is gonna sound dumb I'm sure, but are you using the Helix ASIO drivers from Line 6 or ASIO4All? I've seen more than a few issues over the years with people assuming because ASIO4ALL can load a device, that its the correct driver. A4A will see the Helix, but its function will be quite erratic. 

 

This.

 

Also, as suggested, make sure that all of your MB drivers are up to date, and disable anything you're not using, even if it doesn't SEEM to make a difference. Sometimes the cumulative effect of multiple changes makes the difference.

Share this post


Link to post
Share on other sites

Helix is using the drivers from Line 6, not Asio4All ones. To be sure, I removed Asio4All completely from my PC. 


I'll try updating the mobo and keep fiddling with disabling stuff. 

Share this post


Link to post
Share on other sites
14 minutes ago, Beetlejuice69 said:

Was this ever solved? I'm having the exact same problem and it's killing me.

 

Start here:

 

Disable wireless adapter!!!

Power settings on HIGH PERFORMANCE. Turn off all sleep settings. 
Turn off Windows sounds and special effects.
Disable any unnecessary audio drivers in Sound Panel.

FROM CONTROL PANEL (NOT Settings), open SYSTEM, Advanced System Settings, Advanced Tab, Performance, Settings:
Visual Effects= Adjust for best performance
Performance Options Advanced Tab – Adjust for best performance of = Background Services

Helix Sample Rate matched to DAW. Buffers 128-256 works for most machines.

 

If that doesn't get it, follow the links in the attached file and apply the suggested optimizations.

If THAT doesn't get it, come back.

 

 

Optimize W10 for DAW.txt

Share this post


Link to post
Share on other sites

For my daw stuff, I also when into the usb driver settings for sleep or power or something (under advanced tab for the driver) and turned off the automatic sleep mode, etc.  As per some article I came across - on my laptops, that made a huge difference.  Not sure it's relevant for a desktop.

 

Also things like virus scanners are the DAW's Kryptonite - watch out for that stuff.  Some people apparently go offline while recording/mixing and turn off the virus checker too, then turn on virus checker and go online at other times to keep up to date (or use another computer completely for online use).

 

I just keep my pc with as few unnecessary services running as possible... seems to work well like that, even with chipsets that are known to not always be great for DAW use.  (that's cuz a dell laptop I have is on like a daw's most hated list or something LoL... but it still worked really well once I got background stuff to stop running and the usb power to stay on performance all the time).

 

I did use asio4all for years for my asio needs, and it was always really really great (just used it to get low latency out of stock sound chip - no idea what else it would be good or bad for?).  But I'm new to the helix, so haven't even checked into which driver the helix is using... I'll have to check that too so I don't run into this same problem!

Share this post


Link to post
Share on other sites

You saved me! Thank you so so much!!

 

I did everything in the initial post from Rd2rk and the thing that was causing the issue seemed to be the wireless adapter. Disabled that bad boy and everything's working great. 

Share this post


Link to post
Share on other sites
45 minutes ago, Beetlejuice69 said:

You saved me! Thank you so so much!!

 

I did everything in the initial post from Rd2rk and the thing that was causing the issue seemed to be the wireless adapter. Disabled that bad boy and everything's working great. 

 

Cool!

Do have a look at the other links I sent. Implementing them can prevent other problems down the line.

Rock on!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...