Please ensure Javascript is enabled for purposes of website accessibility Jump to content

SOLVED: Bass Pod XT rotary knobs don't work


Recommended Posts

I thought I'd post my fix to my used Bass Pod XT.  Under Windows 10, I did a firmware update and a flash memory update to the latest versions and after the updates, the Select Page, Effect Tweak, Amp Models, and Effects rotary encoder knobs all ceased working.  All of the other knobs and buttons seemed to work but these 4 rotary encoder knobs didn't.  I tried updating the firmware and flash memory in safe mode as well (hold down the first soft key and power up) and that didn't fix it.  I did an SRAM check (hold down the second soft key and power up) and it reported that memory passed. So I took a wild guess and tried holding down the fourth soft key and power up.  It went through some kind of diagnostic ending with an LCD test whereby it tested all of the pixels in the LCD screen.  After that test, I power cycled the unit and lo and behold, the rotary encoder knobs now were functioning. I hope this helps all of you Bass Pod XT users that have experienced the same problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...