Jump to content
xmacvicar

Badonk Model Crazy Ringing with EMGs?

Recommended Posts

I just got this new guitar LTD EC1000 VB with EMG 81/60

 

When using the Badonk for that brutal metal crunch, I get this insane ringing on palm mutes - shown in this video:

 

https://www.youtube.com/watch?v=5Fav1TAe6vM

 

Other amp models don't seem to be pronouncing the ring the same way.....is it the guitar? The helix? Both together? I am just trying to get some help narrowing this down. Thanks!

 

*attached the preset I was using*

DEATH2.hlx

Share this post


Link to post
Share on other sites

That sounds like the guitar to me... the Helix is just "amplifying" the sound it is being delivered. Does this occur with any other guitars? If not... that's your answer. 

 

Since the guitar is new... make sure the pickups are "solid" in position. No loose screws, no vibrating pickup rings, etc... etc... Don't stop at the pickups... check the saddles, tailpiece, and anything else that could vibrate. 

 

22 minutes ago, xmacvicar said:

Other amp models don't seem to be pronouncing the ring the same way

 

"The same way"? Are you saying the other amps don't do it at all, or are you saying they also make noise but sound different?

 

 

Share this post


Link to post
Share on other sites

Its the guitar....no other guitar is doing it. If I use another amp model, such as the Revv for example, the loud ringing persists with the LTD but no other guitar has the issue.

Share this post


Link to post
Share on other sites

This is def an issue with the guitar and not the helix. Something is loose inside, or the pickups are microphonic or something.

  • Like 1

Share this post


Link to post
Share on other sites
18 minutes ago, xmacvicar said:

This is def an issue with the guitar and not the helix. Something is loose inside, or the pickups are microphonic or something.

 

In my experience... active EMG's will not be microphonic. They are most likely picking up a sound coming from the guitar itself. 

Does it happen on both pickups (individually).... or just one or the other? 

 

If it's just one pickup (or noticeably louder on one pickup)... it's the pickup screws or mounting ring

If it's on both... I would look at other items such as bridge, tailpiece, etc... etc... 

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, codamedia said:

 

In my experience... active EMG's will not be microphonic. They are most likely picking up a sound coming from the guitar itself. 

Does it happen on both pickups (individually).... or just one or the other? 

 

If it's just one pickup (or noticeably louder on one pickup)... it's the pickup screws or mounting ring

If it's on both... I would look at other items such as bridge, tailpiece, etc... etc... 

 

Just tested that - appears its only the bridge that is causing the excessive ringing - the neck is as quiet as can be

Share this post


Link to post
Share on other sites

As an experiment, try jamming some foam under the strings between the bridge and the tailpiece and behind the nut. If that doesn't cure it, it's most likely a loose pickup mount screw/spring. 

  • Like 1

Share this post


Link to post
Share on other sites
Just now, gunpointmetal said:

As an experiment, try jamming some foam under the strings between the bridge and the tailpiece and behind the nut. If that doesn't cure it, it's most likely a loose pickup mount screw/spring. 


I have foam behind the nut right now, as well as a GruvGear Fret Wrap. I haven't tried anything with foam near the bridge yet....I'm taking it back to my local guitar shop where I bought it 2 days ago - they can take a look for me as well!

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, gunpointmetal said:

If that doesn't cure it, it's most likely a loose pickup mount screw/spring. 

 

This is what I am suspecting more than anything else... especially if it is only happening on one pickup. 

Share this post


Link to post
Share on other sites

You're getting a lot of interference from your computer, probably the monitor. Does the sound still happen if you sit further away from it?

Share this post


Link to post
Share on other sites

Took it to my guitar shop. We discovered the bridge pickup (by tapping on the outer housing) is pinging non stop - obviously something not happening on other guitars or on the neck pickup. They are gonna disassemble and adjust or insulate it or something? Either way, waiting to hear back from them!

Share this post


Link to post
Share on other sites

I have a similar issue, my guitar's foamed at the nut (can't foam the bridge - Fender vintage saddles), it happens with 2 different pickups at the neck position, insane way higher ping when palm muting. Yours sounds like noise from either the headstock or behind the bridge. Foam takes care of that.

If not, I had to completely EQ the frequency out which was around 1.7 K, you could locate yours.

 

Also on the Badonk, but to a lesser degree on other hx amp models.

Took it to the store, into a Mesa Triple , no ping at all :-/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...