Jump to content
WildNiteRecords

Using Helix 4CM with a Mesa Mini rectifier

Recommended Posts

Hi guys, 
I am new to helix, Recently tried FRFR and wasn't sold on the sound for what Im doing.
I want to use 4cm to my Mesa Boogie rectifier and I have hooked it all up.
I set my commands up to change the channels of the amp VIA ext amp.
I am experiencing tone suck which I can't get to the bottom of... The amp sounds cleanish on the dirty channel
And also if I put FX after the loop (In screenshot pictured) the effects don't work at all? they work before the input signal but not after nothing at all.
My Mesa has a serial loop could this be causing this? It only has a switch that says bypass or FX loop
My global settings are (guitar pad) off (1/4 outputs - Line) (Instrument - Send return 1) and (Instrument - Send return 2)

Basically all I want to do is be able to run effect before and after the amp... And use snapshots to make the helix change my amp channels between them
 

Sorry if I sound silly there is probably a simple fix but Im really wanting to get it all up and running

Screen Shot 2020-01-22 at 6.55.49 pm.png

Share this post


Link to post
Share on other sites

Check your wiring. 4cm:

 

Guitar>Helix Input>Effects>FX Loop 1 Block>Helix Send 1>Amp Input>Amp FX Loop Send>Helix Return 1>Effects>Helix Left/Mono Out>Amp FX Loop Return

 

Make sure you're using the correct FX Loop Block for the Send/Return pair that you're using. 

Try setting Send/Return 1 to LINE. Send/Return 2 shouldn't even be involved. 

Share this post


Link to post
Share on other sites

I've since sorted some of the issues... I now have a phasing issue on the amp but everything else works great.
My mix is on 100% on the fx loop block

My 4cm is guitar into helix, - 1/4 output to Amps return,-  Amp input into send 1 - and return 1 to amp fx loop send

I have no modulation effects. The snapshots change my amp channels fine its just the weird phaser sound especially in the dirty channel

Thank you for your reply!

Share this post


Link to post
Share on other sites

It sounds like you already figured it out, but I thought I would share my 4CM schematic.  I did this schematic for my TubeMeister 18 which includes a Cab Sim circuit for direct to FOH, but you can just ignore that.   I think it helps to have a visual of what is going on.  I know it helped me.  Good luck.

 

image.png.b6ab47c242bdf2c310ed4b0b9fb5f184.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...