Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Variax battery won't install in the battery compartment.

Recommended Posts

I just got my new JTV69 from Sweetwater. I've charged up the battery. I can't get the battery to install in the battery compartment; the battery won't slide forward in the slots. Is there a trick to installing the battery? Seems like it should just slide in, but it feels like something is in the way. Help!

Link to comment
Share on other sites

Hi Silverhead,

Thanks for the tip. I just tried again several times - keeping it flat - but still no go. (1) Is the battery supposed to be a real tight fit? (2) Would a lubricant like 3 in 1 oil help? I'm stumped about what the problem is and what to do about it.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...