Jump to content
eray

Variax battery won't install in the battery compartment.

Recommended Posts

I just got my new JTV69 from Sweetwater. I've charged up the battery. I can't get the battery to install in the battery compartment; the battery won't slide forward in the slots. Is there a trick to installing the battery? Seems like it should just slide in, but it feels like something is in the way. Help!

Share this post


Link to post
Share on other sites

Make sure the battery is lying flat in the rear portion of the compartment then slide it forward while keeping it flat. I find that it doesn't slide in properly if it is raised at an angle at all.

Share this post


Link to post
Share on other sites

Hi Silverhead,

Thanks for the tip. I just tried again several times - keeping it flat - but still no go. (1) Is the battery supposed to be a real tight fit? (2) Would a lubricant like 3 in 1 oil help? I'm stumped about what the problem is and what to do about it.

 

Regards,

erayman

Share this post


Link to post
Share on other sites

Resolved. It was the battery's first time, so it was a little tighter fit then I anticipated, but it's inside now and I'm ready to rock 'n roll. Thanks!!!

Erayman

Share this post


Link to post
Share on other sites

I would suggest skipping the batteries, and getting a Line6 XPS-AB.... I lasted a couple of days grappling with that waste of time 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...