Jump to content

New G10 unit won't charge fully


Recommended Posts

New G10 unit, just opened it today. I can't seem to get it to charge fully. I've tried charging it in both the G10 base unit and my (also new) Yamaha THR10IIWL. I tried updating the firmware. There was no update on the base unit but the transmitter updated to 1.04. No apparent difference. I read all the manuals to see if I was missing something.


It looks like it's charging for a little while but stops, then I get less than 30 minutes use out of it before it dies.

Am I doing something wrong?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...