Jump to content
kazoue911

hotkeys assignment change but not on purpose

Recommended Posts

Hi all,

 

I've been having issues forever trying to control Cubase via Helix through USB midi while still being able to receive PC/CC information for automatic preset/snapshot recall. I had given up and switched to the new hotkeys feature which seemed to work fine at first but now I'm having an issue again: on random occasion, starting playback in Cubase by pressing the footswitch assign to spacebar will induce a change in this footswitch's hotkey assignment and bring it back to "none" which then prevents me from stopping the playback. When I scroll to my previous/next preset and come back to my main one, everything is as should be and it might work fine for a couple songs, but then, it will happen again, from a different preset, or the same one, it is very intermittent. Has anyone experienced this instability? If so, have you come up with a solution around it? I really would like to get rid of my second midi foot controller and use Helix instead but so far, neither MIDI nor hotkeys have proven reliable enough for live use. a bummer..

 

Thanks for your help.

Share this post


Link to post
Share on other sites

Attach a copy of the preset that you're using. I don't have Cubase, but many commands such as Spacebar for start/stop are standard. If you can also describe what each command does in Cubase I can probably configure Reaper to work like Cubase if it doesn't already. I'll test it to see if I can duplicate the problem. As I'm sure you know, "random" is the hardest to troubleshoot.

Share this post


Link to post
Share on other sites

Wrong Side.hlxThe Hound.hlxRunning.hlxMr. Weather.hlxMain.hlxHeavy.hlx

cues.mid

 

Hi rd2rk

 

Here are the presets I use. I have configured the command center to be exactly the same regardless of which preset is on at a given time. I also included a midi file containing my cues for preset/snapshot recall. You shoul be able to drop it straight into Reaper and asign the output to your Helix and have a similar setup as mine.

 

Please let me know if you find anything of interest. 

 

cheers!

 

Share this post


Link to post
Share on other sites

I wasn't able to use your cues track because the Program Changes are too few and far between to be useful for testing. Also, they're not working. Maybe something weird about how Cubase records them? There's also no Snapshot MIDI events, probably because Snapshot MIDI doesn't transmit automatically like Program Changes, you have to set an Instant Command to send the proper Snapshot Messages.

 

I recorded a MIDI track in Reaper that simply cycles through your Presets every couple of bars, looped it, and let it run. Every so often I pressed the Spacebar Hotkey, and so far it's worked every time.

 

What does the other Hotkey do? In Reaper, "*" is not a factory shortcut. If You tell me what it does in Cubase I can configure Reaper to duplicate the action.

 

Meanwhile, I'll leave it running for a while and hit the Spacebar key once in a while to see if I can get it to fail.

Share this post


Link to post
Share on other sites

OK, I figured out it's RECORD START. I've been running this for about two hours now, randomly starting and stopping, recording, no glitches.

Again, intermittent is the worst to troubleshoot.

 

 

 

 

Share this post


Link to post
Share on other sites

Thanks for trying it out @rd2rk. I suspect a conflict between Cubase and Helix. I get all sort of weird behavior weather I try to use midi or hotkeys to send control messages. It sort of looks like midi feedback but it is not. I have been struggling with trying to get this to work for over a year now and I'm out of ideas. I'll keep using my FBV shortboard as a midi foot controller until I can figure this out. Thanks for your help and please keep me updated if you ever run into some interesting information.

 

 

Share this post


Link to post
Share on other sites
8 minutes ago, kazoue911 said:

I have been struggling with trying to get this to work for over a year now and I'm out of ideas.

 

There's no way that a DAW can change a setting in Helix.

I'm not even sure that I'm understanding your actual problem.

Try this - Install Reaper and work with that for a while. If you've still got the problem (that I couldn't duplicate), then there's something else going on.

FWIW - I tried Cubase and hated everything about it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...