Jump to content
ancker

Helix LT 4CM - No Amp Volume Control

Recommended Posts

I have my Helix LT set up in 4CM with a PRS MT-15 Amp.

Guitar -> Helix LT Guitar Input

LT Send -> MT-15 Input

MT-15 FX Send -> LT Return 1

LT Mono Output -> MT-15 FX Return

 

This appears to work fine with all of the presets without any Send/Return block in play.

The issue I'm having is that the volume knobs on my MT-15 now do nothing. If I set either or both to zero, I still get full signal. Only the volume knob or pedal adjust the volume.

 

Do I need a special Send/Return block for this to work properly?

Is this expected behavior?

What am I missing here?

 

Share this post


Link to post
Share on other sites
23 minutes ago, ancker said:

Do I need a special Send/Return block for this to work properly?

 

Yes. You need to use an FX Loop block in your preset in order for the 4CM to work properly. Otherwise you're just bypassing your amp's preamp.

Share this post


Link to post
Share on other sites
On 3/2/2020 at 11:45 AM, phil_m said:

 

Yes. You need to use an FX Loop block in your preset in order for the 4CM to work properly. Otherwise you're just bypassing your amp's preamp.

 

Thanks. Sorry for the delay in responding, but this helped.

 

As a secondary question, do you just build in an FX Loop for all of your presets, or is there a way to selectively disable 4CM?

 

I suppose I could work up some fun Midi controlled line switcher or something that diverts the signal to the appropriate input on my amp when I select specific presets.

Share this post


Link to post
Share on other sites
5 minutes ago, ancker said:

 

Thanks. Sorry for the delay in responding, but this helped.

 

As a secondary question, do you just build in an FX Loop for all of your presets, or is there a way to selectively disable 4CM?

 

I suppose I could work up some fun Midi controlled line switcher or something that diverts the signal to the appropriate input on my amp when I select specific presets.

 

I think the easiest thing to do is to create 4CM-specific presets and have them set up the way you need them, and not try to make the same presets work for different connection scenarios.

Share this post


Link to post
Share on other sites

If you set-up 4CM properly with your amp, presets that don't use an FX loop will just go straight to the power amp input of the FX return on the amp and bypass the entire preamp section of the amp.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...