Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Helix LT Only Sees 1st IR in Helix Edit


Recommended Posts



After I add IR's to the list in Helix Edit, my Helix LT (about 1 month old) will only let me select the IR in slot 1. It does not matter which IR I put in that slot, I can only select that one with the physical LT. However within Helix Edit I can select a different IR and assign it to the preset just fine and it shows on the LT. But if I get on the LT and turn the knob to select a different one, the original one disappears.

Some things I've tried:

1. Helix Edit: Drag and Drop the IR's, and have also tried "Import"

2. Swapped around the order of the IR's in Helix Edit

3. Deleted the IR block on the LT and added it back in

4. Confirmed that I am running v2.82 on both Helix Edit and the LT

5. Running Windows 10


I've attached screenshots of the Helix Edit screens.

~Pic1 shows the list of IR's in Edit

~Pic2 shows the IR selection in the preset in Edit

~Pic3 shows the dropdown in the preset that displays the list of available IR's in Edit, but they do not show up in the LT


Any ideas on how to remedy this?







Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...