Jump to content
wjernigan

JTV-89F + Helix + L2t = sounds like crap, please help

Recommended Posts

Yes, I drank the cool aid.  I bought it all.  I have a beautiful burgundy JTV.  I have the latest Helix all patched current.  I have the Helix digital cabled into a StageSource L2t for 800 watts of crap.

I've tried all sorts of combinations and permutations.  

I've tried no modeling on the guitar.

I've tried 5 of my other guitars.

I've tried a fresh from scratch amp+cab to the L2t.

I've tried digital and analog to the L2t.

 

I tried to follow one of those "how to setup your Helix out of the box" videos.  The dude sounds like Eddie Van Halen.  My exact setup as his sounds like some out of tune sitar.  

 

I think the issue is the L2t.  Not sure how to test beyond using headphones on the Helix which is next.

I'm looking for anyone with a Helix into a L2t that I can collaborate with.

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
4 hours ago, wjernigan said:

Yes, I drank the cool aid.  I bought it all.  I have a beautiful burgundy JTV.  I have the latest Helix all patched current.  I have the Helix digital cabled into a StageSource L2t for 800 watts of crap.

I've tried all sorts of combinations and permutations.  

I've tried no modeling on the guitar.

I've tried 5 of my other guitars.

I've tried a fresh from scratch amp+cab to the L2t.

I've tried digital and analog to the L2t.

 

I tried to follow one of those "how to setup your Helix out of the box" videos.  The dude sounds like Eddie Van Halen.  My exact setup as his sounds like some out of tune sitar.  

 

Either the Lt2 is screwed up - or your signal chain is. The First question is whether the Helix output is set to Line or Mic and the Lt2 is matched to Line or Mic. 

Share this post


Link to post
Share on other sites

1st time using FRFR monitors can be frustrating if that's the case. Need to keep reading, watching Youtube videos and making sure the gear is ok. Baring having a buddy a block away that can come over and help, a coupla months of that and you will start to sound better to you, and that's all that really matters then. I have great sounding patches and profiles that I could never get on a tube amp, now. You will see- keep at it. ; )

Share this post


Link to post
Share on other sites
16 hours ago, wjernigan said:

My exact setup as his sounds like some out of tune sitar.  

 

 

 

 

 

 

 

 

Are you hearing the guitar acoustically while monitoring with alt tunings? That will make it sound out of tune.

 

Also, post a preset. I'll see how it sounds with my 89F and my Helix.

Share this post


Link to post
Share on other sites

I doubt it’s the L2t. I have two of them, and they’re great sounding speakers. They work really well with the Helix. I think, though, that you probably need to start simply and build from there. Start with an amp model of an amp your familiar with and get that to sound good. It might be easier to start with one of your other guitars first just to minimize the number of variables you’re dealing with.

 

Do you have prior experience with modeling and FRFR setups?

Share this post


Link to post
Share on other sites
18 hours ago, wjernigan said:

Yes, I drank the cool aid.  I bought it all.  I have a beautiful burgundy JTV.  I have the latest Helix all patched current.  I have the Helix digital cabled into a StageSource L2t for 800 watts of crap.

I've tried all sorts of combinations and permutations.  

I've tried no modeling on the guitar.

I've tried 5 of my other guitars.

I've tried a fresh from scratch amp+cab to the L2t.

I've tried digital and analog to the L2t.

 

I tried to follow one of those "how to setup your Helix out of the box" videos.  The dude sounds like Eddie Van Halen.  My exact setup as his sounds like some out of tune sitar.  

 

I think the issue is the L2t.  Not sure how to test beyond using headphones on the Helix which is next.

I'm looking for anyone with a Helix into a L2t that I can collaborate with.

 

 

 

 

 

 

 

You are experiencing the same growing pains that 99.9% of us went through when transitioning from amps to modeling.

 

You don't have a guitar amp anymore... modelers are fundamentally different, and the old rules you're used to no longer apply. Check out Jason Sadites' YouTube channel... he has a number of easy to follow,  square one Helix tutorials. Get a handle on how to create a simple patch, with heavy emphasis on understanding what "simple" means in the digital realm.

 

Modelers require that you think like a recording engineer, not a guitar player. The signal chain you're emulating is exactly what you'd have in a recording studio, heard through monitors in the control room. Merely plugging in a guitar and setting all the amp model's tone controls at noon is NOT gonna cut it.

 

There's nothing wrong with your gear... at this point the problem is conceptual and entirely in your head, as it was for all of us the first time around.

 

Now, all that being said... modelers are not for everyone, and some guys can't make the leap despite their best efforts, and that's OK too. Those of us who logged a lot of studio time before going digital probably had it a little easier because we were already used to monitoring through an FRFR system. Your L2T is never gonna sound like a guitar amp... coming to terms with that is the biggest hurdle. You're creating recorded guitar tones... NOT the sound of a guitar amp a few feet away with nothing between you and the amp but air. A recorded tone and an "amp in the room" tone are two very different sounds, and you can't bully one into sounding like the other no matter what you do.

Share this post


Link to post
Share on other sites

As a Helix noob I wanted to relate my experience with a JTV-69, Helix floor and Powercab 112 Plus. Perfect.  I have only run the Powercab in flat mode and the sound has been perfect. I have been damn impressed. The Boogie Mark IV (Cali) sounds perfect and I've just been flipping through presets trying them and having a blast.

 

So I am guessing, as you are leaning toward, it is the L2T.

 

I haven't modified anything. I just updated the devices and started jamming.

Share this post


Link to post
Share on other sites

--------------------------UPDATE------------------------

I went to headphones, removed the L2t from the equation.

Now I'm just guitar analog to Helix to headphones.

Simple setup on the Helix is:

1. ANGL Metor Amp+Cab

2. Plate Reverb

3. Simple Delay

 

I removed the Dual Pitch that was causing most of the uglyness.

 

I went back through my guitars:

Fender w/humbucker - meh

PRS Custom SE 24 - meh

Gibson LP - meh

JTV 89F with battery removed, purely bridge humbucker - much better, not killer, just much better

 

I thought humbuckers were mostly the same but the rear pickup in the Line6 JTV was substantially different than the rest.  I'm not pumping any vendor here, objectively it was better. (but it's my opinion so I guess it's subjectively?)  If there were such think as a better sound meter then it would have registered better, therefore, objectively better!

 

Next step is going analog from Helix to L2t and I'll try the music test also.

 

Share this post


Link to post
Share on other sites

reply to the thread and at the bottom click on "choose file". You will have to have saved it to your computer to do this.

Share this post


Link to post
Share on other sites
17 hours ago, wjernigan said:

I'm a noob, how does one post a preset?

 

Using HX Edit, select the preset that you are using/having problems with and save it on your computer, somewhere you can easily find it. Then use the "Reply to this topic" box at the bottom of this page and then you can choose to "Drag files here" or click on the option to "choose file", then navigate to the .hlx file that you saved and select it. It should then attach to the message and upload here, where other users can download it and check it out for any weirdness.

 

Hope this helps/makes sense

Share this post


Link to post
Share on other sites

Here's the patch.  The dual pitch is the largest part of the problem.  However, even without it, it sounds flat and unimpressive through headphones.

(all guitars are tuned, that I've verified)

 

 Here's the guts of the patch file.

 

{
 "data" : {
  "device" : 2162689,
  "device_version" : 42074112,
  "meta" : {
   "application" : "HX Edit",
   "appversion" : 42074112,
   "build_sha" : "a5e7561",
   "modifieddate" : 1586526566,
   "name" : "5150"
  },
  "tone" : {
   "dsp0" : {
    "block0" : {
     "@enabled" : false,
     "@model" : "HD2_PhaserScriptModPhase",
     "@no_snapshot_bypass" : false,
     "@path" : 0,
     "@position" : 0,
     "@stereo" : false,
     "@type" : 0,
     "Level" : 1.0,
     "Mix" : 0.50,
     "Rate" : 0.190,
     "Spread" : 0.0,
     "SyncSelect1" : 6,
     "TempoSync1" : false
    },
    "block1" : {
     "@bypassvolume" : 1.0,
     "@cab" : "cab0",
     "@enabled" : true,
     "@model" : "HD2_AmpANGLMeteor",
     "@no_snapshot_bypass" : false,
     "@path" : 0,
     "@position" : 1,
     "@type" : 3,
     "Bass" : 0.250,
     "Bias" : 0.50,
     "BiasX" : 0.50,
     "ChVol" : 0.850,
     "Drive" : 0.40,
     "Hum" : 0.50,
     "Master" : 0.420,
     "Mid" : 0.650,
     "MidBoost" : false,
     "Presence" : 0.390,
     "Ripple" : 0.50,
     "Sag" : 0.50,
     "Treble" : 0.510
    },
    "block2" : {
     "@enabled" : true,
     "@model" : "HD2_ReverbPlate",
     "@no_snapshot_bypass" : false,
     "@path" : 0,
     "@position" : 2,
     "@trails" : false,
     "@type" : 7,
     "Decay" : 0.550,
     "HighCut" : 4570.0,
     "Level" : 0.0,
     "LowCut" : 90.0,
     "Mix" : 0.30,
     "Predelay" : 0.0150
    },
    "block3" : {
     "@enabled" : true,
     "@model" : "HD2_DelaySimpleDelay",
     "@no_snapshot_bypass" : false,
     "@path" : 0,
     "@position" : 3,
     "@stereo" : true,
     "@trails" : false,
     "@type" : 7,
     "Feedback" : 0.350,
     "Level" : 0.0,
     "Mix" : 0.30,
     "Scale" : 0.750,
     "SyncSelect1" : 6,
     "TempoSync1" : false,
     "Time" : 0.2670
    },
    "block4" : {
     "@enabled" : false,
     "@model" : "HD2_PitchDualPitch",
     "@no_snapshot_bypass" : false,
     "@path" : 0,
     "@position" : 4,
     "@stereo" : false,
     "@type" : 0,
     "Cents1" : -7.40,
     "Cents2" : 7.40,
     "Interval1" : 0,
     "Interval2" : 16,
     "Level" : 0.0,
     "LevelVoice1" : 1.0,
     "LevelVoice2" : 1.0,
     "Mix" : 0.50,
     "PanDry" : 0.50,
     "PanVoice1" : 0.1250,
     "PanVoice2" : 0.8750,
     "Time1" : 0.0,
     "Time2" : 0.0
    },
    "cab0" : {
     "@enabled" : true,
     "@mic" : 1,
     "@model" : "HD2_Cab4x12XXLV30",
     "Distance" : 2.0,
     "EarlyReflections" : 0.0,
     "HighCut" : 8000.0,
     "Level" : 0.0,
     "LowCut" : 80.0
    },
    "inputA" : {
     "@input" : 2,
     "@model" : "HD2_AppDSPFlow1Input",
     "decay" : 0.50,
     "noiseGate" : true,
     "threshold" : -48.0
    },
    "inputB" : {
     "@input" : 0,
     "@model" : "HD2_AppDSPFlow2Input",
     "decay" : 0.50,
     "noiseGate" : false,
     "threshold" : -48.0
    },
    "join" : {
     "@enabled" : true,
     "@model" : "HD2_AppDSPFlowJoin",
     "@no_snapshot_bypass" : false,
     "@position" : 8,
     "A Level" : -0.50,
     "A Pan" : 0.50,
     "B Level" : -0.50,
     "B Pan" : 0.50,
     "B Polarity" : false,
     "Level" : 0.0
    },
    "outputA" : {
     "@model" : "HD2_AppDSPFlowOutput",
     "@output" : 1,
     "gain" : 0.0,
     "pan" : 0.50
    },
    "outputB" : {
     "@model" : "HD2_AppDSPFlowOutput",
     "@output" : 0,
     "gain" : 0.0,
     "pan" : 0.50
    },
    "split" : {
     "@enabled" : true,
     "@model" : "HD2_AppDSPFlowSplitY",
     "@no_snapshot_bypass" : false,
     "@position" : 0,
     "BalanceA" : 0.50,
     "BalanceB" : 0.50,
     "bypass" : false
    }
   },
   "dsp1" : {
    "inputA" : {
     "@input" : 0,
     "@model" : "HD2_AppDSPFlow1Input",
     "decay" : 0.50,
     "noiseGate" : false,
     "threshold" : -48.0
    },
    "inputB" : {
     "@input" : 0,
     "@model" : "HD2_AppDSPFlow2Input",
     "decay" : 0.50,
     "noiseGate" : false,
     "threshold" : -48.0
    },
    "join" : {
     "@enabled" : true,
     "@model" : "HD2_AppDSPFlowJoin",
     "@no_snapshot_bypass" : false,
     "@position" : 8,
     "A Level" : -0.0999985,
     "A Pan" : 0.50,
     "B Level" : 0.0,
     "B Pan" : 0.50,
     "B Polarity" : false,
     "Level" : 0.0
    },
    "outputA" : {
     "@model" : "HD2_AppDSPFlowOutput",
     "@output" : 1,
     "gain" : 0.0,
     "pan" : 0.50
    },
    "outputB" : {
     "@model" : "HD2_AppDSPFlowOutput",
     "@output" : 0,
     "gain" : 0.0,
     "pan" : 0.50
    },
    "split" : {
     "@enabled" : true,
     "@model" : "HD2_AppDSPFlowSplitY",
     "@no_snapshot_bypass" : false,
     "@position" : 0,
     "BalanceA" : 0.50,
     "BalanceB" : 0.50,
     "bypass" : false
    }
   },
   "dt0" : {
    "@dt_12ax7boost" : 0,
    "@dt_bplusvoltage" : 0,
    "@dt_channel" : 0,
    "@dt_feedbackcap" : 0,
    "@dt_poweramp" : 1,
    "@dt_reverb" : true,
    "@dt_revmix" : 0.250,
    "@dt_topology" : 0,
    "@dt_tubeconfig" : 0,
    "@model" : "@dt"
   },
   "dt1" : {
    "@dt_12ax7boost" : 0,
    "@dt_bplusvoltage" : 0,
    "@dt_channel" : 0,
    "@dt_feedbackcap" : 0,
    "@dt_poweramp" : 1,
    "@dt_reverb" : true,
    "@dt_revmix" : 0.250,
    "@dt_topology" : 0,
    "@dt_tubeconfig" : 0,
    "@model" : "@dt"
   },
   "dtdual" : {
    "@dt_12ax7boost" : 0,
    "@dt_bplusvoltage" : 0,
    "@dt_channel" : 0,
    "@dt_feedbackcap" : 0,
    "@dt_poweramp" : 1,
    "@dt_reverb" : true,
    "@dt_revmix" : 0.250,
    "@dt_topology" : 0,
    "@dt_tubeconfig" : 0,
    "@model" : "@dt"
   },
   "footswitch" : {
    "dsp0" : {
     "block0" : {
      "@fs_enabled" : false,
      "@fs_index" : 5,
      "@fs_label" : "Script Mod Phase",
      "@fs_ledcolor" : 1037,
      "@fs_momentary" : false,
      "@fs_primary" : true
     },
     "block2" : {
      "@fs_enabled" : true,
      "@fs_index" : 2,
      "@fs_label" : "Plate",
      "@fs_ledcolor" : 16723200,
      "@fs_momentary" : false,
      "@fs_primary" : true
     },
     "block3" : {
      "@fs_enabled" : true,
      "@fs_index" : 3,
      "@fs_label" : "Simple Delay",
      "@fs_ledcolor" : 458496,
      "@fs_momentary" : false,
      "@fs_primary" : true
     },
     "block4" : {
      "@fs_enabled" : false,
      "@fs_index" : 4,
      "@fs_label" : "Dual Pitch",
      "@fs_ledcolor" : 196619,
      "@fs_momentary" : false,
      "@fs_primary" : true
     }
    }
   },
   "global" : {
    "@DtSelect" : 2,
    "@PowercabMode" : 0,
    "@PowercabSelect" : 2,
    "@PowercabVoicing" : 0,
    "@current_snapshot" : 0,
    "@cursor_dsp" : 0,
    "@cursor_group" : "block4",
    "@cursor_path" : 0,
    "@cursor_position" : 4,
    "@guitarinputZ" : 0,
    "@model" : "@global_params",
    "@pedalstate" : 2,
    "@tempo" : 87.3999,
    "@topology0" : "A",
    "@topology1" : "A"
   },
   "powercab0" : {
    "@model" : "@powercab",
    "@powercab_color" : 0,
    "@powercab_distance" : 3.50,
    "@powercab_flatlevel" : 0.0,
    "@powercab_hicut" : 20100.0,
    "@powercab_irlevel" : -18.0,
    "@powercab_lowcut" : 19.90,
    "@powercab_mic" : 0,
    "@powercab_speaker" : 0,
    "@powercab_speakerlevel" : -15.0,
    "@powercab_userir" : 0
   },
   "powercab1" : {
    "@model" : "@powercab",
    "@powercab_color" : 0,
    "@powercab_distance" : 3.50,
    "@powercab_flatlevel" : 0.0,
    "@powercab_hicut" : 20100.0,
    "@powercab_irlevel" : -18.0,
    "@powercab_lowcut" : 19.90,
    "@powercab_mic" : 0,
    "@powercab_speaker" : 0,
    "@powercab_speakerlevel" : -15.0,
    "@powercab_userir" : 0
   },
   "powercabdual" : {
    "@model" : "@powercab",
    "@powercab_color" : 0,
    "@powercab_distance" : 3.50,
    "@powercab_flatlevel" : 0.0,
    "@powercab_hicut" : 20100.0,
    "@powercab_irlevel" : -18.0,
    "@powercab_lowcut" : 19.90,
    "@powercab_mic" : 0,
    "@powercab_speaker" : 0,
    "@powercab_speakerlevel" : -15.0,
    "@powercab_userir" : 0
   },
   "snapshot0" : {
    "@ledcolor" : 6,
    "@name" : "CLEAN",
    "@pedalstate" : 2,
    "@tempo" : 71.7703,
    "@valid" : true,
    "blocks" : {
     "dsp0" : {
      "block0" : false,
      "block1" : true,
      "block2" : true,
      "block3" : true,
      "block4" : false
     }
    }
   },
   "snapshot1" : {
    "@ledcolor" : 4,
    "@name" : "DRIVE",
    "@pedalstate" : 2,
    "@tempo" : 71.7703,
    "@valid" : true,
    "blocks" : {
     "dsp0" : {
      "block0" : true,
      "block1" : true,
      "block2" : true,
      "block3" : true,
      "block4" : true
     }
    }
   },
   "snapshot2" : {
    "@ledcolor" : 3,
    "@name" : "DRIVE+",
    "@pedalstate" : 2,
    "@tempo" : 71.7703,
    "@valid" : true,
    "blocks" : {
     "dsp0" : {
      "block0" : true,
      "block1" : true,
      "block2" : true,
      "block3" : true,
      "block4" : true
     }
    }
   },
   "snapshot3" : {
    "@ledcolor" : 2,
    "@name" : "LEAD",
    "@pedalstate" : 2,
    "@tempo" : 71.7703,
    "@valid" : true,
    "blocks" : {
     "dsp0" : {
      "block0" : true,
      "block1" : true,
      "block2" : true,
      "block3" : true,
      "block4" : true
     }
    }
   },
   "snapshot4" : {
    "@ledcolor" : 6,
    "@name" : "CLEAN AMBI",
    "@pedalstate" : 2,
    "@tempo" : 71.7703,
    "@valid" : true,
    "blocks" : {
     "dsp0" : {
      "block0" : true,
      "block1" : true,
      "block2" : true,
      "block3" : true,
      "block4" : true
     }
    }
   },
   "snapshot5" : {
    "@ledcolor" : 8,
    "@name" : "CLEAN TREM",
    "@pedalstate" : 2,
    "@tempo" : 71.7703,
    "@valid" : true,
    "blocks" : {
     "dsp0" : {
      "block0" : true,
      "block1" : true,
      "block2" : true,
      "block3" : true,
      "block4" : true
     }
    }
   },
   "snapshot6" : {
    "@ledcolor" : 2,
    "@name" : "AMBI LEAD",
    "@pedalstate" : 2,
    "@tempo" : 71.7703,
    "@valid" : true,
    "blocks" : {
     "dsp0" : {
      "block0" : true,
      "block1" : true,
      "block2" : true,
      "block3" : true,
      "block4" : true
     }
    }
   },
   "snapshot7" : {
    "@ledcolor" : 9,
    "@name" : "BIG SWELLS",
    "@pedalstate" : 2,
    "@tempo" : 71.7703,
    "@valid" : true,
    "blocks" : {
     "dsp0" : {
      "block0" : true,
      "block1" : true,
      "block2" : true,
      "block3" : true,
      "block4" : true
     }
    }
   },
   "variax" : {
    "@model" : "@variax",
    "@variax_customtuning" : false,
    "@variax_lockctrls" : 0,
    "@variax_magmode" : true,
    "@variax_model" : 1,
    "@variax_str1level" : 1.0,
    "@variax_str1tuning" : 0,
    "@variax_str2level" : 1.0,
    "@variax_str2tuning" : 0,
    "@variax_str3level" : 1.0,
    "@variax_str3tuning" : 0,
    "@variax_str4level" : 1.0,
    "@variax_str4tuning" : 0,
    "@variax_str5level" : 1.0,
    "@variax_str5tuning" : 0,
    "@variax_str6level" : 1.0,
    "@variax_str6tuning" : 0,
    "@variax_toneknob" : -0.10,
    "@variax_volumeknob" : -0.10
   }
  }
 },
 "meta" : {
  "original" : 0,
  "pbn" : 0,
  "premium" : 0
 },
 "schema" : "L6Preset",
 "version" : 6
}
 

5150.hlx

Share this post


Link to post
Share on other sites
34 minutes ago, wjernigan said:

Here's the patch.  The dual pitch is the largest part of the problem.  However, even without it, it sounds flat and unimpressive through headphones.

(all guitars are tuned, that I've verified)

 

 Here's the guts of the patch file.

 


 

5150.hlx 10.68 kB · 0 downloads

It sounds ok to me. I removed the pitch block, and added a Minotaur OD to get rid of some of the wooliness. I think it sounds great. I am playing it through a Les Paul with fairly hot pickups. File attached.

5150 v2.hlx

Share this post


Link to post
Share on other sites

Found another piece to the puzzle.

 

Scenario #1: I play AC/DC Thunderstruck on my iPad (older with a headphone jack) out through a 3.5mm cable that changes to stereo RCA plugs into the AUX input on the back of the L2t, volume at 6 o'clock, feedback suppression is off, speaker mode is P.A. = whole song sounds great.

 

Scenario #2: I play the same iPad through a 3.5mm stereo to 1/4" stereo jack into the line input on the back of the L2t, same settings as above = audio is modified.  You wouldn't know until the vocals start.  The vocals are almost nonexistent they are so muffled. Then you start to notice that there are other portions of the audio feed that are modified also.   It's weird.  The original analog signal is filtered at certain eq points, and it sounds like there's a slight echo to the base.  Not what I expected.  I can only assume the same is happening to my guitar signal if I plug into the line input.

 

Is this working as designed?  Can anyone duplicate this behavior?  Any song with vocals will work.  The change to the signal is obvious, if you're familiar with the song.

Share this post


Link to post
Share on other sites
On 5/14/2020 at 2:48 PM, wjernigan said:

Found another piece to the puzzle.

 

Scenario #1: I play AC/DC Thunderstruck on my iPad (older with a headphone jack) out through a 3.5mm cable that changes to stereo RCA plugs into the AUX input on the back of the L2t, volume at 6 o'clock, feedback suppression is off, speaker mode is P.A. = whole song sounds great.

 

Scenario #2: I play the same iPad through a 3.5mm stereo to 1/4" stereo jack into the line input on the back of the L2t, same settings as above = audio is modified.  You wouldn't know until the vocals start.  The vocals are almost nonexistent they are so muffled. Then you start to notice that there are other portions of the audio feed that are modified also.   It's weird.  The original analog signal is filtered at certain eq points, and it sounds like there's a slight echo to the base.  Not what I expected.  I can only assume the same is happening to my guitar signal if I plug into the line input.

 

Is this working as designed?  Can anyone duplicate this behavior?  Any song with vocals will work.  The change to the signal is obvious, if you're familiar with the song.

 

@wjernigan -- tagging you here to make sure you see this, because after reading everything above this is probably the issue you've had all along ('sitar' sound).

 

The problem is you're sending a stereo signal on a TRS cable to a balanced mono input. It flips the phase of one of the two signals and adds them, effectively canceling out anything they had in common. Things like vocals and such in the center channel will get cancelled. In short, don't do this.

 

The RCA inputs are meant for unbalanced stereo, and the L2t simply adds them together (sum to mono). Thus these sound like you'd expect.

 

In terms of your Helix being connected to the L2t, either a TRS (balanced) or TS (unbalanced) should work fine, *if* they're coming from a single output jack on the Helix. If you have a y-splitter merging the Left and Right outputs and are plugging those into your L2t mono balanced input, that will also sound like trash, for the same reason as above.

Share this post


Link to post
Share on other sites

@wjernigan - I see that you live in Chandler. I live in Gilbert. I've been using the Helix for a few years now and a Variax of some form or other for over 10 years. I used to run it all through an L2T regularly at gigs - recently changed to a Powercab. Just saying that I have a lot of experience with this stuff. 

 

PM me. I might be able to help you work through some of this stuff.

Share this post


Link to post
Share on other sites
On 5/14/2020 at 5:54 PM, qwerty42 said:

 

@wjernigan -- tagging you here to make sure you see this, because after reading everything above this is probably the issue you've had all along ('sitar' sound).

 

The problem is you're sending a stereo signal on a TRS cable to a balanced mono input. It flips the phase of one of the two signals and adds them, effectively canceling out anything they had in common. Things like vocals and such in the center channel will get cancelled. In short, don't do this.

 

The RCA inputs are meant for unbalanced stereo, and the L2t simply adds them together (sum to mono). Thus these sound like you'd expect.

 

In terms of your Helix being connected to the L2t, either a TRS (balanced) or TS (unbalanced) should work fine, *if* they're coming from a single output jack on the Helix. If you have a y-splitter merging the Left and Right outputs and are plugging those into your L2t mono balanced input, that will also sound like trash, for the same reason as above.

 

I would have to agree with this conclusion. @wjernigan, have you tried it yet?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...