Jump to content
Sign in to follow this  
aadrianperezz

POD HD500X Display contrast issue (?)

Recommended Posts

Hello to you all,

I'm owner of a POD HD500X,  i had it since Christmas 2014. Still in excellent physical hardware conditions, majorly home-use.

I've notice something very peculiar throughout the years, and is that the display has loose some "contrast" from its original parameters.

 

For better understanding I attached a video showing what I'm referring to.

In essence, the default LED CONTRAST parameter in the setup page 2, which is 28, On my POD doesn't look that great. Nevertheless, when you set it on the 40-45 range looks really great.

Obviously I didn't perform a Factory Reset and no luck. 

 

I know some of you are maybe thinking "if your display looks great by just adjusting the LED contrast, whats the big issue here?"
My question: It's not normal for a display present this rare behavior ¿its my display slowly "dying"?  ¿is it a progressive issue where possibly the LED set at 40-45, right now present goog quality in the future will look awful, as it did one with the default led constrast 28?

I'm not interested in spending on a new console unless this one gets faulty like a future bad display.

Thank you in advanced, 
 



 

 

 

 

Share this post


Link to post
Share on other sites

I don't remember what the default value is, but for sure since I bought my HD500 years ago I have chosen and set the screen contrast to 40 and I have never changed it.
For me it is the perfect setting and in all this time the image quality given by the screen has not changed.

 

Frankly, I am more concerned about the duration of all moving parts such as encoders, switches and potentiometers, which are more subject to wear ... in fact I have already had to replace some of them.

 

_______________________________________________________________________________________________________________________________________________________________________

All about POD HD500/X

help and useful tips

Share this post


Link to post
Share on other sites

Since my POD it's not being use for heady duty daily use  i'm not that concern about those potential issues. But I completely understand your concerns; in general the pod its not a console for easy repair or fix in hardware terms. In fact, that's the point of my concern, if my display damages I basically don't know how to find a solution more than use it like that with the pod editor (which could be annoying because you couldn't tweek on rehearsals or gigs) or buy a new multieffect. 

So basically I just want to know if some ppl have experience the same as me, and haven't get any further issues with their display.

Share this post


Link to post
Share on other sites

In case the POD display damages there are spare parts..

 

There is the official one "GC1286400FFWJ-B" 128x64 LCD Panel module

Line 6 50-02-0156 LCD Screen For POD HD500X

302748.jpg

 

or the same part directly from China

LCD Panel 12864B

 

_______________________________________________________________________________________________________________________________________________________________________

All about POD HD500/X

help and useful tips

 

Share this post


Link to post
Share on other sites

Wow Thank you very much, I didn't know about this page of replacement parts! I just had a breath of fresh air. I'll keep this link while hoping my current LCD does not die haha.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...