Jump to content
jucbes

HX Stomp + Mac + Logic Pro X latency issue

Recommended Posts

Hello,

 

Disclaimer: I'm a recent owner, and a total newbie in modellers, USB recording, DAW, etc.

 

So, I have a Mac Book Pro 2015 running Mojave and installed Logic Pro X (3 month trial, nice), connected the Stomp and got some recording done pretty quickly. Pretty cool!

I use the Stomp as input (duh), I set the output to system setting, then I have headphones connected to the Mac to listen to everything (usually I just do silent recording in the evening).

 

Now the issue. Frequently, while I'm playing over a recording, layering stuff, very suddenly the latency jumps a lot. And I'm talking 1, 2 or even 3 secs latency. The latency applies only to the input guitar signal, whatever is already recorded is fine. I need to restart Logic to fix it. Until next time.

 

Any hints to avoid this issue?

 

Also, about Helix Mac driver, could it help with this? Should I install it? Or that is just for macOS/OSX versions older than Mojave?

 

Thanks in advance!

 

Share this post


Link to post
Share on other sites

You should use the headphone output of the stomp to avoid latency in my opinion.

 

  • Like 2

Share this post


Link to post
Share on other sites

Ideally, you choose one device for I/O. I know Apple lets you aggregate audio hardware, but if you want to maintain as much consistency as possible, you should have all your I/O on one piece of hardware. 

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites

Yep, everything said above. When the Stomp is connected to your Mac, it *becomes* your sound card, and if you want all the benefits of using it, you should not be listening through any of your built-in ports on your Mac. Also, I don't know how this is done in Logic, but in general with DAWs there is a way to turn on/off software monitoring for an audio input. When using your Stomp, you also want that to be OFF, or else you'll hear the direct hardware-monitored sound doubled with the software-monitored sound, which will usually have a small delay and make things sound odd. When configured correctly, you'll hear your guitar signal with no perceivable latency, and after you record something, it should all be aligned in sync with everything else in Logic.

  • Like 1

Share this post


Link to post
Share on other sites

Well, you are all absolutely right indeed!

I switched the output to the Stomp, and connected my headphones to it instead. I've been recording for 2 hours now without a single hiccup.

Thank you very much!

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, qwerty42 said:

When using your Stomp, you also want that to be OFF, or else you'll hear the direct hardware-monitored sound doubled with the software-monitored sound, which will usually have a small delay and make things sound odd.

It happened exactly like you said. There's an "input monitoring" toggle on each track, was a quick fix. Thanks for the tip.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...