Please ensure Javascript is enabled for purposes of website accessibility Jump to content

HX Rack "No device conected" - again !!!


Recommended Posts

I'm a user of Helix Stomp and Helix Rack. Stomp has never been a problem. I bought Rack used in January with very low firmware. It was difficult to communicate with the computer, but in stages it was updated to 2.8.2. After the last update, I don't remember if I used the editor. I mainly use Stomp. When I downloaded last 2.9 software, Stomp updated smoothly. When I tried to update Rack, it turned out that Line6 software can't see him. The software always shows "No device conected" or "Select device do update" but without displaying the option to select any device.

I have repeatedly done Helix's Global Reset and all other possible encoder combinations in the Rack. MANY TIMES !!!

Helix Control was always off. Stomp works, but Rack doesn't.

I tested 4 or 5 USB cables, including those through which my HX Stomp easily connects to the computer.

Everything connected directly without any HUBs to all possible USB ports. I tested my Helix's on 3 different computers with WIN 10 and WIN 7. Intel and Radeon. One computer was straight from the store. The other was never used for music. My main music computer works with various software and hardware without any problems.

I have removed the software (Edit & Updater)  and drivers many times. I used CCleaner and Windows tools. I searched and removed registry problems.
I found and manually removed from Win/System32 even old drivers for POD X3.
Over the past few days, I installed 3 versions of HX Edit (2.71, 2.82 and 2.91) on these 3 computers. Alternatively, I have also tried installing drivers and updater separately.
Many times !!! Everything in different order. Alone and as an update.
Run as Administrator.
After each installation and cleaning, I restarted the equipment.

Device Manager never doesn't show problems.

I have disabled the antivirus program.

I even registered my Helix Rack and .... nothing.
All the time, I can't edit him or upgrade or downgrate. The computer never sees my Helix Rack.

After connecting Stomp immediately appears in the "Devices and printers" panel, but Rack is not visible there anytime.

My other music programs load
Helix Rack drivers, but when I try to set it as an interface in GR5 or Ableton, I get a message that Rack is "not present". Stomp under them work smoothly and immediately installs his drivers.

I have read many similar stories in this forum, but I didn't know the advice that would fix my problem. HELP !!! I'm angry, frustrated and after years I think about abandoning Line6 products !!!
Link to comment
Share on other sites

  • 2 months later...
10 hours ago, glc666 said:

Hi, I have the same problem. Do you resolve? My helix floor is not connected


Sometimes I had the same problem after an update.

What works for me:

Uninstall all line6 stuff and reboot the computer.

Then check in the Windows device manger for hidden devices and uninstall all unnecessary drivers from USB sticks and USB hard drives,...

(To many loaded drivers can sometimes cause problems on a USB port) But don't delete any important system drivers!

Reboot again and install HX Edit  - When you get to the options section of the install, leave them all checked.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...