Jump to content
andrewj_gomez

Helix Floor won't power on right/not working

Recommended Posts

So randomly today, my Helix will not power on. I turned it on and the usual Helix splash screen came up, and then a few seconds later it looked all warped/glitchy, and then there was nothing but a blank screen (see pic attached). I just got this/registered it in February and opened a support ticket. Anyone else have the same issue or anything similar? I realllly don't want to have to buy another one, and hope Line6 can fix/replace this unit!

 

-Andrew

IMG_0457_2.jpg

Share this post


Link to post
Share on other sites

IMO... if this is new, just ask for a replacement. 

 

Here are a couple things you can try.

  • Do I see two XLR's plugged in the back? Disconnect those and see if the unit starts consistently. This is not a fix, just a troubleshooting measure.
  • Try a different outlet.... maybe (big maybe and doubtful) the Helix is just starved of power
  • Try a full reset.... (hold FS 9 & 10 during startup). You will loose all of your presets, IR's etc.... so I hope you have a back up. 
    * If it randomly starts up at this time.... try and perform a full BACKUP prior to doing the full restore. 
  • Failing that... try to update/reload the firmware. You will have to start the Helix in update mode by pressing FS 6 & 12 during startup then follow all instructions for updating. 

If none of that works, the unit definitely needs service. Again.... if its under warranty, that is what warranty is for. 

Share this post


Link to post
Share on other sites

I got it from a friend in a trade. He bought it last year and only used it twice (wasn’t his cup of tea). He provided me the original receipt and I registered the hardware on my line6 account. It says I have basic warranty for a couple years.

Share this post


Link to post
Share on other sites

Submit a Service Ticket with Line 6 and they'll get you fixed up.

Share this post


Link to post
Share on other sites
22 hours ago, andrewj_gomez said:

So randomly today, my Helix will not power on. I turned it on and the usual Helix splash screen came up, and then a few seconds later it looked all warped/glitchy, and then there was nothing but a blank screen (see pic attached). I just got this/registered it in February and opened a support ticket. Anyone else have the same issue or anything similar? I realllly don't want to have to buy another one, and hope Line6 can fix/replace this unit!

 

-Andrew

IMG_0457_2.jpg

 

Mine just died for no reason. One day it wound not power on at all. Did all the troubleshooting I could without opening it up. Wish I knew what caused this. It has never been moved and I have used it the same way since it was purchased.

 

Still waiting for service center to open up from Covid-19. Line 6 sent me a loner just as every thing was shut down.

Share this post


Link to post
Share on other sites

I’m glad no gigs are happening right now, but I do use this for studio work a couple times a week at least. I hope they can send me a in it ASAP, even if it’s a loaner, so I can get back and running ASAP.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...