Jump to content

My solution for GX/UX2/UX8 distorted sound on Win10

Recommended Posts



I was getting distorted sound on my GX, UX2, and UX8 that so many others have described in this forum using Win 10 and a Cherry Trail tablet. It would seem to play at the wrong sample rate and sounded like some bad 8-bit Atari video game noise. This may apply to those with a Surface tablet too.


In my case the problem was with the Microsoft Driver for the "Intel(R) USB 3.0 eXtensible Host Controller".


Unfortunately Intel discontinued drivers and let Microsoft take over since Win 8.


I downloaded the Intel driver for Windows 7, disabled driver signing and edited the .inf to make it work with Win10.


After installing the old Intel drivers my Line 6 devices are working properly even through external USB hubs.

  • Like 1
Link to comment
Share on other sites

On 6/9/2020 at 5:02 AM, Dune_uk said:

I’m having a similar problem, can you share the driver? 

Before attempting this procedure make sure that you have this same controller on your system.

  1. Open Device Manager and expand "Sound, video and game controllers"
  2. Highlight the Line 6 device
  3. At the top of Device Manager in the "View" menu select "Devices by connection"

This will show you a tree where your USB device is connected so you can find your USB Controller. For me the tree was:


ACPI x64-based PC

Microsoft ACPI-Compliant System

PCI Express Root Complex

Intel(R) USB 3.0 eXtensible Host Controller


The driver can be found at https://downloadcenter.intel.com/download/22824/Intel-USB-3-0-eXtensible-Host-Controller-Driver-for-Intel-8-9-100-Series-and-Intel-C220-C610-Chipset-Family

After extracting you will want to edit iusb3hub.inf and iusb3xhc.inf (located in \Drivers\Win7\x64 if you're on 64-bit) as follows:


Replace this text

Intel(R) Corporation = Intel, NTAMD64.6.1, NTAMD64.6.2


With this

Intel(R) Corporation = Intel, NTAMD64.6.1

Then restart with the Disable Driver Signature Enforcement option (hold shift when selecting restart/Troubleshoot/Advanced Options/Startup Settings/Restart/Option 7)


Manually install the driver in device manager (right click Intel(R) USB 3.0 eXtensible Host Controller/Update driver/Browse my computer for driver software/Let me pick from a list of available drivers on my computer/Have Disk...)


Let us know how that goes or post your USB Controller if it's different.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

  • 4 weeks later...
  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...