Jump to content

Recommended Posts

I bought a new helix in Oct 2016. I never had a computer to upgrade the soft/firmware until a few days ago (MacBook Pro). My Helix is only ver 1.06.5. 

I've installed the updater but only get a black page when it asks for me to choose a device. I haven't a clue what my next step might be. 

I've also created a number of my own patches in the last four years that I'd rather not lose if possible. 

Can anyone recommend any video I can watch or articles I could read etc, that would certainly be great. My tap tempo for example has never worked since the day I bought it.

Thanks for your time! 

Brad at Nevin Park

 

 

 

Share this post


Link to post
Share on other sites

Read and follow the installation instructions that are posted with the latest HX Edit software, v2.92.

 

Note the introductory comment highlighted in red text at the beginning of these instructions. And note that I haven’t really done so (well, maybe a little bit by saying this)!

Share this post


Link to post
Share on other sites

Ok, I’ve got HX Edit installed and I’m signed into my account but I’m only getting a red “connection interrupted” at the bottom with reconnect not connecting. 
This now my current sum knowledge of how this might work. Thanks though. 

Share this post


Link to post
Share on other sites

Some troubleshooting for USB connections:

- try a different cable

- try different USB connections on your computer.

- avoid using a hub

Share this post


Link to post
Share on other sites

It’s direct, so I’ll hunt for another cable. I do appreciate your input. Thanks again! 

Share this post


Link to post
Share on other sites

Have you tried using different USB ports on your computer? That's more likely to solve the issue; less likely but still possible is a faulty cable.

Share this post


Link to post
Share on other sites

I have two on either side of the new MacBook Pro and have tried both to no success. I only have one usb cable with the square connector on one end that I’ve used for a number of years for my midi controller kbd. I’ll go and get a new cable tomorrow and see if that works. 
 

thanks for checking in!

I’ll let you know if that works tomorrow evening sometime. 

Share this post


Link to post
Share on other sites
7 hours ago, nevinpark said:

Ok, I’ve got HX Edit installed and I’m signed into my account but I’m only getting a red “connection interrupted” at the bottom with reconnect not connecting. 
This now my current sum knowledge of how this might work. Thanks though. 

I just want to check something....

 

When you installed HX Edit did you install all the listed components, especially the drivers?

Share this post


Link to post
Share on other sites

Well, I chose the install. I didn’t see anything about drivers etc. Oops? 

Share this post


Link to post
Share on other sites

It ‘installed successfully’ it told me. Come to think of it, the Helix Floor was recognized and it is a four year old unit that’s never been tweaked, so it is connected in a way, just not following through. I never thought to look for drivers. Hmmmm. 

Share this post


Link to post
Share on other sites

Loaded the available driver, danced with the new security install and it’s loaded. Still get ‘connection interrupted’. Picking up alternate USB cable tomorrow sometime. I’m discouraged. 

Share this post


Link to post
Share on other sites

Here’s some more information. 
 

 

The release notes for v2.92 indicate that you can use HX Edit v2.92 to upgrade from any earlier firmware. The above says differently. Try following the above procedures.

Share this post


Link to post
Share on other sites

I've pretty much done all it instructs; latest HX edit, installed the latest driver etc. It's at step 2 #3 that HX Edit keeps saying 'connection interrupted' and that's where we stop.

Tantalizingly close, but no cigar.  

I bought a new usb cable today, tried both USB ports on the MacBook etc. The guy at the music store today thought there might have been a version of HX Edit a few releases back that have some components in it I don't have.....or something. 

 

It may be time to try to contact Line 6 and get a service ticket, or just effing call them. 

 

update: I just did a service ticket with Line 6. We'll see what we'll see I guess.

 

Thanks again!

Share this post


Link to post
Share on other sites

Dear Silverhead,

 

I thought I should let you know that my Helix issues have been sorted out. I needed to go waaay back and download the editor (ver 1.4) from 2016 before the Mac and the Helix would see each other. After that all went as advertised. Thank you once more for your kind assistance and time. I’m up to date!! 
Best wishes,

Brad at Nevin Park

Share this post


Link to post
Share on other sites

Glad to hear you’re all sorted out. Thanks for letting me know.

Share this post


Link to post
Share on other sites

Dear Silverhead,

 

I thought I should let you know that my Helix issues have been sorted out. I needed to go waaay back and download the editor (ver 1.4) from 2016 before the Mac and the Helix would see each other. After that all went as advertised. Thank you once more for your kind assistance and time. I’m up to date!! 
Best wishes,

Brad at Nevin Park

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...