Jump to content
Firewalker750

USB keeps disconnecting

Recommended Posts

Has the below issue been resolved with the Helix? Mine keeps disconnecting via usb on multiple computers. It's not noted in the known issues section of the latest update

 

In rare cases, Helix/HX devices can become disconnected from HX Edit. If possible, always connect your Helix/HX device directly to the USB port closest to your computer’s power connector. Never use any sort of USB hub, which may include the front USB ports on the front of towers.

 

I did do the usual troubleshooting, factory reset, etc. 

Share this post


Link to post
Share on other sites

I haven't checked but it sounds like this was a known issue in a previous release and is no longer noted. That suggests that it was fixed.

If you are having trouble, the most common troubleshooting steps are....

- try a different USB cable

- try all USB ports on your computer

- make sure you are using the latest Line 6 driver

- recycle the power on both your computer and Helix

Share this post


Link to post
Share on other sites

I think you should open a support ticket.

Share this post


Link to post
Share on other sites

I get disconnects from time to time as well, but strangely this happens only for HX Edit. I'm running Ableton as DAW and I never had issues with that programme. I guess it has to do with the HX Edit software itself and not so much with the USB cable or which port I'm using (I've tried different cables/ports also). FWIW, I'm running an old MacBook Pro with OSX El Capitan and the latest HX Edit software. I don't need to install a HX specific driver, just works out of the box. 

The disconnects are inconvenient indeed and it should not happen, but I've learned to live with it. Apart from the dropouts I'm also experiencing slow response from time to time. Not really helping you, but at least so you know you're not the only one having these kind of issues.

Share this post


Link to post
Share on other sites

What about your power settings?  Windows can have a lot set to sleep, especially on laptops.  I always set mine to 'High Performance'.  You can mine deeper for more settings.

 

https://imgur.com/a/ixfzEbY

 

EDIT: One test might be to see how long it takes for the USB to disconnect after not using it.  If it is consistent, and close to a set number of minutes such as 10, 15 or 30, then that would point to something going to sleep; meaning, that would point to a setting somewhere with a specific time.

Share this post


Link to post
Share on other sites

Power settings are good. Thanks for the tip though. 

 

We'll see how the support ticket pans out. 

 

Anybody have to send theirs away to get repaired for this issue? If so, how much did it cost?

 

 

Share this post


Link to post
Share on other sites

I've had this happen time to time... but I chalked it up to once I installed an external webcam on my desktop it started happening but not before that.  Are there any other usb devices you're using at the same time?

 

Sean Meredith-Jones

www.seanmeredithjones.com

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...