Jump to content

HX Native doesn't receive MIDI from host (Ableton 10)


huzzam
 Share

Recommended Posts

Hi all, I'm a new HX Native user, and long time HX Effects user.

 

I'm trying to get HX Native to respond to MIDI CC messages per the manual section "MIDI Bypass & Controller Assignment." For some reason, the plug in doesn't seem to receive any MIDI at all (the "MIDI In" light never flashes). HXN doesn't respond in "Learn" mode, and even if i manually assign a CC, HXN doesn't listen to CC changes. Other plugins (e.g. Soundtoys Echo Boy) do successfully receive & respond to MIDI messages. Is there something in HXN that i need to enable? The manual implies this should be working.

 

(I'm aware that I can hack together similar functionality by using automation parameters, but MIDI CCs supposedly should work, and would be much more fluid & quick to configure on the fly.)

 

Can anyone point me in the right direction?

Thanks in advance!

Link to comment
Share on other sites

  • 1 year later...

I'm sorry to report that I have not had success getting Helix Native to respond to automation changes sent from MIDI controller assignments on macOS 11.6 when Logic Pro X is run natively on the M1 processor. If you run Logic under Rosetta, then it works as expected. 

Link to comment
Share on other sites

  • 1 month later...

I'm trying Helix Native on Ableton 10 & Macbook 2012

Plugin Automation 

Simply Automation is OK (like all Plugin) but is "limited" to 16 Discrete controllers and 16 Switches. OK BETTER THAN Pod pro hd limited to 2 Midi CC and 9 switches....

With Ableton MIDI Mapping  it's easy to automate "HW Remote controller"->"plugin linear controller" ->"Helix effect parameter".

 

Midi CC

For Midi CC i've a "little" issue.. With manually assignment works...Midi learn doesn't work... (midi green light flash but doens't map...)

And... sometimes, on change preset, It losts assignment (example: overdrive "drive" param).

 

Anyway for ableton & Helix Native Midi CC Mapping, you need 2 Tracks:

  • Audio track with plugin helix (ok it's easy..)
  • Midi Track "always on" (no auto) with input source on midi controller (example Akai Lpd8) and output to Audio track | Helix Native. Be sure that on Ableton midi preferences your controller is set "ON in "Track input" e not only "remote input". Remote input is used only for first scenario (Plugin automation)
Link to comment
Share on other sites

  • 4 months later...

Helix Native in Ableton Live Not Receiving Midi Messages

I've spent countless hours working in MainStage and can get things working with plugin automation (add a button, map midi from controller to button, assign that button to toggle Helix Native control).  What I would prefer is to just have Helix Native respond to the Midi messages as specified in the manual.  I realize that is impossible with MainStage because MainStage doesn't send midi to audio plugins so I decided to try Ableton Live Lite since midi can be routed to plugins.  Unfortunately I cannot get the midi message light in Helix Native to light and respond to midi.

 

MacBook Pro 14" M1 Max

macOS Monterey 12.1

Ableton Live 11.1 Build: 2022-01-27_9922074e99

Morningstar MC8 Firmware v3.9.6

Helix Native v3.15

  • I can verify that midi is being received from my Morningstar controller.  I see it light up all the correct places in Ableton to indicate that midi is being received.  
  • I have tried rebooting
  • I have tried trashing Helix Native prefs in the `/library/Application Support/Line 6/Helix Native` directory
  • I have tried both the VST3 version of Helix Native as well as the AU version of the plugin.

 

Here's the setup I "think" should work:

 

Midi Config: I don't think Remote should be necessary, but I may use the controller for automations so I left it checked.

image.png.2b876f9d7f00c9c2ee170056794d51ed.png

 

My midi channel configuration

image.png.4eb2fa57a7a4c4c24f72e5255211b733.png

 

Audio channel config.  Includes my instrument in and the Helix Native plugin.

image.thumb.png.698420551fb915de316b74ed00f64c72.png

Link to comment
Share on other sites

Well.  I lucked into the solution.  I hate giving up when it seems like something should work.

 

To get Helix Native to receive midi messages in my setup as described above, I had to RIGHT CLICK on the Helix Native plugin title bar and check
"Enable MPE Mode".  Now the "Midi In" lights up when midi is sent from my controller.

 

1644363893_ScreenShot2022-03-01at3_02_51PM.png.a918ef419b604cd37172a64617594980.png

Link to comment
Share on other sites

On 3/1/2022 at 12:06 PM, eagecl said:

Well.  I lucked into the solution.  I hate giving up when it seems like something should work.

 

To get Helix Native to receive midi messages in my setup as described above, I had to RIGHT CLICK on the Helix Native plugin title bar and check
"Enable MPE Mode".  Now the "Midi In" lights up when midi is sent from my controller.

 

1644363893_ScreenShot2022-03-01at3_02_51PM.png.a918ef419b604cd37172a64617594980.png

I don't see Enable MPE Mode in Reaper. :-)  That's the problem, Native is the same across all DAWS, pretty much.  And your midi controller setup is pretty much the same.  But the plumbing to get it to work is considerably different DAW to DAW.

Link to comment
Share on other sites

  • 4 weeks later...

Agreed.  It's really frustrating.  I have a feeling it's less about Helix Native though and more about Ableton.  Still, more guides would be helpful.

 

By the way, as part of my troubleshooting process I downloaded Reaper and it was the easiest to get working and verify that Helix Native was in fact capable of seeing midi messages from my controller.  MainStage was a no go, Ableton seemed like it should work, but mysteriously wasn't.  Reaper just worked.  Unfortunately I don't care much for the interface and Live wound up being a better fit.

 

That being said, I've run into some other head scratchers with Ableton Live that I've had to find some creative workarounds for so it's not perfect.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...