Jump to content
soundmodeler

Using Helix cab sims causes buzzing in PowerCab

Recommended Posts

Hi,

 

When I use the Helix’s cab sims through my PowerCab 112 Plus, I get a lot of low-end buzzing, especially when the volume or drive is raised. I've got the PC in FRFR mode and I’m connecting with a Line 6 cable. I’ve done some EQ tweaking, but the problem remains.

 

Using IRs loaded in the Helix - checking to make sure Helix cabs are turned off - or the speaker selections in the PC itself doesn’t produce any buzzing at all. So I guess the PC speaker itself is okay. I ran the Helix through my combo amp, using just the power section, to see how the Helix amps/preamps interact with a different speaker. No buzz.

 

So the buzzing only happens when I use the Helix cab sims through the PC, but I can’t think of what might be causing it and why shifting to the PC speakers or Helix IRs (I don't have any IRs loaded in the PC) eliminates the problem. Does anyone have a suggestion? 

Share this post


Link to post
Share on other sites

Is it a physical buzzing, or a tone buzzing?

One of my PC212+ will physically buzz if I run a bass guitar through it and turn it up a little.  The other does not.  Seems like a loose cable or something inside is rattling on the speaker or cabinet.

Share this post


Link to post
Share on other sites

If it seems to be tone buzzing, my guess is that you're clipping digitally?  It could be clipping internally on the Helix, or into the PowerCab, or even in the PowerCab itself.

 

Put the "cursor" on the output block of the helix and view the new VU meters.  See how loud it is and turn down the output as needed.  Turn up the PowerCab to compensate if needed.  Try a limiter or compressor before the output so you can reduce peaks while still getting more volume. 

 

View the ring on the PowerCab while playing.  If it's clipping the input it will blink red each time.  Again, turn down the Helix, and turn up the powercab to compensate if you havee headroom.

 

If you are using any speaker sims or things in the PowerCab it could be clipping internally there instead.  You can edit the settings to turn down the digital volume in the PowerCab until the buzzing goes away.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...