Jump to content
DolurumMafikala

Pod HD 500X Win 10 Blue Screen (BSOD) fixed for me

Recommended Posts

Summary
Check the Pod HD ASIO driver is not performing Sample Rate Conversion without you being aware of it. Remove easy potential sources for stutter.

Background
I had been plagued by the commonly-reported Pod HD-related blue screens (BSOD) on my Win 10 desktop, particularly when working with my DAW, Reaper. I have reached a point where my setup is now stable. Over recent weeks I've had four recording sessions without bluescreens whilst maintaining a USB connection.

In this post I'm intending to document what I did, what was effective and what was ineffective. I see many frustrated posts about this issue. Sometimes people seem to be replacing or returning their Pod HD, which is a shame. I have not seen Sample Rate Conversion problems being talked about in the trouble shooting posts I read, so I hope this helps someone.

Workarounds or ineffective configurations I tried
- Ignoring USB and going direct to my other interface (as I have one). Obviously this works, but the sound quality did not seem as good as the USB connection to me. I'm not saying I can hear the extra DAC/ADC step, but it's another spot where you have to get the levels right, and you need two cables if you want stereo. My other interface only has two channels and I wanted to keep a mic in the other one. So, if you are really stuck this works fine, but was not great for me.

- Disabled Selective USB Power Down. You will see other references to this step. It did not reduce BSODs for me on its own. I did leave this setting disabled in my final configuration, though, so it may be a factor.

- Using the rear USB vs the front USB. This does have some logic to it as the front USB ports on a desktop tend to be a hub, so if the rears are not then things have been simplified. Using a Rear USB did not make a difference for me.

- USB2 vs USB3. Simply swapping to USB2 was not enough for me, but I have continued to use a USB2 port in the stable configuration, so could be a factor. If you have USB2 ports available I think it make sense to use them, as the Pod HD was, I think, designed before the USB3 standard was introduced.

- Different combinations of allowing the Pod to be or not to be the audio device used by Windows as default made no difference for me.

- Disabling Windows System Sounds on its own made no difference for me, but I have continued to leave them off in the stable configuration, so could be a factor.


After trying those solutions I found the official Line 6 advice on USB troubleshooting here:

https://line6.com/support/page/kb/recording/computer-audio-set-up-and-troubleshooting/usb-audio-troubleshooting-r443/

and set about eliminating sources of stutter which seem to be less-well handled by the Pod HD driver stack when compared with the driver for my Focusrite Saffire 6 USB audio interface.

I noticed that Reaper was reporting that the Pod driver was operating at a 44.1 kHz sample rate, despite the Windows Sound Control Panel settings being set to 48kHz sample rate and Reaper being set to use whatever the hardware was using. Checking the Line 6 Audio-Midi Devices App confirmed the same thing, and the Sample Rate Converter light in that app was on. I went through all the parts of the end to end system where I could set the sample rate and made sure all were aligned to the same settings (48kHz, 24 bit). There are four places I checked and aligned:

1) Windows Sound Control Panel/Playback tab/Line 6 POD HD Device Properties/Advanced/Default Format -> Set to 24bit, 48000 Hz (Studio Quality)
2) Windows Sound Control Panel/Recording tab/Line 6 POD HD Device Properties/Advanced/Default Format -> Set to 24bit, 48000 Hz (Studio Quality)
3) Reaper/Audio Device Settings -> Request Sample Rate to 48000
4) On the Pod itself, under the IO settings there is a setting for the sample rate of the S/PDIF interface. This name suggests it has nothing to do with the USB output, but I made sure it was set to 48Khz too. Annoyingly, I can't remember what the default was, so I can't remember if I changed this.

After step 3 Line 6 Audio-Midi Devices App now reports no Sample Rate Conversion happening and Reaper also reports 48kHz operation.

I also shut down some unnecessary audio-using apps (Skype, Google Music Manager and Steam) and removed the Windows System Sounds. I felt these were easy and prudent steps to take. I felt from the Line 6 article the general advice was to remove sources of noise and stuttering, so where I could remove potential sources easily for me I did so.

I did not at any time remove my existing Focusrite Saffire 6 USB interface and its driver, so in my case at least the Pod is able to co-exist with other ASIO drivers. Note that the Focusrite wasn't being used as Reaper doesn't provide the option to use two ASIO devices at the same time, but was plugged in and powered on.

I have not taken the time to isolate the single factor that has made a difference for me, however the BSODs did seem to clear up once I had got the Pod ASIO driver operating in 48 kHz sample rate instead of doing Sample Rate Conversion. I don't yet know why it was stuck operating at 44.1 kHz, as nothing before or after it was asking for that and I had not changed defaults. Furthermore, when I was trying to force it back to 44.1 to isolate the fix for this post it stubbornly refused to return to that rate. At this point I have arrived at a stable setup for me so I am unlikely to spend more time characterizing the cause, but will report back if I find something. I'd say it is likely others have this problem as I don't change defaults for this sort of thing.

Effective Configuration
- Disabled Selective USB Power Down
- Disabled Windows System Sounds
- Shut down unnecessary apps that use audio
- Ensured Windows Sound Control Panel properties for Playback and - Recording on the Pod are set to 24bit, 48000 Hz
- Reaper/Audio Device Settings -> Request Sample Rate to 48000 (key step for me)
- Using front panel USB2 port

I am sure not all of these steps are quite necessary for me, but wanted to share as completely as I could.

General guidance, summary observations and speculations

Clearly, reading the official advice at https://line6.com/support/page/kb/recording/computer-audio-set-up-and-troubleshooting/usb-audio-troubleshooting-r443/ is good practice.

I've internalized that article as "you have to be as kind to the drivers for the Pod HD as you can". For me that meant getting over a Sample Rate Conversion that was happening, which I speculate takes extra cycles in the driver stack, introduces more potential error conditions and makes it more susceptible to stutter conditions. I am not sure why the driver was choosing to operate at 44.1 Khz instead of 48 Khz, but I have been able to force it to 48 Khz operation with Reaper. Removing unnecessary Sample Rate Conversion feels like good practice in any case.

Getting the USB connection stable has been a big plus for me. The clarity of my recordings is better, I have stereo, so things sound fuller, it is easier to set levels and hear changes. It makes me feel like I need Helix Native less. Happy days :-)

DM

Share this post


Link to post
Share on other sites

I have passed the BSOD win 10 and I can do the recording smoothly on my daw ,,,,,,, but there is one thing that still fails, namely I cannot listen to the sound from the video player that is played without going through my daw

Share this post


Link to post
Share on other sites

Hi, Have you changed the Windows Playback Device to the Pod? If you click the speaker icon in the bottom-right of the screen in Win10 you can select the Pod there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...