Jump to content
TheMaGotT

Activating/deactivating split per snapshot?

Recommended Posts

I have a problem with my helix that's been bugging me for weeks and which I can't seem to solve by myself.

 

I use the helix for rehearsing with my band and have a patch for every song, with the snapshots being controlled via midi. My clean tone has a split in it, where I have a clean signal with only amp, ir etc. in path A and the reverb and delay on path B. The reason for that is that I like to heavily EQ those (I have a high cut set to 2.0khz because I like the effects to be rather mellow and dark and feel like that without EQ, they are way too bright), but don't want those EQ settings on my general guitar tone. 

 

Now, since I only need the split for the clean tone, I'm wondering about what to do with said split for the distorted tones. Even with all blocks on path B turned off, I still have two (identical) signals going into the merge block, which would make the tone more muddy I suppose? Correct me if I'm wrong. I could just turn down the volume down for path B, but that affects the volume of the tone in general (it is louder when I simply delete the split) and doesn't seem to be the ideal solution.

 

Isn't there a way to decide for each snapshot if the split is active or ignored? There does seem to be a power button on the switch block, but when I turn it off, I still have two signals going into the merge block, so I guess all it does is deactivate all blocks on path B. 

 

Does anyone have a solution for this? Any help is very much appreciated 

 

(tldr: what I basically want is that when I have a clean snapshot, the split should be active and when it's a distorted snapshot, the signal should simply go from input to output, completey ignoring the split and path B).

     

I attached a screenshot of the rhythm and clean tone for one of my patches.

 

Screenshot Rhythm.png

Screenshot Clean.png

Share this post


Link to post
Share on other sites

Try making the split an A/B split. For your cleans set the mix in the center so each path gets the same amount of signal; then, for your rhythm tone set it to 100% A so that no signal is sent to the parallel path. You can snapshot enable this split block.

 

Should work ...

Share this post


Link to post
Share on other sites

Try the attached example preset. The the "B Level" switch ON you get both paths. OFF is Path A only. The trick is in the Mix Block.

 

 

EDIT: I forgot you wanted snapshots. Here it is with snapshots.

TheMaGotT.hlx

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...