Jump to content
Hatman777

Wah Pedal Issue

Recommended Posts

Hello All So another Noob Question

As i assign a Wah to first Block then I use My pedal to Control the Wah Nothing happens

My setting is  EXP1 which is somewhat greyed out and when i use the EXP pedal it shows % value instead of showing EXP1 greyed out 

Now i tried Assigning the wah to separate PEdal and still nothing is there a setting In global that needs to be activated ? 
i read about that if you press hard on the toe it switches something ive tried pressing really hard and nothing happens

 

thanks all for any help or guidance 

Share this post


Link to post
Share on other sites
13 hours ago, Hatman777 said:

thanks all for any help or guidance 


Helix 3.0 Owner’s Manual - Rev E - English 
Page 8 

 

Expression Pedal Move the expression pedal to control volume, wah, or a combination of amp and/or effects parameters. Activate the hidden toe switch to toggle between EXP 1 and EXP 2. (The scribble strip above tells you which one is active.) If an external pedal is connected to the rear panel EXP 2 jack, the built-in pedal becomes EXP 1 only.—see “Controller Assign” (Page 53j etc. 
 

plus page 66 re EXP 1, 2 and 3 position

 

Determines whether the Helix expression pedal positions are recalled per snapshot, per preset, or applied globally. If you want a Volume Pedal or Wah to maintain its position when switching presets, set this to “Global.”


Could be worth browsing through.

 

Or, reset your Globals from the backup file you made with HX Edit.

 

Hope this helps/makes sense.

Share this post


Link to post
Share on other sites
9 hours ago, datacommando said:


Helix 3.0 Owner’s Manual - Rev E - English 
Page 8 

 

Expression Pedal Move the expression pedal to control volume, wah, or a combination of amp and/or effects parameters. Activate the hidden toe switch to toggle between EXP 1 and EXP 2. (The scribble strip above tells you which one is active.) If an external pedal is connected to the rear panel EXP 2 jack, the built-in pedal becomes EXP 1 only.—see “Controller Assign” (Page 53j etc. 
 

plus page 66 re EXP 1, 2 and 3 position

 

Determines whether the Helix expression pedal positions are recalled per snapshot, per preset, or applied globally. If you want a Volume Pedal or Wah to maintain its position when switching presets, set this to “Global.”


Could be worth browsing through.

 

Or, reset your Globals from the backup file you made with HX Edit.

 

Hope this helps/makes sense.

 

 

Yes Thanks Datacommando, will try that  out for sure 

  • Upvote 1

Share this post


Link to post
Share on other sites

My tip: it really requires quite a forceful press on the toe to invoke the wah...for days I was just being too gentle with it, and was frustrated like you that I just couldnt get it to work. Then in anger I really toed it hard and then it all worked. YMMV! 

  • Like 1

Share this post


Link to post
Share on other sites

I don't know if this has been mentioned but I believe the Wah is automatically assigned to EXP2 and the Volume pedal to EXP1. And the toe switch is automatically assigned to switch between 1 & 2. So if you saved your patch with EXP1 being selected, the Wah won't work. You'll have to step down on the toe switch to go to EXP2. Which is how I would want it anyway. I would want to start with the Volume pedal engaged and a press of the toe swtich to toggle between the wah and volume pedal.

Share this post


Link to post
Share on other sites

I thought I noticed something odd so I tested a theory.  

 

Backstory:  I think it may be probable I am unlike many of the folks who regularly participate here in that I do 99+% of all my editing work right on the unit.  I very rarely use HX-Edit to make patches or to edit them.  Mostly I use it for backing up my edits and for loading new ones.  That's because I use my Helix as a pedal board.  It's not a user interface for my computer.  It plugs into a guitar amp.  If I am editing, I want to hear what I'm doing in real time and I couldn't be bothered to go to all the work of dragging the amp and the Helix around and figuring out how to reconnect, etc.

 

What I thought I noticed was that a couple of the patches that I did modify using HX-Edit were ones where the wah worked as expected.  To test my theory, I connected Helix to the computer and used HX-Edit to remove and then reinstall the wah on one of my non-working-wah presets.  I reconnected to the amp and found it had worked so I banked through all of my patches to take note of the ones that the wah didn't work on and then connected to HX-Edit again and fixed them all the same way.  Now they all work.

 

Don't ask me.  I have no idea why.  I'm not a Helix expert.  I just use the thing.  It's probably some kind of global setting but I have browsed them all and didn't see anything that jumped out at me.  All I know is my  patches work now and they didn't before.  Maybe this will help the OP?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...