Jump to content
HonestOpinion

URGENT: 3.01.0 Firmware with bugfixes just released

Recommended Posts

Looks like a follow-up version of the the 3.0 firmware has been released with bugfixes. You should probably update your firmware to 3.01.0 before you start a new topic or post about a 3.0 issue. I don't see a new HX Edit for 3.01.0 yet. This is just a firmware update. At least for the moment.  As phil_m posted elsewhere, try using the "Check for updates" link at the bottom of HX Edit to do the firmware upgrade before you resort to using something like the standalone Updater. Worked fine for me.

 

Update: This topic somewhat redundant now as Line6Tony just put up a sticky. Apparently there is some urgency connected with this update as 3.0 can corrupt the audio(presets?), so do it right away! Also per Line6Tony there will be a Native update coming in short order as well.

  • Thanks 2

Share this post


Link to post
Share on other sites

Ya know, it just occurred to me if all my defaults and favorites are going to be wiped out and if so where are they saved in the backup??

Share this post


Link to post
Share on other sites
1 hour ago, DunedinDragon said:

Ya know, it just occurred to me if all my defaults and favorites are going to be wiped out and if so where are they saved in the backup??

 

Those should get backed up in the 'Create Backup' as well. There are new headings for them when you do a 'Restore From Backup'.  I would think it should only be an issue if you do a global reset anyway(never a bad idea).

Share this post


Link to post
Share on other sites

Yeah...I guess I could have just looked, huh?  But I was in the middle of installing the fix when it occurred to me.

Share this post


Link to post
Share on other sites

Are the new effects included in the HX effects? It shows that in the release notes, but I updated mine just now and don't see them. Not that I mind too much, there are already more effects to choose from than I care to look for haha.

  • Like 1

Share this post


Link to post
Share on other sites

Ha, never upgrade to a .0.0 major upgrade, always wait at least for the first bug update.  The rule looks like it applies again!

Share this post


Link to post
Share on other sites
1 hour ago, multimike said:

Are the new effects included in the HX effects? It shows that in the release notes, but I updated mine just now and don't see them. Not that I mind too much, there are already more effects to choose from than I care to look for haha.

 

Sounds like either you didn't upgrade your firmware to 3.01.0 or you did not upgrade HX Edit to 3.0.  You need to do both.

  • Like 1

Share this post


Link to post
Share on other sites

HX Stomp 3.01 firmware update installed easily using HX Edit 2.92.  Helix Native 3.0 has crashed my Windows 10/Ableton Live 10 Suite and the best I can do is use version 1.90 and that was a bear to get it to work.  HX Edit crashes with 3.0 but will work with version 2.92.  

Share this post


Link to post
Share on other sites
2 hours ago, DunedinDragon said:

Yeah...I guess I could have just looked, huh?  But I was in the middle of installing the fix when it occurred to me.

 

Been there!

Share this post


Link to post
Share on other sites

It's not working for me, I'm getting an error I've never seen before.  during Backup part of the firmware it says 

 

"Error occurred during the backup:

"Failed to open license. (code -1130)"

"Do  you want to retry"

 

I've never seen this before, I have no new IRs or patches in the last 5 updates over 2 years, and everything I do have is paid licenses.

 

there doesn't seem to be anything on the forums about this issue either.

1.jpg

Share this post


Link to post
Share on other sites
On 12/4/2020 at 11:17 PM, kringle said:

It's not working for me, I'm getting an error I've never seen before.  during Backup part of the firmware it says 

 

"Error occurred during the backup:

"Failed to open license. (code -1130)"

"Do  you want to retry"

 

I've never seen this before, I have no new IRs or patches in the last 5 updates over 2 years, and everything I do have is paid licenses.

 

there doesn't seem to be anything on the forums about this issue either.

 

Hmm, haven't seen this one. Looked this up with Google rather than the forum and it looks like it is some kind of general license server error. I would try rebooting my PC. Could be a corrupt preset perhaps. Try selecting a different preset before attempting your backup. If all else fails I suppose you could backup a bundle, your setlists, and even individual presets and use them to restore if necessary. Does your version of HX Edit match your firmware version? If not take care of that first. Btw HX Edit 3.0 is the match for firmware 3.01.0.

 

Another thing occurred to me and this is pure unfounded speculation. Do you have any presets purchased from the Line6 'Marketplace'. If so maybe their license server is trying to check them and because they may be slammed by too many users trying to update at the same time it is failing to acknowledge.

 

Anyone else seen this and know what the issue is?

Share this post


Link to post
Share on other sites

Thanks.. I played for a few minutes and I think it's the later... It's failing on things I purchased from Marketplace.    I figured it out by trying to small batch exports and basically anything from the Marketplace is failing... I deleted everything that had the golden pic next to it and the backup was successful... I haven't used them in the last year so probably won't miss em' and I always have an old backup in too.

 

and yes, I believe I'm all matched, I had no issues with the 3.00 update,  and I'm just bumping up to the urgent fix 3.01

 

also, I am logged into HX Edit and I could choose and play the marketplace items so they worked.. it only failed on the backup.

Share this post


Link to post
Share on other sites
5 minutes ago, kringle said:

Thanks.. I played for a few minutes and I think it's the later... It's failing on things I purchased from Marketplace.    I figured it out by trying to small batch exports and basically anything from the Marketplace is failing... I deleted everything that had the golden pic next to it and the backup was successful... I haven't used them in the last year so probably won't miss em' and I always have an old backup in too.

 

and yes, I believe I'm all matched, I had no issues with the 3.00 update,  and I'm just bumping up to the urgent fix 3.01

 

also, I am logged into HX Edit and I could choose and play the marketplace items so they worked.. it only failed on the backup.

 

Wow, my unfounded speculation may actually have been correct, grin.  First time for everything. If that indeed was the culprit then I would think that others that hit this just have to find a window where everyone is not updating there firmware at the same time and the Marketplace servers aren't too busy to ack.

Share this post


Link to post
Share on other sites
6 hours ago, guitarboy_02451 said:

Is there an update for HX Edit as well? Or just press on with pride on the 3.01 HX update?

 

No update to HX Edit.... this is just a firmware update. 

  • Like 1

Share this post


Link to post
Share on other sites

My update to 3.01went well but I had a bit of a false alarm. After the update, it looked like my Presets were still in place but they sounded awful. I Clicked on File>Restore From Backup.....  After the restore, the presets were fine. Later I turned the Helix off and back on. It said, Rebuilding Presets....  After that the presets sounded the same, which is good. I turned it off and back on again and everything worked as it should. 

I've only had my Helix for a week so I'm a rookie at this but I thought I my experience might help someone. 

Share this post


Link to post
Share on other sites

hello there !

impossible to download latest version of firmware (HELIX floor firmware v3.01).
From Firefox browser I get a "SSL_ERROR_RX_RECORD_TOO_LONG" error message and from Brave browser I get a " ERR_SSL_PROTOCOL_ERROR " ... my Win8.1pro can't find any solution...

using Line6 updater software is the same,  it makes an unknown error trying to download firmware


anyone can help ?

Share this post


Link to post
Share on other sites

Using HX Edit 3.0, connected to HX Stomp 3.0, it updated to 3.01 w/o issue. Accepted the Backup of 3.0 fw, and proceeded to installing 3.01. Then rebuilt Factory Presets, and to be sure, repowered the Stomp holding FSWs 2 and 3 to be sure everything (factory presets) updated and rebuilt properly. The entire process took less than 5 mins.

 

Later today or tmrw, I'll do the Helix Floor.

 

Hope it goes smoothly for all....

Share this post


Link to post
Share on other sites
17 hours ago, HonestOpinion said:

 

Sounds like either you didn't upgrade your firmware to 3.01.0 or you did not upgrade HX Edit to 3.0.  You need to do both.

Sigh...to think I would have learned by now...thanks!

Share this post


Link to post
Share on other sites

I updated to 3.0 on my stomp and experienced the new annoying "hum" that others have claimed to take issue with. I have just updated to 3.01. I backed up my presets, updated the firmware, restarted the stomp and did a factory reset to global settings. I then restored my presets from the backup. I've turned the stomp off and on again to allow for everything to configure. I still experience the hum and many of the patches either didn't populate, don't have sound despite blocks being present, or have moved to different numbers (for example: previous preset that was in 31A is now 34C). I've gone back and updated and restored a couple more times to see if anything would change. It has not. How can I get my unit to function properly at this point?

Share this post


Link to post
Share on other sites
3 hours ago, DrAShah said:

I updated to 3.0 on my stomp and experienced the new annoying "hum" that others have claimed to take issue with. I have just updated to 3.01. I backed up my presets, updated the firmware, restarted the stomp and did a factory reset to global settings. I then restored my presets from the backup. I've turned the stomp off and on again to allow for everything to configure. I still experience the hum and many of the patches either didn't populate, don't have sound despite blocks being present, or have moved to different numbers (for example: previous preset that was in 31A is now 34C). I've gone back and updated and restored a couple more times to see if anything would change. It has not. How can I get my unit to function properly at this point?


That reminds me of the song, "If I had a hammer..."

Share this post


Link to post
Share on other sites

Does anybody have any idea what this update is fixing specifically?

strangest thing happened last night. I have a clean/dirty amp rig and I was integrating the foot switch for dirty amp channel switching. 
I took care of the hum issue by clipping the ground on the FS cord. 
I then started having problems with the volume controls on the amp not engaging properly (like I could only hear preamp fizz), then the hard pans for each amp started feeding the other amp. Very strange stuff. 

Share this post


Link to post
Share on other sites
4 hours ago, DrAShah said:

I updated to 3.0 on my stomp and experienced the new annoying "hum" that others have claimed to take issue with. I have just updated to 3.01. I backed up my presets, updated the firmware, restarted the stomp and did a factory reset to global settings. I then restored my presets from the backup. I've turned the stomp off and on again to allow for everything to configure. I still experience the hum and many of the patches either didn't populate, don't have sound despite blocks being present, or have moved to different numbers (for example: previous preset that was in 31A is now 34C). I've gone back and updated and restored a couple more times to see if anything would change. It has not. How can I get my unit to function properly at this point?

 

One thing I might try at this point is taking backups and then trying to restore from an earlier set of backups if you have one, different than the backup you used for your most recent restore. Perhaps something got corrupted in your last restore but maybe the backup was corrupt. Once you get the preset thing straightened out another thing to look at is your global settings which may now be different than your previous settings.

Share this post


Link to post
Share on other sites

Has 3.01.0 been pulled already? I no longer see it on the Downloads page.

 

I already installed it, and it did fix an issue I was having with the HX effects, but a little curious as to why it's no longer available.

Share this post


Link to post
Share on other sites
1 hour ago, JackRabbit160 said:

Has 3.01.0 been pulled already? I no longer see it on the Downloads page.

 

I already installed it, and it did fix an issue I was having with the HX effects, but a little curious as to why it's no longer available.

What was it that the update fixed?  I too would be interested to know why the update has been pulled.

 

 

Regarding the use of backups....  I was prompted to do a backup when I installed this update.  I did so and when the update was finished, all routing and patches and such stayed the same as I routed them.  Nothing got funky at all.  I wonder why some of you folks are having a problem?  Can be frustrating for sure.

Share this post


Link to post
Share on other sites
5 hours ago, Michael_E said:

Does anybody have any idea what this update is fixing specifically?

 

Bug Fixes in 3.01

  • In extremely rare cases with specific blocks in a specific order, audio could become severely corrupted–FIXED
  • In certain cases, the Delay > Glitch Delay can exhibit minor pops and clicks when placed on Path 2, regardless of where its Smoothing parameter is set (that is, not the good type of glitchiness)—FIXED
  • Many other minor fixes and improvements
2 hours ago, JackRabbit160 said:

Has 3.01.0 been pulled already? I no longer see it on the Downloads page.

 

I already installed it, and it did fix an issue I was having with the HX effects, but a little curious as to why it's no longer available.

 

It hasn't been pulled... it's still available as a firmware update from the site for the entire HX Series of hardware (HX Effects, HX Stomp, Helix, Helix Rack, Helix LT)

  • Thanks 1
  • Upvote 2

Share this post


Link to post
Share on other sites
16 hours ago, JackRabbit160 said:

Has 3.01.0 been pulled already? I no longer see it on the Downloads page.

 

I already installed it, and it did fix an issue I was having with the HX effects, but a little curious as to why it's no longer available.

 

15 hours ago, Michael_E said:

What was it that the update fixed?  I too would be interested to know why the update has been pulled.

 

 

Regarding the use of backups....  I was prompted to do a backup when I installed this update.  I did so and when the update was finished, all routing and patches and such stayed the same as I routed them.  Nothing got funky at all.  I wonder why some of you folks are having a problem?  Can be frustrating for sure.

 

Let's not start any destructive narratives here. According to Line6 it is important to update to the 3.01.0 firmware for the the bugfixes contained therein. There is a big difference between asking for assistance to navigate properly on the downloads page and saying something doesn't exist. Don't mean to sound harsh. I suppose there is always the chance that the download was momentarily unavailable, although it seems unlikely. Just want to make sure no rumors get started that prevent people from updating.

 

Edit: (Thanks MusicLaw) Looks like if you select "HX Edit" from the '- All Software - ' dropdown menu it does not show the 3.01.0 firmware. You should just select the device, e.g. Helix from the '- All Hardware -' menu and your OS. My apologies to the users above. I can more easily see why they made the assumption they did if that is how they selected from the Downloads page. Line6 might want to consider changing this as MusicLaw suggested.

 

The 3.01.0 firmware is still available!

 

 

Share this post


Link to post
Share on other sites
14 hours ago, HonestOpinion said:

 

One thing I might try at this point is taking backups and then trying to restore from an earlier set of backups if you have one, different than the backup you used for your most recent restore. Perhaps something got corrupted in your last restore but maybe the backup was corrupt. Once you get the preset thing straightened out another thing to look at is your global settings which may now be different than your previous settings.

Definitely tried that as well when initially trying to troubleshoot it. 

Share this post


Link to post
Share on other sites

NOTICE:

If you browse to Line 6's Downloads page, to obtain 3.01 HX Edit, select your Helix Family Hardware Device in the Hardware dropdown field, and leave the Software dropdown at "All Software"!

 

As of a moment ago, if you leave the first dropdown selection at: "All Hardware" and select: "HX Edit" in the Software Dropdown field (regardless if the OS dropdown is left at "All OS" or "Win 10") the results page only shows HX Edit 3.0!! And, if you leave the software dropdown field at "ALL Software" the 3.01 flash memories for each of the Helix family units are individually displayed (long scrolling) and below them is still HX Edit 3.0.

 

Hopefully Line 6 will update their site tomorrow (Monday).

 

Also keep in mind that an updated new version of Helix Native (perhaps 3.01) is also expected very soon. 

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites
33 minutes ago, MusicLaw said:

NOTICE:

If you browse to Line 6's Downloads page, to obtain 3.01 HX Edit, select your Helix Family Hardware Device in the Hardware dropdown field, and leave the Software dropdown at "All Software"!

 

As of a moment ago, if you leave the first dropdown selection at: "All Hardware" and select: "HX Edit" in the Software Dropdown field (regardless if the OS dropdown is left at "All OS" or "Win 10") the results page only shows HX Edit 3.0!! And, if you leave the software dropdown field at "ALL Software" the 3.01 flash memories for each of the Helix family units are individually displayed (long scrolling) and below them is still HX Edit 3.0.

 

Hopefully Line 6 will update their site tomorrow (Monday).

 

Also keep in mind that an updated new version of Helix Native (perhaps 3.01) is also expected very soon. 

 

 

I don't see a problem with the way it works now. 

 

HX Edit stays at version 3.0, so if you choose to download only the software called hx edit, it'll only show you 3.0.  There is no 3.01.0 HX Edit.

 

If you choose All software, you get everything including firmware.  Firmware is not HX Edit.  HX Edit is just one (of two) ways to update the helix hardware series with new firmware releases, whether you download them yourself from that website or use HX Edit to download the fw update for you.

 

I see nothing to fix or change on the website based on what you described.

  • Like 2
  • Upvote 1

Share this post


Link to post
Share on other sites
54 minutes ago, donkelley said:

I don't see a problem with the way it works now. 

 

HX Edit stays at version 3.0, so if you choose to download only the software called hx edit, it'll only show you 3.0.  There is no 3.01.0 HX Edit.

 

If you choose All software, you get everything including firmware.  Firmware is not HX Edit.  HX Edit is just one (of two) ways to update the helix hardware series with new firmware releases, whether you download them yourself from that website or use HX Edit to download the fw update for you.

 

I see nothing to fix or change on the website based on what you described.

 

I see what you mean from a consistency standpoint but changing it would get more people migrated more quickly over to the 3.01.0 firmware. Line6 have implied that it is a very good idea to get up to 3.01.0 immediately. They want everyone on HX Edit 3.0 to upgrade to the 3.01.0 firmware. Setting up the download menu this way does not help accomplish that. Worth repeating though that for now, if a user is trying to find the latest firmware and editor releases for a device, just select the device. Don't select from the '- All Software -' dropdown menu.

Share this post


Link to post
Share on other sites

To update to Helix 3.0, first you have to update to Helix Edit 3.0 Software. To update from Helix 3.0 Firmware to Helix 3.01.0 Firmware, you should go to Free Software Downloads>Helix>Helix>GO and then proceed to get the firmware. Helix 3.01.0 Firmware has nothing to do with Software. 

Maybe "Free Software Downloads" should be changed to Free Update Downloads. Maybe "All Hardware" should be changed to "Hardware/Firmware".

Share this post


Link to post
Share on other sites
10 hours ago, DugT said:

To update to Helix 3.0, first you have to update to Helix Edit 3.0 Software. To update from Helix 3.0 Firmware to Helix 3.01.0 Firmware, you should go to Free Software Downloads>Helix>Helix>GO and then proceed to get the firmware. Helix 3.01.0 Firmware has nothing to do with Software. 
...

 

You make a good point. Anyway, most people will hopefully be updating to 3.01.0 through HX Edit 3.0 rather than using the Updater and downloading the flash/firmware file from the website.  Just appears that the way the Downloads page is set up while the editor, firmware, Native versions are out of synch has the potential to cause confusion. Already did.  I'm sure everyone will figure it out. Hardly a calamity.

Share this post


Link to post
Share on other sites
10 hours ago, DugT said:

Maybe "Free Software Downloads" should be changed to Free Update Downloads. Maybe "All Hardware" should be changed to "Hardware/Firmware".

 

Well imho no since the way they have it is pretty much the way most companies have it.  Like laptop companies... the line6 system is very similar to dell, toshiba, etc etc (well toshiba is out of the game now, but they were huge).

 

Hardware is for choosing what hardware you have.  Then there is software, which means anything you can download, for that given hardware.

 

Software technically includes both applications and firmware.  Arguably these days it also includes documentation since manuals went away from printed form.

 

I know I'm a geek, but since line6 is using the correct definitions of those terms, to me it makes perfect sense.  I think maybe you can't please everybody all the time :-)

 

Side note: I thought that this was how this downloads section looked a good 10 years ago when I played a variax through an xt live?  If so then it's been deemed "not a big problem" for quite some time now :-)

  • Upvote 1

Share this post


Link to post
Share on other sites
6 hours ago, donkelley said:

Side note: I thought that this was how this downloads section looked a good 10 years ago when I played a variax through an xt live?  If so then it's been deemed "not a big problem" for quite some time now :-)

 

Being new to Line 6 – but with a 30+ years experience in working on computers as a graphic designer, sound engineer etc. – the first time I came to https://line6.com/software ff. I thought "my goodness, what's this?!"

Line 6 desperately needs a qualified web designer. Not just a website programmer. (Vive la différence. ;)

  • Upvote 1

Share this post


Link to post
Share on other sites
On 12/7/2020 at 6:23 PM, lou-kash said:

Line 6 desperately needs a qualified web designer. Not just a website programmer. (Vive la différence. ;)

 

They obviously don't invest much of their resources to the software/web elements of their business.  

Share this post


Link to post
Share on other sites
3 hours ago, Drybonz said:

 

They obviously don't invest much of their resources to the software/web elements of their business.  

That's an assumption, but it's more likely that they aren't able to hire pros to focus entirely just on consumer facing web design and development from the ground up.  I don't always agree with their design choices (I hate pop-overs, specially when they overlay the login box LoL)... so I'm not defending the design as perfect by any means, and I'm not necessarily disagreeing with you per se.

 

It just doesn't mean they don't have qualified pros doing their website... I'd expect the consumer site is limited by technology, resource specialty and priority of budgeting.

 

If you 2 work in web development/design then you probably are aware that senior web developers/UX specialists tend to work on the web projects that are more application based and built from the ground up, where as consumer facing sites generally are designed/maintained by marketing staff using templating engines.  Graphics quality matters, but the design choices are often cramped by the lack off flexibility of the templating engine being used.

 

So I wouldn't jump all over them just yet.  However, their bread and butter is products for musicians - products that are supposed to sort of self-update and self-maintain, hence why they added the updating layer into HX edit long long ago instead of forcing you to use the line6 updater for such things.

 

So I'd think their serious developers and UX folks are more involved in the actual product design/development, not in the website.

 

Having them hire a $70k+ web UX designer (UX as opposed to graphics, two different skills), then hiring a full stack web developer to build the consumer site from scratch without a templating engine, would probably cost far more than they could budget for, just to make a few little things in the downloads section look a little different

 

It works fine - it's not going to make everyone happy all the time - but it's not a big deal for most people to wade through it as it is.

Share this post


Link to post
Share on other sites
28 minutes ago, donkelley said:

products that are supposed to sort of self-update and self-maintain, hence why they added the updating layer into HX edit long long ago instead of forcing you to use the line6 updater for such things

 

Fair enough, that's the way to go. Except that it still doesn't work as it should. (I'm looking at you, HX Edit, still incapable of updating yourself!)

 

30 minutes ago, donkelley said:

their serious developers and UX folks are more involved in the actual product design/development, not in the website

 

As it stands right now, the website is still part of the user experience. And this part of the experience is not good.

Heck, while Helix Native was on sale last week, I have decided to buy this "double-discounted" license to go along with my Stomp.

But I wasn't able to proceed with the checkout, being taken to https://shop.line6.com/customer/account every time with no info how to proceed!

Eventually I began to click on various parts of the page to see what happens. Coincidentally, after clicking on "Europe" at the bottom ("Worldwide" was active), I was finally taken to the checkout, being "allowed" to buy the software. D'oh.

 

38 minutes ago, donkelley said:

If you 2 work in web development/design

 

I'm a graphic designer by profession since 30+ years, with some experience and skills in HTML and CSS coding, as well as designing and administrating several Wordpress-based websites. So I definitely know that good interface design and good functional programming are two different things. You can write as an "elegant" and clever code as you want, but if your UX sucks, so will your website.

 

line6.com is not the worst site I've ever used, and after the few months on here I can get along quite fine. But it's full of small annoyances that are adding up and that may put many less "techy" users off.

Share this post


Link to post
Share on other sites

Do we know if the "miscellaneous bug fixes" (from the patch notes) includes the fix for the Rat pedal that they broke in 3.0?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...