Jump to content

Remove through on Poly Sustain


JulienVD
 Share

Recommended Posts

I'm trying to find a way to remove the "through" when using poly sustain (Using only one switch!!!)

 

Here's my patch:

 

Path A - Poly sustain -> amp+cab -> stereo effects -> L and R outputs (into monitors for the moment, two amps for live)

Path B - Volume block (just to create a "B"  path) -> Send (into amp)

 

That way, I get a Wet-Dry-Wet.  Great!!

Only thing is, I'd really like to remove my playing from Path A whenever I'm soloing over a drone.

 

I tried putting a volume block before the Sustain block to mute the sound going into path A.  That works great, but I need two footswitches. 

If I merge the volume block and sustain block to one switch, it turns the sustain block off at the same time as it cuts the live signal.

 

I know my issue might be "niche" but it's really the first thing I created with the Poly Sustain.

It seems obvious, really, to be able to mute the "through" signal when using the Poly Sustain with a unit capable of parallel paths.

(again: the issue is not really to be able to do it, but rather to do it efficiently with only one switch.  I made myself a patch where using two switches works fine.  But it's fiddly and uses a switch I'd rather use for something else)

 

Cheers!

 

Link to comment
Share on other sites

I'm not very good with the complicated routings and not having an image directly of what your doing vs what your trying to do leaves only the picture in my head...and thats a, very...very scary place sometimes, lol....

 

Could you reverse your A/B paths..what I mean is (no idea if this works or not, its slow at work and I wanna try and be helpful, lol)

 

Path 1  - splits at the beginning,   1A runs your preset sound you had on path 2 (if I read right?), path 1B runs to the end creating a 2nd output on path 1.  Path 1A is set to the XLR (your monitor outputs) and 1B would be sent to 2A.

 

2A would have your Poly Sustain path?  

 

Thus your splitting your signal before the sustain so it still sees the clean guitar input, but you can then mute or control the 'split' on path 1 to mute the input going to the Poly Sustain?  

Link to comment
Share on other sites

I do split before anything.

 

The issue might only exist on the Hx Stomp, which is what I have.

We only get two paths, A and B.

In my example, one path contains stereo effects, going to the L&R outputs

The other goes to "Send" -> real amp

 

Changing the blocks around from A to B or vice versa doesn't fix the problem.

 

 

Link to comment
Share on other sites

On 12/8/2020 at 4:14 AM, JulienVD said:

I'd really like to remove my playing from Path A whenever I'm soloing over a drone.

 

Assign the Route To parameter of Split A/B to the same Footswitch as the Sustain, with Min Route To: Even Split, and Max Route To: B100

 

Works for me, setting it up the same way as you did.

(By creating an Aggregate Device from Mac Built-in audio and Stomp, with Main Out going to my MacBook via USB, and Send Out via patch cable into the MacBook's line-in minijack. But technically it's the same routing as if going directly to separate amps.)

Link to comment
Share on other sites

9 minutes ago, lou-kash said:

with Min Route To: Even Split, and Max Route To: B100

 

… or whichever balance of your amps you need: you may need to experiment with how much signal goes where and when. You may even want to assign other Level parameters to the same footswitch for more complex balance between the amps.

Link to comment
Share on other sites

On 12/9/2020 at 11:41 AM, lou-kash said:

 

Assign the Route To parameter of Split A/B to the same Footswitch as the Sustain, with Min Route To: Even Split, and Max Route To: B100

That's great! 

Hadn't thought of that.

It's exactly what I was looking for!

Link to comment
Share on other sites

  • 5 months later...
On 12/10/2020 at 4:54 PM, JulienVD said:

That's great! 

Hadn't thought of that.

It's exactly what I was looking for!

I've got it an A/B split on the same button as the sustainer, but i think there's a timing issue where the A/B crossfade isn't quick enough to send the signal to the sustainer, so you end up with a very low gain capture. Been scratching my head but can't find a workaround. Any ideas?  

Link to comment
Share on other sites

4 hours ago, noisyneil said:

I've got it an A/B split on the same button as the sustainer, but i think there's a timing issue where the A/B crossfade isn't quick enough to send the signal to the sustainer, so you end up with a very low gain capture. Been scratching my head but can't find a workaround. Any ideas?  


This is where the new Mute All and Dry Kills options under the Operation parameter that was added to the Poly Sustain model in the 3.10 update comes in. It was added for this sort of thing. You put the Poly Sustain on the parallel path and rather than control the bypass state with a footswitch, you control the Operation parameter and set the Min to Mute All and the Max to Dry Kill. That way, even though the block is on, it’s not passing signal when Mute All is active (footswitch unpressed), the sustain effect comes through when you hit the footswitch while killing the dry signal.

  • Upvote 1
Link to comment
Share on other sites

3 hours ago, phil_m said:


This is where the new Mute All and Dry Kills options under the Operation parameter that was added to the Poly Sustain model in the 3.10 update comes in. It was added for this sort of thing. You put the Poly Sustain on the parallel path and rather than control the bypass state with a footswitch, you control the Operation parameter and set the Min to Mute All and the Max to Dry Kill. That way, even though the block is on, it’s not passing signal when Mute All is active (footswitch unpressed), the sustain effect comes through when you hit the footswitch while killing the dry signal.

Oh wow! In my existing preset those options weren't showing up, but I deleted the block and reloaded it and there they are! Thanks! I'm gonna experiment now. Muchas gracias!

 

edit: thought you had to keep your foot on the button, but somehow got it working perfectly! you're a hero!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...