Jump to content

HX STOMP - Making Mac freeze!


Magicon
 Share

Recommended Posts

Hello guys,

I hope someone sees this because I am at a loss as to how to fix this issue I'm having...

I recently moved into a new apartment and ever since my HX Stomp has been acting up. Almost every time I turn it off, my entire system freezes (kind of). This means: everything disconnects, all bluetooth devices are thrown out and my external HDD is disconnected (scary!!!). Essentially I causing me to have to hard-restart my Mac (Retina, Late 2015) via the Power-Button. I'm afraid the Stomp is gonna fry my system, is there anything I can do? Is this issue even known? I hope someone can help me because I really love my HX Stomp but I can't use it via USB if this keeps up...

 

Thank you in advance.

Link to comment
Share on other sites

Have you installed the Helix Driver v1.0.9, or are you plugging the Stomp in as is?

If no driver is installed, your Mac will switch to 48 kHz sampling rate when you plug in the Stomp. That might cause issues with some other 3rd party software.

For more info about the driver see line6.com/software and select "HX Stomp" + "Drivers" + "Mac OS X" as filters above.

Link to comment
Share on other sites

17 hours ago, Magicon said:

Almost every time I turn it off, my entire system freezes (kind of).


Hi,

 

Maybe if you shut down your Mac first, then turn off the Stomp.

 

Even though the majority of modern equipment is “hot swappable”, I have found that some computers are not happy to have external devices disconnect while they are still possibly communicating with them.

 

Just a thought.

 

Hope this helps/makes sense.

 

Link to comment
Share on other sites

14 hours ago, datacommando said:

I have found that some computers are not happy to have external devices disconnect while they are still possibly communicating with them.

 

That's why I was asking about the driver. I was having similar issues with the Stomp on El Capitan while initially having installed v1.0.9 driver. Downgrading to v1.0.7 fixed it, no problem since. On Mojave it might be exactly the other way round. At the moment I'm on the Catalina partition and there's no problem "hot plugging & unplugging", driver 1.0.9.

 

And then there's also the USB cable thing…

@Magicon, have you checked with different USB cables?

  • Like 1
Link to comment
Share on other sites

Hey! Sorry for not answering yesterday. I don't know if there's a new version, but yes. I have the driver (i can change sample rates)

This does work... (this is a luxury problem), but I hate having to turn off my Mac every time before I can use the USB slot again. - not really a fan of USB Hubs, but maybe I'm just paranoid.

I might update to Catalina someday, but I am unsure with some of my audio plugins. I might need them but they're strictly 32 Bit :(

I'll check it out with another cable!

Thank you guys for helping me! Hope this quoting stuff works, I don't usually go on forums for stuff like this.

Edit: Quoting didn't work haha, but I think you can tell who I am referring to.

  • Like 1
Link to comment
Share on other sites

1 hour ago, Magicon said:

I might update to Catalina someday

 

Don't hurry, unless you desperately need to run apps/services/devices that require Catalina.

I have installed Catalina on a separate partition since over a year – as well as Mojave, High Sierra and Sierra – testing this and that every now and then, recently testing mainly the various Logic 10 versions for each OS and their own respective quirks.

However, my "mission-critical" partition remains El Capitan. "It just works", as they say.

Link to comment
Share on other sites

1 hour ago, Magicon said:

not really a fan of USB Hubs, but maybe I'm just paranoid.


Stay paranoid!

 

Rule number one in Line 6 Helix world is “do not use a hub!” - Oh, that way madness lies!

 

You might want to check your cables and also check that you don’t have any other USB drivers that may cause a clash!

 

Here’s the very old USB troubleshooting tips from Line 6

 


Hope this helps/makes sense.

 

 

Link to comment
Share on other sites

On 12/24/2020 at 1:35 AM, Magicon said:

Okay. Now this is weird but I've noticed this lately. Sometimes it works. Right now the issue is gone and I had the same thing for a month or so, but then it came back. - that's why I'm writing here :)

 

One mac/usb problem I ran into is if I have HX Edit open & connected to my HX Stomp, and then turn off the Stomp, my entire USB system would reset, unmounting all my external drives etc such that I'd have to reboot.

 

My solution is to just make sure that I _always_ quit HXEdit before changing the power status of my Stomp:
Stomp on -> start Edit

close Edit -> Stomp off

 

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...