Jump to content
Sign in to follow this  
hichembell

DT50 loss in volume

Recommended Posts

Hello guys,

 

My DT50 lostS about half of its volume...i'm using it guitar straight into the amp.... It Used to be really really loud at home..(like a traditional tube amp) now the master volume is halfway  for bedroom practice (no it is in full power mode) Also the power tubes do not Get as hot as it used to be.. It used to really get hot but not anymore  any suggestions ?

 

I would like to precise that I previously changed the inside power transformer of the amplifier...it used to have a 220v model, yet since I bought the part from U.S only 110v was available. since electricity in our country is 220V I just use a 220vV o 110V converter before plugging  the amp. is it possible that this external converter is not feeding enough energy to make the amplifier loud as it used to be ?

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...