Jump to content

Here we go again .... (sigh...)


MGW-Alberta
 Share

Recommended Posts

I hate the hoops Line-6 makes you jump through.

There's gotta be a better way.

Fractal doesn't cause this much anguish.

 

Anyway ....

 

I went against my better judgement and decided to update to 3.01 from 2.82

I was perfectly happy with 2.82 but that damned acoustic sim was taunting me.

I connected the Helix Floor to my Mac (10.13.6) (USB 2.0 - direct, no hub) using version 2.82 and created a backup of my Helix.

So far, so good.

I updated HX-Edit to version 3.00 first and that was successful so I connected again.

Then from within HX-Edit 3.00 I checked for updates and clicked "Yes" when it asked if I wanted to update.

The update process began well enough so I walked away because I know it takes more than the "few minutes" the update tells you it will take.

I came back a minute later with a fresh cup of coffee and the Helix was frozen.

Small red letters:  "Update failed, entered update mode."

I've seen that error message before, a couple of times and I hate it.

I tried to close HX-Edit but it was frozen as well and it had taken my Mac hostage along with it.

I couldn't do anything else and I was forced to "Force Quit" HX-Edit.

First I double-checked the downloads page to make sure 3.00 was compatible with my OS and it is.

I rebooted Helix holding 6 & 12 to enter safe mode; screen says "Entered Update Mode".

I re-opened HX-edit.

HX-Edit does not find the device.

I've had this happen before too.

I uninstalled HX-Edit and reinstalled it.

At least it doesn't hang my machine anymore but it still fails to connect to the Helix and it does take about 15 seconds to close after failing to connect.

 

Is it a bug in HX-Edit?
Have I missed something?

What did I forget to do?

Pretty please ....

 

Oh, I forgot.  

I also tried the latest version of Line-6 Updater but that program won't run properly on my Mac.

It just freezes immediately after opening and besides, I'm pretty sure I read somewhere we don't do it that way anymore anyway.

I should probably uninstall that as  well.

Link to comment
Share on other sites

I'm not sure what hoops Line 6 is exactly making you jump through anymore. Everything is done with HX Edit now, but Line 6 Updater should still be working for you. The Fractal update process isn't really all that different as they have a separate update utility called Fractal Bot, which is analogous to Line 6 Updater.

 

Usually update problems come down to specific USB cables or USB ports being problematic. I'm not sure why Updater isn't running for you. It should be. Try uninstalling stuff and reinstalling, I guess. When you say you checked to see if 3.0 was compatible, did you actually download and install HX Edit 3.0? Many people assume HX Edit updates itself automatically. It does not. You need to download and install the latest version.

  • Like 1
Link to comment
Share on other sites

45 minutes ago, MGW-Alberta said:

I updated HX-Edit to version 3.00 first and that was successful.

Forgive me for quoting myself but I did say I updated to 3.00.

I wouldn't lie about that.

 

I have had people tell me in the past that it is the cable when I have had this issue of not connecting.

A number of times, actually.

I have the original cable that the device came with.

I have the cable that's connected to my printer that works every time I want to print.

Over and above those I have 5 addition brand new printer cables from different sources that have each been used one time because somebody insisted that just because a cable is new doesn't mean it's good.

One of those 5 is a very expensive "gold contacts" cable.

I'm not buying any more cables.

I'm done with that.

I connected to make a backup of my Helix so it's not a cable issue.

The thing that has changed since a perfectly good connection is the software.

Same as every single other time I have had this connection issue.

 

I will uninstall both programs again and re-install .... just so I can honestly say I tried it.

AboutHX-Edit.jpg

Link to comment
Share on other sites

random thought....I'm far from a tech, and far from knowing anything about Apple/Macs.......BUT, I had a program/device awhile ago (can't even remember if it was music related) but it had intermittent connection issues similar to what I've seen on here and for some reason reading your post reminded me of my experience.  Whenever I'd have this issue happen, I literally had to go into the Windows Device Manager and 'remove' something with the USB Port.  I dont remember if it was the driver, or if it was something else with the USB Port...But as soon as I did that, restarted, connected my mystery device, powered my mystery device on.....Windows would detect the 'new dvice' in the USB Port and install a driver automatically and it'd work great again.....usually until I restarted the cpu, unplugged the USB cable to use a different device or something...then I'd have to redo that process.   

 

If I remember correctly everytime I plugged in a new device...instead of just 'connecting' it was detecting a 'new  device' and essentially creating a 'new' USB Port in the device manager.  My laptop only had 3 ports....but sometimes when I'd do this I'd see 5 or 6 in the Device manager with the yellow ?'s on them....remove all of them, restart...etc....and issue went away.  

 

Again, not sure that applies to Mac/Apple stuff, and definately not IT trained here...Just thought I'd throw it out there.  It wasnt the cables or my device I was plugging in...

Link to comment
Share on other sites

Thanks Metal Kid but I doubt that's it.  Apple definitely has its own issues when it comes to USB but that's not one of them.  This biggest thing you have to get used to with Apple is that most devices (not the Helix) have to be "ejected" (on a software level) before you can physically eject them or else they may not be detected the next time you plug them in without jumping through a hoop or two.  The Helix has none of that, mostly because the computer doesn't see it as a peripheral device like a printer or external drive, etc.  It's not something the computer can connect to and use outside of the dedicated program (HX-Edit/L6UD) so it doesn't care if you yank it out or not.

Link to comment
Share on other sites

Soooo ....

I believe I have determined with certainty that cabling is not the issue and in my case it probably never has been, just as I've always suspected.

 

I uninstalled both HX-Edit and Line-6 Updater and then reinstalled both of them.

 

HX-Edit still refuses to connect.  It recognizes the Helix and tries to connect (thereby proving the cable is not the issue) but then it quits and says, "Not connected".

 

Line-6 Updater is a little more promising in that it connects and begins the update just as HX-Editor did the first time but then it encounters the same error and stops.

 

Below are the HX-Editor fails.

 

 

L6HXE01.jpg

L6HXE02.jpg

Link to comment
Share on other sites

I decided to try something.  

I uninstalled HX-Edit 3.00 and Line-6 Updater 1.19 and installed HX-Edit 2.80 and L6UD 1.17 to see if I could at least get back to my 2.82 installation.  

Same thing across the board.

HXE 2.80 will not connect; it sees the unit and tries but stops.

L6UD 1.17 will only connect long enough to begin an update and fail with the same exact error messages.

When I updated to 2.82 I swore it would be the last time I go through this utter nonsense.

I have had this thing for just shy of 4 years and I have never once had a problem-free update.

Using the system afterward is/was problem-free.

Now I can't use it at all.

 

I'm going to start a support ticket ... if I can remember how to do that.

Link to comment
Share on other sites

Since you are disgruntled that this is ALWAYS a problem.... then I suggest you look at your entire chain as a potential problem, not just the Helix. I see you have ruled out the "cable" as an issue... but I don't see mention of other important troubleshooting steps. Just because a printer prints.... that doesn't rule out other conflicts/issues. 

 

As a computer/IT tech.... I'll offer a couple suggestions that I don't see mentioned already.

  1. Remove all unnecessary peripherals from the computer.... this includes any printers, scanners, etc...
  2. Try connecting the Helix to a different USB port. There are reasons for this....
    • USB Ports are in pairs or groups within a computer... sort of like "internal hubs" for lack of a better description
    • If you are on the same "group" as a slower device (keyboard, mouse) then the ports slow down to their speed... often USB 1. This would seriously hinder an update process. 
    • The point of disconnecting everything else and trying other ports is to find a "grouping" that isn't shared. 
  3. Sometimes a USB2 device does not behave in USB3 (blue) ports. Try to find a dedicated USB2 (black) port if you have one. . If your only option is a 2nd USB2 port with a keyboard/mouse connected to the other.... try moving those to the USB3 port. 
  4. Always start each process (attempt) with a fresh reboot... might not help, but never hurts! 

 If it still doesn't work....  do you, or anyone you know have a PC you can try the update on? NO, you shouldn't have to.... but if your computer is the last "common denominator", you can't rule it out :) 

Good luck! 

 

4 hours ago, MGW-Alberta said:

I have had this thing for just shy of 4 years and I have never once had a problem-free update.


Yet I've had my Helix nearly 3 years... and have never had a single problem updating it :) 

Something more is at play.... whether it's a faulty Helix, or a conflict at your system. 

  • Upvote 1
Link to comment
Share on other sites

Thanks for your thoughts.  It is appreciated.  The following addresses your points:

 

1.  There are only two things that normally connect to my computer;  a printer (USB) and an audio interface (Thunderbolt).  Both are disconnected.  There is a small dialogue box that runs continuously in the background that is related to the interface (Apollo Twin Duo) which has been closed.  "Force Quit" shows that no other apps are open during my attempts except sometimes Safari but not every time.  Bluetooth has been turned off, which disables the only other peripheral, the MagicMouse.  Being a MacBook the keyboard is built in so no USB device to disconnect or relocate there.

 

2.  There are only 2 USB ports.   Both are 2.0.  One of them does seem to last longer than the other before disconnection occurs but they still both get tried.  Counter to the instructions in the update warnings, the port furthest from the power cable is the one that lasts longer, not the closest one.  My USB hub has been disconnected.  Different cables from my collection get rotated periodically.

 

3.   There is no USB3.

 

4.  Every try gets another Helix reboot.  The Mac has been rebooted several times as well.

 

 

 

I tried to search all my previous support tickets to read what worked each timebut apparently only the two most recent ones are still on file here.  I don't know what happened to the other two or three.  One of the remaining ones is related to updating.  That was for 2.82.  In that one the solution was to remove previous drivers from the system using a pair of commands in Terminal.  I tried the Terminal commands again.  No help this time.  The other ticket was for an anomaly where any time I touched the "amp" button on the Helix the unit would freeze and would have to be rebooted.  Support was unable to help me with that issue but it disappeared after the 2.82.

 

Some progress was made last night in the wee hours.  The red progress bar went halfway across.

 

I have an old Dell that has not been powered up in 7 or 8 years, which  runs Vista.  I suppose I could dig that out and try it.

  • Like 1
Link to comment
Share on other sites

USB port configuration, the sleep mode options for your usb host configuration, and so much more which are controlled by the OS, by the settings in your computer, all of that stuff can tie into being triggered by idle time events, among other things.  Windows is more susceptible to this, but I'm certain Macs can suffer from it too since they are all running standard intel chipsets and architecture (at least until the last couple months when everyone's giving up on Intel in the computer design world.

 

Depending on how your usb ports are configured (something possible to see in windows 10 with lots of effort, but more of a low level config file editing thing on Macs the last time I checked (several years ago), the USB port could be entering a different mode after a period of user input-idle time.

 

So it's possible that if you just move your mouse every 30 seconds or so during FW updates that the computer will not go into any change in USB power mode (such as performance limiting changes, a default setting on most windows laptops (for example)).

 

It's worth a shot.

 

It's also possible that the last time you tried your update, because you're anxious about it, you kept moving things, touching mouse or touchpad, or similar... and that's why it worked.

 

Or this might not be the problem at all.

 

But it's worth considering that you might have unusually setup USB ports that aren't behaving how you need them to behave during user idle time.

 

PS:  printers don't transfer nearly as much data as a fw update to a USB device would.... so the fact that your printer is reliable does not mean that I am wrong about this being one possible cause.

 

It's just a slim chance that this is your problem, but it certainly doesn't hurt to move your mouse once every few seconds to make sure the computer stays WIDE awake.  It can go into lower power usb mode while the screen is on and you have no idea.... USB power mode timing is set independently of your screen lock or anything else.

Link to comment
Share on other sites

I only used the printer example to verify it wasn't the cabling at issue because in previous episodes I had been repeatedly told I needed a new cable.  Hence my collection of barely used cables.  I will investigate if there are any user adjustable parameters with respect to my USB ports.  I don't think so though.  I was actually looking for anything related to that pretty much the whole time.  My mind was reeling in possibilities and I tried as best I could to leave no stone unturned.  A number of times I was doing this while the update was "in progress" so I don't think idle computer time was a factor.  At least not a consistent factor anyway.  It would halt right in front of me and interrupt me reading something in my PDF manuals or reading online.

Link to comment
Share on other sites

On 1/20/2021 at 4:39 AM, MGW-Alberta said:

Here are the Line-6 Updater fails:

 

 

 


Hi,

 

Well, from the screen shots, it looks like you are able get the Updater to see your Helix, but rather than installing the firmware from a previously downloaded file, you’re updating via the internet. Even in 2021, this can cause issues simply by having an unstable connection and/or a large amount of server traffic. If you have problems with the update do a “local install”. Also, it’s a good idea to close down any other running applications and disconnect other USB items to avoid potential conflicts.

 

Hope this helps/makes sense.

  • Upvote 1
Link to comment
Share on other sites

1 hour ago, MGW-Alberta said:

I tried to download the file and do a local.  The file I got was a dmg file which still accessed the internet for the data.

 

That wouldn't be the UPDATE file.... it was likely just the "updater program".  

 

The UPDATE file would have been an "hxf" file... 

That would provide you the update file....

Then run the updater and tell it to use that update file instead of going online to find it. 

 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...