Jump to content

FX Send & Return


Vics53
 Share

Recommended Posts

Greetings! Loving my Pod Go so far. Tonight, I tried hooking my Strymon Big Sky unit into the FX Send & return of the Pod Go. Wasn't working at first so I tried this, that and the other thing. Well, it works but when I click on the Big Sky and strike a note or chord, there's a slight pause and the overall sound (including the Big Sky) fades in. When I click the Big Sky off there's no problem. The sound is there. I've got it hooked up correctly into the Pod, just can't seem to figure out what I'm doing wrong.

 

My aim is to do some volume swells using the foot pedal while the Big Sky carries on. You know, those "churchy sounding swells."

 

Thanks in advance.

Link to comment
Share on other sites

What does "click on the big sky" mean?  You mean you press on the footswitch to activate the FX loop?  Ah no ok you click on one of the Big Sky (SBS) buttons to activate...  ok.

 

If you put the SBS before or after the go, does the problem still occurs?  If you put a patch cable or just a regular cable to FX loop in/out (so that the fx out returns without any pedal, directly out -> in), does your issue still arise? 

 

Sounds to me like it's 'an issue' with the SBS; does it have an autoswell which is what is generating the cut sound then fade in?

Link to comment
Share on other sites

I watched a video on You Tube to be sure I had the Strymon hooked up correctly, of which it is.

 

I have a cord going from the Pod's FX loop SEND going to the RIGHT IN on the SBS.

I have another cord going from the Pod's FX loop RETURN going to the RIGHT OUT on the SBS.

(There is also a Left IN and a Left OUT on the SBS. I tried that as well but get the same thing.)

 

According to the video, this should work the same as if you were plugging a pedal into an amps FX loop. He also said that no special footswitch assignments on the Pod Go were needed. Fact is, I just tried the SBS through an amp and no problem.

 

There are some sounds from the SBS that have the "auto swell" effect, but no matter which sound I choose they all have have that effect through the Pod. 

 

So what happening right now is: with none of the SBS's foot switches activated, I have my dry signal from the Pod.

When I click any foot switch on the SBS I still have my dry signal from the Pod.

When I click on any foot switch on the SBS AND click on the Pod's MONO FX LOOP foot switch, that's when the sound from the SBS and the Pod just fades in and the volume is also quieter compared to just the dry signal.

 

If this is supposed to work as it did through my amp, I don't know what's wrong.

Link to comment
Share on other sites

The Big Sky is stereo, but I've never had a problem with it before and yes, the FX loop on the Pod is set to Mono.

 

I think I may have this sorted out. In order to get this to work, it seems like I do have to engage the Mono FX Loop activated/illuminated. I also had to boost the Main Out in my signal chain to some degree as well as do some minor tweaks on the Blue Sky.

 

So it does work but not as I was expecting it to per the video I watched when they said "it will work just as if you hooked up an external effect to an amps FX send and return". Apparently you have to have the Pod's Mono FX Loop switched engaged when using an external effect in the FX loop.

Link to comment
Share on other sites

Quote

So what happening right now is:

1) with none of the SBS's foot switches activated, I have my dry signal from the Pod.

2) When I click any foot switch on the SBS I still have my dry signal from the Pod.

3) When I click on any foot switch on the SBS AND click on the Pod's MONO FX LOOP foot switch, that's when the sound from the SBS and the Pod just fades in and the volume is also quieter compared to just the dry signal.

 

Think you need to map it out as X + Y = Z.  Ex:  PGO Loop on + SBS off = just PGO, works normally, good.

 

But I think I know what your issue might be, see manual page 32, Global Settings > Ins/Outs #5 (see below)

 

With this option set to always-on, it engages some sort of ...  Wait...  Can't even recall the twisted logic...  Ok see the last post here:

 

Quote

when the FX Loop is on, it gives me absolutely no processed signal, like the FX return goes straight to the PGO out... Exactly like this:

 

image.png.e184630ccd6ec713d7317e32ac257655.png

 

And yeah my Looper (in) is connected to Pod Go FX send, and my looper (out) is connecter to the Go's FX return, so I expected it to go through all the chain like you said, but it's really not what it does...

 

Ok I just figured it out...! 

 

Global settings, in/out

 

image.thumb.png.81c56efc696ed8ebbd315219392980b1.png

 

That was why as I said in this and the other thread I linked earlier, that the looper kept playing even if the block was off...  So it's actually an interesting option if you have a mono looper and are outputting sound from Go to Monitors/PA/whatever!

 

But yeah not sure why that option was set the way it was...  When I changed the option, the Go started behaving as you would expect... The more you know LOL   (optimally, there could have been some indicator that the option is on/off, since it really screws up the FX loop behavior, but I guess that when you know the option exist...)

 

Thanks!

 

Link to comment
Share on other sites

Thanks gang. I really appreciate all the info. Right now it's working fine so at the moment that's all that matters. I don't have much time today to dig into what you're showing me here, but next week I'm going to further investigate all you've shown me. The more I'll know the better!

 

Thanks again and have a good day!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...