Jump to content

App Problems with AMPLIFi75


jeff_greiner
 Share

Recommended Posts

I have had my AMPLIFi75 for a few years now, however the Bluetooth connection between my amp and the IOS app has not been working the past month. Not only this, but the app is virtually unusable. It either crashes, or stays frozen on my iPhone. I even tried deleted and reinstalling the app, but that hasn’t worked. Is anyone else having the same issues?

Link to comment
Share on other sites

  • 4 months later...

The unfortunate truth in the matter of both IOS and Android versions of the Amplifi Apps have NEVER worked properly since day one of all Amplifi products. Since day one bluetooth connectivity HAS NEVER WORKED PROPERLY. Line 6 has known about this MAJOR BUG since day one and has never attempted to fix it. 

 

Unfortunatly ALL owners of any Amplifi were deliberately screwed by Line 6. Tens of thousands have been ripped of succesfully by Line 6 because they sell a product THAT HAS NEVER WORKED PROPERLY FROM THE START!  Since day one it has been clearly documented by MILLIONS that Amplifi 150 and all other Line 6 products have a MAJOR blue tooth conectivity problem with both the Android and IOS versions of the Amplifi app. Like me if you own any Line 6 product you have a usless paperweight. If you are thinking about purchasing an Amplifi YOU KNOW UP FRONT THAT IT WILL NEVER WORK! BEST ADVICE STAY AWAY FROM EVERYTHING LINE 6 AND DON'T LOOK BACK!

Link to comment
Share on other sites

  • 4 weeks later...

I am also having Bluetooth problems with amp. Right now I'm using fbv shortboard and it doesn't make a difference it cuts out , have to reboot amp. Tried resetting to factory and updating amp still looses  Myloweslife connection . Tried with iPhone, iPad . Same results . Been like this since I got it about a year and a half ago tried everything I can think of and been told by line6 . Now they said I should send it in for repairs of course at my cost I said no because this has been a problem since new and have contacted line6 about this time after time. They told me to try update as far as I know 2.10 is the latest update unless I missed something. Waiting to see what there next response is frustrated!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...