Jump to content
Jiiiim

Help with horrible fizzy low end distortion on preset

Recommended Posts

Hello!

 

New Helix user here.

I've made a dual amp preset that I'm otherwise pretty happy with, except on the right channel amp (a Matchstick ch2) there is a really horrid unnatural distortion happening. The only way I can (almost) dial it out is to put a pretty aggressive low cut on it, and but both Biases all the way up.

Can anyone help?

I'm using a K-Line San Bernerdino with Lollar Imperial humbuckers, and monitoring direct from the Helix with 600ohm Beyer DT770s.

Here's the preset if anyone would like to try it:
https://www.dropbox.com/s/6fwqm45fryf5tlo/Matchstick Fizz.hlx?dl=0
 

Share this post


Link to post
Share on other sites

As usual, what you are listening through makes a huge difference. It won't do much good for me to try it because I don't have your guitar, pickups, or headphones. Those headphone probably go down into the sub range. If you're gonna monitor with them, I'd just cut the lows and be done with it. Experiment with cutting lows before the signal hits the amp, and also the cabinet/IR EQ.

Share this post


Link to post
Share on other sites

Also try increasing the Bias level in the power amp section.

Share this post


Link to post
Share on other sites
3 hours ago, Jiiiim said:

Hello!

 

New Helix user here.

I've made a dual amp preset that I'm otherwise pretty happy with, except on the right channel amp (a Matchstick ch2) there is a really horrid unnatural distortion happening. The only way I can (almost) dial it out is to put a pretty aggressive low cut on it, and but both Biases all the way up.

Can anyone help?

I'm using a K-Line San Bernerdino with Lollar Imperial humbuckers, and monitoring direct from the Helix with 600ohm Beyer DT770s.

Here's the preset if anyone would like to try it:
https://www.dropbox.com/s/6fwqm45fryf5tlo/Matchstick Fizz.hlx?dl=0
 

Have you tried updating to 3.1? They made some improvements to the audio engine. It is mainly noticeable on distorted sounds. 

Share this post


Link to post
Share on other sites

 

On 4/15/2021 at 11:56 PM, bradenballestero said:

Have you tried updating to 3.1? They made some improvements to the audio engine. It is mainly noticeable on distorted sounds. 

 


Yeah, I have, and it is marginally improved, but still quite present. 

Just to add some more info to describe the sound:

It's coming from the low-end of the guitar i.e. the bottom 2-3 strings, but it manifests itself as a nasty high end fizz/unnatural distortion. Is this some sort of aliasing??

I can certainly dial some of it out if I but a low cut on the front, and then put Bias and Bias X up full, but it is still there.

Share this post


Link to post
Share on other sites

It can be virtually anything, and I would bet more on the guitar, than the Helix. Like pickup poles clearance from strings...if they are too close, a magnetic field will pull them back, producing nasty overtones and harmonics.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

I've not listened to it but turning Hum and Ripple down will probably fix it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...