Jump to content

Pod GO Edit can't see my Pod Go but it's there in device manager.


wpostma
 Share

Recommended Posts

This screenshot says it all. It's not a bad usb cable, because then the device wouldn't show up at all in Windows.   Instead it's an issue where the device DOES show up in windows, but despite that, Pod Go Edit does NOT see the device.

 

Pod Go Edit version 1.21.  Pod Go USB driver 1.0.0.7.

 

Yea yeah, we rebooted, yeah yeah we tried a different usb cable and also sacrificed 3 chicken sandwiches, using the approved Santeria ritual guides.

 

podgoedit_problem.png

Link to comment
Share on other sites

Before v1.21, did you have a previous version of Pod Go Edit installed?

 

If you are a new Pod Go user and hadn't installed Pod Go Edit before, you can't install v1.21 on its own and upgrade Pod Go because it's only an update program and not a stand-alone full installation.  Uninstall Pod Go Edit v1.21, install an earlier version (any of the previous versions is fine eg v1.1 and then upgrade to v1.21 via the upgrade feature in Pod Go Edit v1.1. 

Link to comment
Share on other sites

That doesn't make any sense because using the SAME exact download for Pod Go Edit 1.21, it works FINE when I do it on Windows 7, so if what you're saying made any sense, then it wouldn't work on Windows 7, on a machine that has never had pod go edit v1.0 or v1.1 on it either.

 

The PROBLEM is that WIndows 10 does not work with the PodGO with the provided usb drivers in the download.

 

There is NO UPGRADE ONLY, if you go to the downloads page and ask it to give you a download the download it gives you for 64 bit WIndows WORKS FINE with Windows 7 and NOT with windows 10.

 

If what you're saying is true then Line6 is to be chided for doing such a silly thing as shipping an "updater program" that would install fine without checking if there was all the existing content there it needed to upgrade.   I happen to be a professional software developer and I know a thing or two about making installers for applications.

 

(a) It would be a failure of their developers to actually CATCH this, 

 

(b) it would be user hostile of them to give you an UPGRADE-only binary, without asking if you already have a v1.0 updater.

 

Imagine I just came home from the shop today with a brand new pod go.  I go online, and then, what?  I have to go wade through forum posts to find a series of binaries that might even install?  I'd be sad and dismayed if Line6 was that lame.

Link to comment
Share on other sites

23 minutes ago, wpostma said:

The PROBLEM is that WIndows 10 does not work with the PodGO with the provided usb drivers in the download.

 

There is NO UPGRADE ONLY, if you go to the downloads page and ask it to give you a download the download it gives you for 64 bit WIndows WORKS FINE with Windows 7 and NOT with windows 10.

 

Brand new Pod Go user here. Windows 10 and working 100% fine for me using Pod Go Edit.

 

Maybe actually read what Voxman55 took the time to explain to you before simply disregarding it as not being a problem on your end?

Link to comment
Share on other sites

Your WIN10 version is 1909 which is shortly before end of MS support.

If I remember correctly Pod Go 1.21 istalles new drivers, too. With my WIN 10 20 H2 everything works fine.

Maybe after updating your WIN10 to the latest version might solve your problem?

Link to comment
Share on other sites

  • 1 month later...

Hi wpostma,

 

Just wondering if you ever got to fix this. I have the same issue on 2 sparate Windows 10 computers (both 20H2). Pod Go Edit 1.21 fails to pick up the device though it is clearly recognised by Windows. Version 101 doesn't work either. Wasted three hours of my life trying to get this to work. Raised a ticket today but not holding out much hope. I assume it is a driver related issue/conflict....? On one machine I am running a Behringer X32 as an interface, on the other a Focusrite. I am sure Line 6 will blame those. I just want to update the firmware, not a lot to ask. If they can't get it working I will be returning the unit. It's a lot of money for something that already has limited capabilities....disappointed.

Link to comment
Share on other sites

21 hours ago, BigClever said:

Hi wpostma,

 

Just wondering if you ever got to fix this. I have the same issue on 2 sparate Windows 10 computers (both 20H2). Pod Go Edit 1.21 fails to pick up the device though it is clearly recognised by Windows. Version 101 doesn't work either. Wasted three hours of my life trying to get this to work. Raised a ticket today but not holding out much hope. I assume it is a driver related issue/conflict....? On one machine I am running a Behringer X32 as an interface, on the other a Focusrite. I am sure Line 6 will blame those. I just want to update the firmware, not a lot to ask. If they can't get it working I will be returning the unit. It's a lot of money for something that already has limited capabilities....disappointed.


Is POD Go Edit the only Line 6 software you have open?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...