Jump to content
RChatfield1977

Helix 3.10 Update Issues....

Recommended Posts

I've just updated to the new 3.10 Firmware only to find there are no new Mandarin Rocker Amp and no new pedals as it stated in the update. I have done everything Line 6 has stated and in the update including the factory reset but still nothing. Anyone else having the same issue?

 

 https://line6.com/support/page/kb/effects-controllers/helix/helix-310-release-notes-r969/

Share this post


Link to post
Share on other sites
13 minutes ago, RChatfield1977 said:

 I have done everything Line 6 has stated and in the update including the factory reset but still nothing.

 

What about the part about updating HX Edit?

  • Upvote 1

Share this post


Link to post
Share on other sites
30 minutes ago, CraigGT said:

 

What about the part about updating HX Edit?

I did the update last night. I saw the instruction saying:

How do I update to 3.10?

Any chance you've already updated HX Edit to 3.01 (released on Feb 2, 2021)? If so, just connect Helix/HX to your computer via USB and launch HX Edit. The software will walk you through the entire procedure, including updating HX Edit 3.01 to 3.10 and backing everything up to your computer.

 

I opened HxEdit and started the update process, and it did update the Helix firmware.  I assumed it had also updated HxEdit but, when I checked this morning, HxEdit was still on 3.01.  I had to download and install the 3.10 HxEdit update separately.  I don't think this is working as intended, but it does explain why RChatfield1977 isn't seeing the new amp.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, gbr13697 said:

 

I opened HxEdit and started the update process, and it did update the Helix firmware.  I assumed it had also updated HxEdit but, when I checked this morning, HxEdit was still on 3.01.  I had to download and install the 3.10 HxEdit update separately.  I don't think this is working as intended, but it does explain why RChatfield1977 isn't seeing the new amp.


Hi,

 

This page contains the only 2 comments that I have seen regarding this - if it was a major issue then this place would be alive with complaints.


Always ensure that HX Edit and the firmware version numbers match, and reboot your computer.

 

Please supply your computer and Operating System details, so others can compare, should they encounter issues with the installation.

 

Hope this helps/makes sense

 

Edited by datacommando
Text

Share this post


Link to post
Share on other sites

For me the entire update process, this time, worked just flawless.

 

Been prompted there were 2 updates; one for Edit, one for Stomp. Did both, worked as intended.

 

Just don't rush things. Read the prompts, follow the instructions. This helps most of the time...

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
1 hour ago, datacommando said:

 This page contains the only 2 comments that I have seen regarding this - if it was a major issue then this place would be alive with complaints.

This is about the 5th ive seen counting  another forum....and hey 3.10 has only been out for about 12 hours.

Share this post


Link to post
Share on other sites
3 hours ago, RChatfield1977 said:

I've just updated to the new 3.10 Firmware only to find there are no new Mandarin Rocker Amp and no new pedals as it stated in the update. I have done everything Line 6 has stated and in the update including the factory reset but still nothing. Anyone else having the same issue?

 

 https://line6.com/support/page/kb/effects-controllers/helix/helix-310-release-notes-r969/

You didnt follow the first step of rules and update to 3.01

Share this post


Link to post
Share on other sites
1 minute ago, willjrock said:

This is about the 5th ive seen counting  another forum....and hey 3.10 has only been out for about 12 hours.

 

Yep, a couple or three over on the FarceBuck Helix Family page which boast 33,000 plus members. They seemed to fall into the usual category of not updating HX Edit first. As someone over there pointed out 5 minutes reading the release notes will save a long time of public embarrassment. As it has been pointed out many times, regarding these updates - nothing is foolproof to a sufficiently talented fool.

Share this post


Link to post
Share on other sites

I had HX Edit 3.01. It told me there was an update so I clicked. It updated both HX Edit and Helix to 3.10. However, HX Edit wasn't showing me the new blocks even though HX Edit was saying it was 3.10. I reinstalled 3.10 manually and then it worked.

Share this post


Link to post
Share on other sites
39 minutes ago, jonandtice said:

I had HX Edit 3.01. It told me there was an update so I clicked. It updated both HX Edit and Helix to 3.10. However, HX Edit wasn't showing me the new blocks even though HX Edit was saying it was 3.10. I reinstalled 3.10 manually and then it worked.

 

Line6 software doesnt use procedural updates (base install/Core + updated libraries), so each update it's just a brand new download of a brand new installer, which needs previous .exe version to quit. Im pretty sure you still were on 3.01 when you tried first time.

Share this post


Link to post
Share on other sites
1 hour ago, PierM said:

 

Line6 software doesnt use procedural updates (base install/Core + updated libraries), so each update it's just a brand new download of a brand new installer, which needs previous .exe version to quit. Im pretty sure you still were on 3.01 when you tried first time.

I wasn't. I checked Help -> About HX Edit... It said 3.10. I rebooted just to make sure it wasn't using old libraries.

  • Upvote 1

Share this post


Link to post
Share on other sites

So... let's assuming that somebody (me...) wasn't paying close-enough attention and ran the 3.10 update with HX Edit 2.9? 

 

What we know is:

The update appears to operate correctly and the Helix does register with 3.10, but

The new Mandarin Rocker and the new pedals don't make it into the Helix. 

 

So, how do we fix this? Do we need to (i) roll back to the previous firmware, (ii) update HX Edit and (iii) then run the 3.10 Update again?

 

Sure hope there's a way to fix this without rolling back the firmware. 

 

Thanks in advance, 

Bradley GT

 

Share this post


Link to post
Share on other sites
1 hour ago, GeeTah said:

So... let's assuming that somebody (me...) wasn't paying close-enough attention and ran the 3.10 update with HX Edit 2.9? 

 

What we know is:

The update appears to operate correctly and the Helix does register with 3.10, but

The new Mandarin Rocker and the new pedals don't make it into the Helix. 

 

So, how do we fix this? Do we need to (i) roll back to the previous firmware, (ii) update HX Edit and (iii) then run the 3.10 Update again?

 

Sure hope there's a way to fix this without rolling back the firmware. 

 

Thanks in advance, 

Bradley GT

 

 

Take a backup first. Download and install HX Edit 3.10. You can uninstall HX Edit 2.9 first if you want to be extra careful. Then make sure you do the factory reset, and restore per the release notes for HX Edit 3.10 if you haven't already.  You shouldn't have to do the firmware update again.  If it starts acting wonky though I would just to make sure everything went according to plan.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks guys for your help with the update. Now when I turn the helix on I have to wait for it to build the presets..... Any help?

Share this post


Link to post
Share on other sites
4 minutes ago, RChatfield1977 said:

Thanks guys for your help with the update. Now when I turn the helix on I have to wait for it to build the presets..... Any help?

 

This is normal. It will only do it once. Let it finish.  Btw, if this firmware version is anything like the others you may see this rebuilding upon restart behavior from time to time when you import or copy and paste presets. It will only rebuild those presets however, not all of the user presets as it does after a firmware upgrade. Again, totally normal.

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi all.

 

Another here with Helix Floor showing "Boot failure. Entered update mode!" message, after starting initialization clearly showing version 3.10 in the screen.

 

I also followed the explicit instruction pointed previously that if you had HX Edit 3.01 was not needed to update it previously to 3.10, as it would be part of the update process.

 

Once in this situation, I've tried to press 5&6 buttons when restarting to do a Global Reset, as per:

https://helixhelp.com/tips-and-guides/universal/reset-options

 

But without success (after restarting, shows a message ""Entered Update Mode!" and does nothing (no progress bar, etc.)

- Is it doing anything?

- Is there another reset procedure? 

- Should I try downloading directly to a USB pen the update and restart with the USB pen on the Helix USB port?

 

Will GREATLY appreciate how to solve this ...  

Share this post


Link to post
Share on other sites

Try running Line 6 Updater while your device is displaying the Entered Update Mode message.

  • Upvote 1

Share this post


Link to post
Share on other sites

I love this time of year, when the update failures are in bloom...

  • Haha 3

Share this post


Link to post
Share on other sites
On 4/21/2021 at 7:57 AM, cruisinon2 said:

I love this time of year, when the update failures are in bloom...

Lol, sometimes i think people just make it up to gain attention. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...