Jump to content
brucemacdonald

Spider V20 Mk II - Terrible noise and high-pitched whine

Recommended Posts

Hi, I've just got a new Spider V 20 MkII as an upgrade to my Spider III. I was surprised and disappointed to hear the loud buzzing and high-pitched whine coming from the amp on all settings except clean. My Spider III is completely silent on all modes, including INSANE. The Spider V is pretty much unusable because of the noise emitted when there is no significant input from a guitar. I have tried changing guitars, changing instrument cables, using different power sockets, moving to different rooms, but nothing seems to improve it.

I can remove a lot of the noise using the Spider Remote noise gate and adjusting gains, but I don't see why that should be necessary with out of the box, factory preset tones.

Is there something wrong with my Spider V amp or is this just something this amp does?

 

Any help in getting rid of this unwanted buzz and whine is appreciated.

 

Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...