Jump to content
willyjacksonjs22

Helix native noise problem

Recommended Posts

When using my hx stomp, I don’t have a noise issue when boosting treble, tone, presence or higher frequencies. But with helix native I do.

with helix native I use a Scarlett 2nd interface and all signals are fine. I’m also using a hss strat which I use the humbucker most of the time for Rock and metal playing. The noise is kinda like static or something. Another guitar I have that has active pickups, doesn’t seem to have the problem with native and my Scarlett. So is kinda wierd that it’s just one guitar being ok with the hardware but not with native.

Share this post


Link to post
Share on other sites

When you're playing, is the guitar in the same place relative to the computer as the HXS?

Share this post


Link to post
Share on other sites

I think i got it fixed lol i lowered the humbucker pickups. I guess is because the output of this pickup is really high that it cant be too close to the strings like my 

other guitar with active pickups which is a surprise. Im also still wondering why the hx stomp was eliminating the noise but anyways im getting a better tone than before. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...