Jump to content

Expression Pedal working, but only does 0% or 100% - Nothing in Between?


scottwilliams
 Share

Recommended Posts

1 hour ago, scottwilliams said:

was trying to use expression pedal for first time.  just trying to set up as volume pedal and trying to follow the manual...

now the hx is just cycling through every preset non- stop - whether expression pedal connected or not!

 

any tips much appreciated!


Hi,

 

O.K. Things have gone slightly mad, BUT you are not really giving much information to work with here.

 

You simply say that you “messed up expression settings on HX” BUT what HX unit? There are half a dozen variants.

 

What expression pedal? On board or external, if external, what make/model?

 

Following the manual? What did it say in the manual that could screw up something as simple a setting a volume pedal block?

 

Mmm... “cycling through presets non stop - whether expression pedal connected or not!”. That’s insane! 
 

When weird sh!t happens - perform a factory reset. I would tell you how to do that, BUT you haven’t said what unit you’re having trouble with?

 

Hope this helps/make  sense.

 

Oh, yeah - have you tried turning it off, and on again?

Link to comment
Share on other sites

13 minutes ago, scottwilliams said:

hi - thanks - I did manage to get that to stop... I think it was the polarity setting on the moog exp pedal (i reset and restored).. I've updated topic... it works now, but only switches between 0 and 100% - nothing in between?


Hi,

 

Here we go again - this comes up quite a bit, or variations of it..

 

Check this link to see if it helps - or maybe buy a cheapo M-Audio EX-P that does the job just fine.

 


Hope this helps/makes sense.

 

Link to comment
Share on other sites

i did see the option for "position" which it kind of 'forced' if I selected FS2... unless there's another place to set it that I didn't see, I'm pretty sure that was set as you've indicated it should be.  Either way, for the moment, I am taking datacommando's advice and trying a different expression pedal.  Pretty sure I can still return the Moog.  Thanks!

  • Upvote 1
Link to comment
Share on other sites

Helix doesn't accept/work with TRS cables and exp pedals. The EXP port does only listen for tip and sleeve.

 

You either need to mod the medal, or the cable, to make it a TRS to TS, isolating the Ring.

  • Downvote 1
Link to comment
Share on other sites

1 hour ago, PierM said:

Helix doesn't accept/work with TRS cables and exp pedals. The EXP port does only listen for tip and sleeve.

 

You either need to mod the medal, or the cable, to make it a TRS to TS, isolating the Ring.

 

10.
EXP 1/2, FS 4/5 Connect an expression pedal here to adjust a wide variety of parameters.* With a Y-cable (tip-ring-sleeve 1/4" jack, split to two tip-sleeve 1/4" jacks), two expression pedals can be connected. Alternatively, you can add one (or with a Y-cable, two) external footswitches to access additional stomps, presets, snapshots, etc. (FS4=tip, FS5=ring). To set this jack’s function(s), see page 52. By default, this jack is set to accommodate a Mission SP1-L6H Line 6 Expression Pedal, which has a toe switch that toggles between EXP 1 (Wah/Pitch or Poly Wham) and EXP 2 (Volume/Pan). For external footswitches, the momentary (unlatched) type should be used.

Link to comment
Share on other sites

5 minutes ago, rd2rk said:

EXP 1/2, FS 4/5 Connect an expression pedal here to adjust a wide variety of parameters.* With a Y-cable (tip-ring-sleeve 1/4" jack, split to two tip-sleeve 1/4" jacks), two expression pedals can be connected. Alternatively, you can add one (or with a Y-cable, two) external footswitches to access additional stomps, presets, snapshots, etc. (FS4=tip, FS5=ring). To set this jack’s function(s), see page 52. By default, this jack is set to accommodate a Mission SP1-L6H Line 6 Expression Pedal, which has a toe switch that toggles between EXP 1 (Wah/Pitch or Poly Wham) and EXP 2 (Volume/Pan). For external footswitches, the momentary (unlatched) type should be used.

 

Not sure what's the message here. I do have the Stomp, and Rack too.


If you have a TRS pedal, and you use a TRS/TRS cable, straight into the Exp port, it won't work. It will go 0/100/0.

 

Pedals in Helix must be TS, but since 99% of the market is TRS, you either need to mod the pedal, or the cable, as I did for all my TRS pedals.

 

Said that, not sure that's the problem with the OP, as he should still get 0 to 100 to 0. Just trying to help, like you.

  • Downvote 1
Link to comment
Share on other sites

2 minutes ago, PierM said:

 

Not sure what's the message here. I do have the Stomp, and Rack too.


If you have a TRS pedal, and you use a TRS/TRS cable, straight into the Exp port, it won't work. It will go 0/100/0.

 

Pedals in Helix must be TS, but since 99% of the market is TRS, you either need to mod the pedal, or the cable, as I did for all my TRS pedals.

 

Said that, not sure that's the problem with the OP, as he should still get 0 to 100 to 0. Just trying to help, like you.

 

Posted for the sake of clarity, since we both know that EVERYONE reads the manual.... :-)

  • Haha 1
  • Upvote 1
Link to comment
Share on other sites

well... thanks for the comic relief..  FWIW, I have looked in manual, but even the part you quote doesn't seem to address how to connect a single expression pedal, and there were a bunch of folks on the forum - including the other guru above - who seemed to indicated the M audio pedal would work without modification.   I guess I'll find out one way or the other tomorrow.  Thanks!

Link to comment
Share on other sites

15 minutes ago, scottwilliams said:

the M audio pedal would work without modification


Hi,

 

If you are going to use the M-Audio EX-P with your unit (I have 2 on my Helix floor and one on my controller keyboard), a couple of things to note are:

  1. Turn the small grey knob on the left hand side fully anti-clockwise.
  2. Flip the switch on underside of the pedal to “OTHER”
  3. In the Global Setting ensure the polarity option is set to “Inverted”.

Have fun.

  • Upvote 1
Link to comment
Share on other sites

30 minutes ago, scottwilliams said:

well... thanks for the comic relief..  FWIW, I have looked in manual, but even the part you quote doesn't seem to address how to connect a single expression pedal, and there were a bunch of folks on the forum - including the other guru above - who seemed to indicated the M audio pedal would work without modification.   I guess I'll find out one way or the other tomorrow.  Thanks!

 

Ok im confused now.

 

In the OP you said it's a Moog Exp Pedal, which is a TRS/TRS. Now it's a M Audio, which is a TS pedal. Hard to help when things arent clear enough. Still not clear if Helix or a HX stomp...

 

Anyway, if it's a Moog Exp Pedal, like the EP3, you just need a Y Cable, TRS to TS/TS (like pic 1), and a custom cable with TRS on a side (that you'll plug to your exp pedal), and a TS on the other side (that you'll plug into one of the two TS female from that Y cable). The custom cable it's just a TRS cable with the ring wire cut and isolated on the TS side, and only Tip and Sleeve properly weld to the jack terminals. This worked for me 100% of the time (even with few TRS Expression knobs) , so I guess it should help your situation too. Then, if it is a M-Audio, it should work as it is. STILL, if it's a HX Stomp, you need that Y cable.

 

 

image.jpeg.07aff4524736bb34e6e3ac826594223f.jpeg

 

 

2-F0-DD740-4-B18-4-E61-AA83-0-C34644-B90

 

  • Upvote 2
  • Downvote 1
Link to comment
Share on other sites

36 minutes ago, scottwilliams said:

FWIW, I have looked in manual, but even the part you quote doesn't seem to address how to connect a single expression pedal


Oh, yeah, I almost forgot. 
 

See page 53 - HX Stomp 3.0 Owner’s Manual - One Expression Pedal (there is even a diagram)

 

  • Upvote 1
Link to comment
Share on other sites

8 minutes ago, datacommando said:


Oh, yeah, I almost forgot. 
 

See page 53 - HX Stomp 3.0 Owner’s Manual - One Expression Pedal (there is even a diagram)

 

 

I tried that, but for me doesnt work. I mean, if I connect a TRS pedal, straight into EXP port, does the 0/100/0 thing, even with all properly setup as the manual. Manual isnt clear if the example it's using a TS pedal or a TRS tho... a bit foggy.

  • Like 1
  • Downvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...