Jump to content
z3albw1rr

HX Effects - can it do this (and could someone try for me?)

Recommended Posts

I'm not sure I totally understand the limitations of the HX Effects so bear with me here.

 

I think you can have up to 9 blocks, correct?

 

If so, here's what I want (in typical pedal order not necessarily footswitch order):

 

Wah - not assigned to a FS, but able to be activated by just moving an external expression pedal.

 

Phaser - Legacy Phase 90 on FS1 (numbers are irrelevant, I'm just using them to total up to 8 - I assume I can assign this effect to any FS I want).

 

Effects Loop out to external drive pedals, and then back in (any concerns about impedance?)

 

Chorus - Legacy Dimension on FS2

 

Flanger - Legacy AC Flanger on FS3

 

Rotary Drum/Horn - Legacy that model on FS4 (or, Legacy Opto Tremolo)

 

Binson Echo Rec - Legacy on FS5

 

Binson Echo Rec - Legacy on FS6 (one will be fixed, the other tap tempo)

 

63 Spring Reverb - Legacy again - always on.

 

Now, if the effects loop is a block, that's 9.

 

What I want though is one more thing - a Volume pedal I'll assign a min/max value to operate with another expression pedal.

 

If the FX loop is a block, then I can give up the Reverb and just use my amp's own reverb, and the Volume pedal will be the last block.

 

I want to make sure:

 

A. I can do all this and it has enough DSP (and Line 6 BTW told me the Legacy Effects were under-reporting their DSP usage which would be fixed in an update, so not sure if it's been addressed but I'd like to see if it can do it with all Legacy effects. If not, I could use the new effects, so it would still be nice to for someone to let me know about those if the Legacy ones won't work). Bread and butter stuff - Cry Baby, Phase 90, CE1, MXR Flanger, 122 or 145, Echo Plex x2, a Spring Reverb (if FX loop doesn't take a block) and I think the volume pedal is only a legacy but anything like a clean boost or EQ I can just have a lower volume and higher volume the pedal can go between is fine).

 

B. I will most likely swap out the Rotary with other effects - I realize I probably won't be able to get a polyphonic pitch shift in there, but it could be: Tremolo (typical Blackface), Pitch Shifter/Harmonize (the legacy one or any that work), Fuzz, another drive, etc. These would of course be different Presets!

 

I would really love for someone to actually check and see if it can actually be populated with these 9 blocks. All Legacy, or, if not all the new ones that are similar.

 

I don't need stereo, I don't need parallel paths, etc. etc. I just need to use it as a Mod and Delay box, with a Wah before, a Boost after, an FX loop for my drives. No fancy ambient echoes or verbs, or other stuff - bread and butter classic effects. I can use those in other presets without as many things in them - such as just an Acoustic Sim (and maybe a reverb)

 

That brings up a final question:

 

C. Can I switch between "boards" in real time? If I have a preset with these 9 effects in it, can I press like the mode switch, then go up a preset, to my one with say just the acoustic simulator, and keep playing the sound of the current preset, and when I step on the new preset have it change to "acoustic guitar", then while playing that, press the mode and go back to the 9 effect preset, and press the button and have it go back to at least the recalled state of that one (if not both the recalled or discarded version). Ideally with no break in sound (and do tails hold over preset changes?).


If not I would have to do something like give up a block to the acoustic sim, and have a snapshot of 8 and another snapshot of just the acoustic sim (or that and verb).

 

But I need to make sure it can run all this stuff. 9 actual effects - basic effects -  if it can only run say, 6 or 7 before it runs out of DSP, that becomes problematic - or if I can't switch presets on the fly and have to give up some blocks, that'll suck even if it will run 9, but if it'll only run 6 or 7, that's even worse. Then I'm to the point of using an external wah, external boost, and external reverb, and may even have to get a real phaser to put out in front of the drives (and maybe fuzz as well...).

 

Thanks in advance for anyone who can test this out for me or give me some insight as to if these things are even possible.

 

 

 

 

Share this post


Link to post
Share on other sites

Let's just start at the beginning - you having this totally wrong!

HXFX can have lots of effects - limited only by DSP (memory)

Maybe you've got confused with the stomp? or the Pod Go?

But you can set up lots of presets and get to them easily, so you can have a pile of different effects in the next preset.

It's like you have 100's of pedal boards - each built for a particular song if you like.

Each preset is essentially a new pedalboard of whatever effects you might want limited only by DSP - that could be 14 or more effects in just that one preset.

Next preset might have 12 effects - none of which were in the last preset. And so on.

So unless you want to turn on every one of these at the same time, you are thinking it in the wrong way.

So look at the Line 6 page on it and rethink the whole of what you have tried to work out here.

Share this post


Link to post
Share on other sites

I just bought an HXFX and only have access to 9 blocks.

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, rvroberts said:

HXFX can have lots of effects - limited only by DSP (memory)
...... that could be 14 or more effects in just that one preset

 

Not on the HXFX you can't....

The HXFX has a maximum limit of 9 blocks. Less if you are using DSP intensive blocks. 

 

11 hours ago, z3albw1rr said:

I would really love for someone to actually check and see if it can actually be populated with these 9 blocks.

 

I don't own an HX Effects, but Helix Native has compatibility mode for each hardware so I set that to HX FX and tested it there. 

The primary configuration you listed can certainly be done... with a little DSP to spare.

 

NOTE: In Native I cannot insert a Loop... but in my experience a loop does not draw much (if any) DSP. There is enough DSP left over to insert "almost" any other effect so I can't see adding the loop being an issue. 

 

11 hours ago, z3albw1rr said:

Now, if the effects loop is a block, that's 9.

 

Yes, the Loop is a block so to use a Volume you would need to replace something else. 

 

11 hours ago, z3albw1rr said:

Can I switch between "boards" in real time?

 

I assume you are talking about changing presets and the answer is Yes and No. There will be a slight gap when changing the preset.... For some this is a huge issue yet for others they can always find the "moment" they are not playing to make this change seamlessly. 

 

If one song uses rotary and the next uses tremolo... change the preset between songs. Same could apply for Phase vs Flange since it is "rare" to have both in the same song. 

 

11 hours ago, z3albw1rr said:

I will most likely swap out the Rotary with other effects - I realize I probably won't be able to get a polyphonic pitch shift in there, but it could be: Tremolo (typical Blackface), Pitch Shifter/Harmonize (the legacy one or any that work), Fuzz, another drive, etc.

 

There does appear to be DSP available for almost any effect (not the Poly stuff... but you seem to know that) if you took our the rotary. 

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
3 hours ago, codamedia said:

 

 

Quote

I assume you are talking about changing presets and the answer is Yes and No. There will be a slight gap when changing the preset.... For some this is a huge issue yet for others they can always find the "moment" they are not playing to make this change seamlessly. 

Thanks,

 

The gap is always a huge issue for me. However, as you said, I would be unlikely to use Leslie and Trem in the same song, so those being different "boards" wouldn't be a big issue - I've been using my M13 this way - simply not changing presets mid-song. However, the M13 does in fact have seamless preset changing!

 

I started thinking last night about the Loop - I remembered I had an M5 and an M13 and tried the M5 in the M13's loop and there was a slight, but noticeable difference in sound. I then remembered that I had in fact tried my own drive pedals in the M13's loop and it didn't work so hot. I started researching last night and I saw a lot of issues with this.


In fact, I tried a Helix, and tried using an INTERNAL effect and the problem is the "Send/Return" treats the signal like an Aux Send and Return on a Mixing Console. It creates a Parallel signal flow where the dry signal passes through in addition to the effected signal. This would be fine if you had a delay in your loop set to 100% wet. But for a drive, you need 100% wet signal on the drive and the dry signal muted. Which wasn't easy to do. The loop "paths" are not very intuitive and actually seemed to work in reverse.

 

I didn't see any way to set it so it's like a traditional old school "loop" pedal (not looper) - an effects switcher - like you would use when you wanted to put a tone-sucking-when-bypassed pedal in a loop but then engage/disengage the loop to bring it into or out of the signal path.

 

I finally got it to work by setting the values in what seemed to be the opposite way I'd think they work, and putting an ADDITIONAL BLOCK in the dry signal path with its volume set to 0 to mute the dry path.

 

But that was a lot of work for something that should be "boneheaded simple".

 

So at this point, I think I'm at Wah out front, drives out front, 4 mods and 2 delays, and using a single expression pedal for boost/volume - so 7 effects, 6 assigned to footswitches, 1 "off the board" (the volume). Use presets to get to additional boards. Maybe 2nd expression pedal for some other parameter control (mix of delays... Fast/Slow on a Rotary, etc.).

 

BTW: The software will tell you it will run these things, but it won't freeze up and need to be rebooted like the Helix I tried would when you put the "wrong" effects in there. Since the Legacy effects were under-reporting how much DSP they used, putting them in the software will appear that they'll work, but on the actual device, it locked it up. I couldn't put but 2 delays, a verb, and an amp model into a Helix LT before it would freeze.

 

 

 

 

 

3 hours ago, codamedia said:

 

 

Share this post


Link to post
Share on other sites
2 hours ago, z3albw1rr said:

The gap is always a huge issue for me. However, as you said, I would be unlikely to use Leslie and Trem in the same song, so those being different "boards" wouldn't be a big issue - I've been using my M13 this way - simply not changing presets mid-song. However, the M13 does in fact have seamless preset changing


It most certainly doesn’t... The transition time from one preset (or scene, technically, I guess) to the next on the M13 is a little shorter than the HX Effects, just because it’s using a smaller chip, and there’s less stuff to load, but it’s not seamless.

Share this post


Link to post
Share on other sites
2 hours ago, z3albw1rr said:

In fact, I tried a Helix, and tried using an INTERNAL effect and the problem is the "Send/Return" treats the signal like an Aux Send and Return on a Mixing Console. It creates a Parallel signal flow where the dry signal passes through in addition to the effected signal. This would be fine if you had a delay in your loop set to 100% wet. But for a drive, you need 100% wet signal on the drive and the dry signal muted. Which wasn't easy to do. The loop "paths" are not very intuitive and actually seemed to work in reverse.

 This is also incorrect. The Mix control determines how wet/dry mix of the loop. If you have it at 100, the loop is a standard serial effects loop.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, phil_m said:


It most certainly doesn’t... The transition time from one preset (or scene, technically, I guess) to the next on the M13 is a little shorter than the HX Effects, just because it’s using a smaller chip, and there’s less stuff to load, but it’s not seamless.

That may be true, and I didn't want to get into this, but it seems "more seamless" when the effects are largely the same or not changing states than when you're changing to a more extremely different set of effect. So two Scenes with all the same effects but just different ones engaged and bypassed is pretty darn seamless. But having a completely different set of effrects in different states seemed a little more noticeable. In fact, IIRC some things, like let's say a drive with a high gain but a low volume, would often "pop" as it changed because it seems to me that the drive processed slightly before the volume so it would come through for milliseconds at a higher volume then suddenly drop down. So it seemed more "abrupt" the more differences there were between the effects. That seems to make sense.

 

But, as you said, it was "more seamless" and that's "more better" if you want as seamless a transition as possible.

Share this post


Link to post
Share on other sites
4 hours ago, phil_m said:

 This is also incorrect. The Mix control determines how wet/dry mix of the loop. If you have it at 100, the loop is a standard serial effects loop.

I'd love to see step by step instructions for the settings for this (or rather, I would have at the time) because I tried all the combinations I could think of. It didn't matter what I did, the dry signal still came through. IIRC some of the settings would make it be 100% dry even with the loop on, but getting 100% wet without the dry signal also passing was impossible. The loop itself was 100%, but the dry signal path couldn't be disengaged without my putting another block in there to mute it.

 

At this point I can't sit down and replicate the issue, but that it wasn't you just put a pedal in the loop and engage/disengage the loop without messing with a bunch of settings. That's the way it should be, and that wasn't the way it was.

Share this post


Link to post
Share on other sites
9 hours ago, z3albw1rr said:

I'd love to see step by step instructions for the settings for this


Hi,

 

As you might expect, all the parameter functions for the Send/Return blocks are described in the HX Effects 3.0 Owner’s Manual - Rev B English (Send/Return pages 25 and 26)


Here’s what it says regarding the “Mix” parameter for a Return:

 

“Blends the Return signal vs. the dry signal passed through the Return block. When set to 0%, the path bypasses the Return completely. When set to 100%, the entire signal is fed from the Return, and no dry thru signal is heard.”

 

Here’s what it says regarding the “Mix” parameter for an FX Loop:

 

”Blends the FX loop signal vs. the dry signal passed through the FX Loop block. When set to 0%, the path bypasses the FX loop completely. When set to 100%, the entire path is fed through the FX loop, and no dry thru signal is heard. (This means that if you don’t currently have your external gear connected to the Send & Return jacks, you won’t hear any output signal unless you bypass the FX Loop block!)”


Manuals are full of interesting facts like that.

 

Hope this helps/makes sense.

  • Upvote 2

Share this post


Link to post
Share on other sites

A good practice, that always worked for me, is to download and study the manual (which are all available in pdf for every modern pedal in the market), before to buy new stuff. Also cheatlists are good help. This way I do get two advantages; 1) If Im gonna buy it, I will already know good stuff as soon as it arrives new home, so I can start messing with it, out of the box. 2) Manuals are telling you what's doable and what's not, so that's enough info to decide if buy or not buy. In this specific case, you also have a trial of Native, to experiment the details, and the sound of everything. We do live great times. :)

 

Works for me 90% of the time. 

  • Like 1
  • Upvote 2
  • Downvote 1

Share this post


Link to post
Share on other sites
12 hours ago, z3albw1rr said:

I tried all the combinations I could think of. It didn't matter what I did, the dry signal still came through. IIRC some of the settings would make it be 100% dry even with the loop on, but getting 100% wet without the dry signal also passing was impossible. The loop itself was 100%, but the dry signal path couldn't be disengaged without my putting another block in there to mute it.

 

User error is a distinct possibility..... it most certainly works exactly the way you want it to work - so something else was at play! 

19 hours ago, z3albw1rr said:

In fact, I tried a Helix, and tried using an INTERNAL effect and the problem is ... 

 

If you walked into "trying a Helix" with a pre-conceived notion of how it works, then that would be a big mistake. There are many ways that you can "accidentally" create a "dry through" on the Helix and if you try to fix it in the wrong block or location that could explain the type of frustration you are describing.

 

20 hours ago, z3albw1rr said:

BTW: The software will tell you it will run these things, but it won't freeze up and need to be rebooted like the Helix I tried would when you put the "wrong" effects in there. Since the Legacy effects were under-reporting how much DSP they used, putting them in the software will appear that they'll work, but on the actual device, it locked it up. I couldn't put but 2 delays, a verb, and an amp model into a Helix LT before it would freeze.

 

If this was a problem in the past, it certainly doesn't appear to be now.

 

I just loaded your setup into a SINGLE path on my Helix... and when I went to load an amp all but 3 amps (Supro, JC120 and US Small Tweed) were greyed out.  So... I loaded one of those three amps, turned on all effects and made noise for a few minutes. Nothing froze. 

 

FWIW... I use quite a few legacy effects and my live preset(s) are usually one giant serial path - some up to 25+ blocks. I have never once had my Helix freeze or require a reboot. I'm not suggesting it can't happen... I'm just pointing out that it's not the norm. 

Share this post


Link to post
Share on other sites
2 hours ago, codamedia said:

 

User error is a distinct possibility..... it most certainly works exactly the way you want it to work - so something else was at play! 

 

 

If this was a problem in the past, it certainly doesn't appear to be now.

 

I just loaded your setup into a SINGLE path on my Helix... and when I went to load an amp all but 3 amps (Supro, JC120 and US Small Tweed) were greyed out.  So... I loaded one of those three amps, turned on all effects and made noise for a few minutes. Nothing froze. 

 

FWIW... I use quite a few legacy effects and my live preset(s) are usually one giant serial path - some up to 25+ blocks. I have never once had my Helix freeze or require a reboot. I'm not suggesting it can't happen... I'm just pointing out that it's not the norm. 

I was trying to emulate the M and 4 series switch capabilities by putting 2 drives in a S/R loop, and assign a single FS to toggle between them. Then I assigned another FS to bypass/engage the loop. This way I could "pre-set" which drive would be on when the loop was engaged, and have either, but not both (which is the way the 4 series worked and a column on the M series worked).


I have found L6 products to be quite intuitive in the past and there are often "tips and tricks" or "secret operation" things to be discovered in the manual, so I did read it, and I do, as another poster suggested, look through the manuals to determine if a product appears to do what I need it to do. Once I couldn't figure out easily how to do this loop I did go through the manual, but again, the behavior didn't seem logical to me. I did in fact get it to work, so I'm not saying it doesn't work, I'm just saying that I personally found it to be more cumbersome than I expected it to be. But that's a little nag. So we can call it user error and be on our way.

 

The other issue was told to me by Line 6 specifically and they said "it's our fault". The effects were under-reporting their DSP usage so additional effects were NOT greyed out like they were supposed to be. I put in a Twin Reverb, 2 Echorecs and a 63 Spring, and then when scrolling to try to add any other effect, I could get to the effects screen and then it would just freeze as I was scrolling through. Nothing was greyed out anywhere. It would just lock up and I'd have to restart. L6 told me those legacy effects are under-reporting and I just happened to come on a combination that caused this - or maybe, thankfully, made them aware of it.

 

They said it would be addressed in the "next" update but at the time (about a month ago as of this message) I didn't know when that was going to be.

 

They may have already addressed it.

 

As for the number of effects: I appreciate those who've tried it but it seems you tried it on a Helix...a Floor or LT? And the other person tried it on the software only.

 

I was hoping for someone to try it on the HXFX (HX Effects) specifically.

 

Thanks for your help.

Share this post


Link to post
Share on other sites
4 hours ago, PierM said:

A good practice, that always worked for me, is to download and study the manual (which are all available in pdf for every modern pedal in the market), before to buy new stuff. Also cheatlists are good help. This way I do get two advantages; 1) If Im gonna buy it, I will already know good stuff as soon as it arrives new home, so I can start messing with it, out of the box. 2) Manuals are telling you what's doable and what's not, so that's enough info to decide if buy or not buy. In this specific case, you also have a trial of Native, to experiment the details, and the sound of everything. We do live great times. :)

 

Works for me 90% of the time. 

Oh I do, believe me.

 

However, it's that 10% that gets me - stuff that's not addressed in the manual and not easy enough to find out online

 

For example, I had to come here specifically to ask if this device will run these effects. Nowhere in the manual is this addressed. It just says "up to" and "dsp permitting".

 

There's no way to tell which combination of effects will be possible and which won't based on the manual.

 

The other things I asked, OK, yes maybe I missed those.

 

 

Share this post


Link to post
Share on other sites
7 hours ago, datacommando said:

 

Hope this helps/makes sense.

Thank you for that! Maybe I was just holding my pick wrong at the time. It certainly didn't seem that straightforward as I was trying it but maybe because I was trying to do more than just a simple loop it could have gotten more confusing.

 

It is nice to know now that basic loop functionality should work as expected for both a typical Loop pedal as well as Aux Send/Return kind of functionality.

  • Upvote 2

Share this post


Link to post
Share on other sites
9 minutes ago, z3albw1rr said:

There's no way to tell which combination of effects will be possible and which won't based on the manual.

 

If you download the trial of Native, you can test all the combination you'd like to test, using the plugin in compatibility mode. The only thing that you can't test are FX Loops, as they are hardware, but those are basically DSP free.

 

It's LOT OF FUN, and does really give you a realistic overview over the hardware counterpart. 

  • Downvote 1

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, z3albw1rr said:

 

I was hoping for someone to try it on the HXFX (HX Effects) specifically.


Hi,

 

Sadly I’m not a HXFX owner and not able to check this out. Although this has already been done by “codamedia”, when it was tested in both in Helix Native and a single path in a Helix. Also, I find it rather confusing that you keep mentioning you need this to work on a HXFX box, but you actually managed to “freeze” a Helix by adding an amp and cab block.

 

I’m a Helix floor (and Native) user and have been since late 2016, and in all that time I have never managed to get the thing to “tilt” - ever - and I have put some pretty oddball patches into it. I have had it hooked up to external rack digital delays, Yamaha SPX 90, Ditto x4 and Boss RC30 loopers, Zoom pedals and even a put Line 6 POD HD500 in the FX loop just for sh!t ‘n’ giggles. I’m still waiting for it to fall over.

 

Forum contributor, “Malhavok” (Ben Vesco) has done his own tests of DSP usage, and has been publishing the lists for quite some time. Find the latest updates here:

https://benvesco.com/store/helix-dsp-allocations/

 

Hope this helps/makes sense.

 

Edited by datacommando
Typo
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Hi Z3,

 

I put your 8 effects and effects loop on my HX Effects and it all works fine.   All 8 effects can be enabled at the same time including the wah(chorme).  You can copy this to another preset location and swap other effects without too much difficulty.   I didn't try swapping much, but I did swap in the new "Hot Springs" reverb and adriatic delay.

 

Patch file is attached below.

 

Bob

Z3LegacyBoard.hlx

  • Like 1
  • Thanks 1
  • Upvote 1

Share this post


Link to post
Share on other sites
On 6/7/2021 at 5:48 PM, bobcoss said:

Hi Z3,

 

I put your 8 effects and effects loop on my HX Effects and it all works fine.   All 8 effects can be enabled at the same time including the wah(chorme).  You can copy this to another preset location and swap other effects without too much difficulty.   I didn't try swapping much, but I did swap in the new "Hot Springs" reverb and adriatic delay.

 

Patch file is attached below.

 

Bob

Z3LegacyBoard.hlx 8.65 kB · 0 downloads

Thanks BobCoss.

 

That's really what I needed to hear.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...