Jump to content

Helix Effects: loud humming when switching channels on Mesa Boogie Mark V 90 Watt Head


olliwii
 Share

Recommended Posts

Hi,

 

i'm trying to control the channel switching on my Mark V via the Helix Effects instant blocks.

I've figured out the function in general and the switching itself is working properly ( tip+ring for the wanted channel).

The only problem i'm having is excessive humming (mind i already have two gates in my signal chain).


I have seen a similar problem in this forum before, but the thread is some years old now.

Does anyone know if there is a proper solution or are there just workarounds with external components?

 

kind regards and thank you in advance

 

olli

Link to comment
Share on other sites

Hey there!

 

I have a Mark 5 35 Combo but before that had a Mark V 25 Head. I had no issues with noise except when I had Helix connected to my computer via USB. Wondering if you've tried unplugging the USB if it's connected?

 

I will eventually get around to modifying the foot switch cable for the 35 combo by adding some 1/4" connectors for channel and EQ switching but haven't gotten there yet.

 

 

T

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...