Jump to content

Helix LT preset display flaky (same number across whole row, ...)


marmatkat
 Share

Recommended Posts

Hi Folks. I'm having a strange problem with my LT. When using the BANK UP and BANK DOWN footswitch buttons on the left, I've sometimes seen display weirdness as I scroll. One time the bottom row was empty except for one preset, and at practice last night the bottom row showed all the same preset (see pic). Has anyone seen this before? Is there a fix? Thank you.

 

  • Version: 3.11.0 ("Your Helix LT device is up to date with firmware version 3.11.")
  • Mode: Performance View
  • Global Settings: Footswitches: Stomp Select: Touch. Preset Mode Switches: Snap/Stomp. Snapshot Mode Switches: Auto Return. Up/Down Switches: Banks. Swap Up/Down: Off

helix-display-bug.jpg

Link to comment
Share on other sites

8 hours ago, marmatkat said:

Version: 3.11.0 ("Your Helix LT device is up to date with firmware version 3.11.")


Hi,

 

When you updated to firmware v3.11, did you follow the instructions to backup, do a factory reset and then reload from your backup file?


It’s one of those things that is advised to avoid any weirdness after the update. In fact the Line 6 release notes for the update make a feature of it by using big red letters.

 

Anything else I should know?

Yes. We STRONGLY recommend performing a factory reset AFTER UPDATING your Helix/HX firmware to 3.11 and THEN RESTORING YOUR BACKUP. (Backing up is part of the update process). Here's how to perform a factory reset. IMPORTANT: MAKE SURE YOU HAVE A BACKUP FIRST, AS A FACTORY RESET WILL ERASE ALL YOUR WORK!

  • Helix Floor/LT: While holding footswitches 9 & 10 (bottom row, 2 middle switches), turn on Helix Floor/LT
  • Helix Rack: While holding knobs 5 & 6 (2 furthest right knobs below the screen), turn on Helix Rack
  • HX Effects: While holding footswitches 6 & TAP (2 farthest right switches on the bottom row), turn on HX Effects
  • HX Stomp: While holding footswitches 2 & 3, turn on HX Stomp
  • HX Stomp XL: While holding footswitches C & D, turn on HX Stomp

Hope this helps/makes sense.

 

  • Thanks 1
Link to comment
Share on other sites

I've had this on my LT since forever  I considered filing a bug report but found it too annoying to explain the various aspects of it so didn't bother.

 

If the LT boots into signal chain view and SNAP/STOMP mode, pressing Bank up/down gives a row of 16As instead of the stomp labels. There are other aspects relating to the updating of the 4 stomp screen areas when in signal chain view but I can't remember them all.

 

For me though, in performance view the stomp areas are updated correctly and that's what I use so it stopped bothering me.

Link to comment
Share on other sites

1 hour ago, marmatkat said:

Brilliant discovery, Mike. Question: Did you try a factory reset?

 

It's persisted through multiple firmware updates and factory resets and is 100% reliable. I don't actually remember it not doing that.  

 

I've just had a look again.

 

Basically the four stomp areas that you see when switching presets in stomp/snap mode aren't updated when switching preset if you're in signal chain view.  That includes at initial boot. If by some process they get changed from the initial 16A to what they should be (switching to performance view and back again) they'll be wrong again if you switch preset.  They also aren't updated to reflect the actual bypass status of the stomps.

 

See what I mean about trying to explain it?  It quickly descends into a confusing mess.

 

Link to comment
Share on other sites

1 hour ago, MikeUnderscoreB said:

It's persisted through multiple firmware updates and factory resets and is 100% reliable. I don't actually remember it not doing that.  

 

 

Have you contacted support?

Link to comment
Share on other sites

49 minutes ago, MikeUnderscoreB said:

That possibly comes across as a bit abrupt.  The reason I don't care is that it's only something you ever see if you're in snap/stomp mode and signal chain view and are just about to change presets.

 

We all deal with our personal needs in our own ways. Myself, if something I paid a lot of money for doesn't work as advertised, I want to know why. I may not need the feature today, but if I suddenly find tomorrow that I need it, that's not when I want to have to deal with support. Better to do that BEFORE the need becomes critical.

 

But that's just me.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...