Jump to content
ahwk0607

TEMPO ISSUE SLIGHTLY SOLVE BUT STILL....

Recommended Posts

Basically there is a tempo issue on HEILX that it didn't receive the midi clock message from other musical devices thru midi in ports.

But there are some clues.

Basically there are 3 basic midi messages about midi clock.

-"Song Start" (decimal 250, hex 0xFA)

It is a midi message for allowing device to start receiving the midi clock message until receiving the "Song Stop" message. (Sync)

 

-"Timing Clock" (decimal 248, hex 0xF8)

As the "Song Start" message received, the musical device calculate the bpm thru receiving timing clock message 24times per 1/4 note.

For example, if I send a 120 bpm, then HELIX receive the 96 Timing Clock messages on 2 seconds.

So the helix recognize it as 120bpm if it worked normally (it didn't ;/)

 

-"Song Stop" (decimal 252, hex 0xFC)

If this messages sent to a device, the device starts to ignore the Timing Clock message until they receive the Song Start message again. (Not sync)

 

The main problem of the HELIX is it didn't receive the TIMING CLOCK messages.

 

If I modulate the mid source to only send a SongStart , SongStop, the magical thing happens.

The tempo is maintained as I set already on (per preset or per snapshot, or Global) and it pick the perfect timing for starting point.(That is perfect!!)

 

But the problem is that some Modulation models(which can change the rate setting fit on bpm ex) 1/4 1/8Dot...)  and Filter models which also contain rate parameter,

didn't even response on Song Start messages.

 

So the method I use upper is a half soultion to use midi well.

 

1. Set the preset or snapshot bpm as you desire.

2. Send only Song Start message.

3. When you want to stop, send Song Stop  message

 

 

My Question is this:

 

Is it possible to fix this midi tempo issue?

Or is there any temporary solutions to use right now?

Share this post


Link to post
Share on other sites

What program are you sending MIDI clock from? I think the issue is that whatever program you’re using isn’t sending MIDI clock until you hit a song start message. MIDI clock is just a constant stream, and the Helix will respond to it as long as it’s there.

Share this post


Link to post
Share on other sites

I tested RC505, LAUNCHPAD PRO MK3, ZOOM UAC2(audio interface with midi port), 

Although I didn't touch any device setting to keep the midi clock message, it didn't sync(+- 2bpm)

If I use it without sending midi clock it is better at sync, if the helix preset bpm is already set.

 

But the main problem is that some fx block didn't respond to midi clock, song start message,  like barberpolo tremolo, filter which have rate parameter.

It should be fixed.

 

Share this post


Link to post
Share on other sites
16 minutes ago, ahwk0607 said:

But the main problem is that some fx block didn't respond to midi clock, song start message,  like barberpolo tremolo, filter which have rate parameter.

It should be fixed


Do you have the rate parameter set to a note value?

Share this post


Link to post
Share on other sites
On 8/13/2021 at 12:37 AM, phil_m said:


Do you have the rate parameter set to a note value?

Yes of course. Not hz. Note like 1/4 1/8 1/2 dot like that

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...