Jump to content
Sign in to follow this  
rnoordermeer

Midi out firmware 3.11 major issues

Recommended Posts

Okay so I am using my helixfloor in combination with a Mesa Boogie TC-50.

It is connected in a 4 cable method with midi to switch amp channels and turn my reverb on and off and some other stuff on the amp.

I have the Helix setup in snapshot mode and each snapshot send there own midi parameters to the amp.

This is working absolutely  amazing for me. This way I can get the most out of my amp without having to use the switch it came with.

But now when I upgrade to firmware version 3.11 I get major issues on the midi part.

Instant switching of the amp channels does not work anymore there is a hugh delay in midi parameters been sending out from the helix ( I am talking up to 5sec and longer).

The helix sends midi signals out faster when there is no sound from the guitar going in to the helix. This is a major issue for me because I need the switching to be instant as soon as I hit the switch I need to be playing. For example when I come from my lead channel and want my clean channel I dont want a distorted amp sound.

I tried everything for example after update set everything to factory settings, change midi cc's to avoid known issues in the release note, making sure instant command waiting time is setup properly set up. I tried to rebuild all my patches. But the only fix for now is running on firmware 3.10

If anyone has any ideas it would be really welcome. Because I am afraid that if this issues stays in future firmware updates I can not update anymore 

 

Share this post


Link to post
Share on other sites

That's wacky. It's not normal for MIDI commands to be delayed. Make sure you don't have any sort of send/receive loops going on (enable Rx and enable Tx set on multiple MIDI devices). I can't imagine what might cause such a delay. MIDI commands are sent instantly from my Stomp running 3.11. Have you tried other troubleshooting? For example, hook up just your Helix to MIDI monitor software running on a computer, via USB and test.

Share this post


Link to post
Share on other sites

Version 3.1 introduced a 'Wait Time' parameter to midi commands sent from Command Centre but because this didn't exist in older presets then it didn't always get updated nicely.

Have a look at your midi commands in Command Centre and tweak the wait time parameter.

 

Craig

  • Thanks 1

Share this post


Link to post
Share on other sites

"Wait Time" setting slipped by me. Good to know it exists if its ever needed. Still, that could only account for up to a 1 second delay, not the 5 seconds hes reported. That's crazy. Could be a wormhole.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...