Jump to content
pvickers

Helix S/PDIF Sync Lock Problem

Recommended Posts

I have a Helix Floor unit routing into a FocusRite Scarlett 18i20.

 

What I have found is I can set the Helix and 18i20 to a sample rate of 44.1 kHz and it seems to work fine.

However, using the default of 48 kHz causes synchronization issues... The signal drops out, pops etc.

 

I have the 18i20 set to synchronize using S/PDIF and the "Digital I/O Mode" set to S/PDIF RCA.

 

I'm using the S/PDIF output on the Helix to the input on the 18i20.

The cable is good quality, 75-ohm, and intended for digital links. (15 feet long.)

I'm running the latest firmware on the Helix 3.11.

Also have the latest FocusRite firmware and "Control" software (version 3.7.4.1943).

(I'm running this all using an Intel based MacBook Pro on "Big Sur" version 11.6.1.) 

 

I have already tried using a very high quality, 3 foot cable.  This made no difference.

 

Is it possible the Helix could have a hardware problem?

 

Thanks!

 

 

 

 

Share this post


Link to post
Share on other sites

I'm using a PC with W10.

My 2nd gen 18i20 is on FW 1653. The latest.

Control v3.6.0.1822. The latest.

Set to 48k, Clock Source INTERNAL.

No problems. Helix works.

You have a MAC with Big Sur. That OS is known to have had problems with lots of stuff.

I would contact Focusrite Support.

 

  • Like 1

Share this post


Link to post
Share on other sites

Possible but not likely.

1. Make sure your Helix SPDIF is set to internal clock.

2. Make sure your DAW (or session) is set to the desired sample rate.

3. If 1 and 2 check other sample rates.

4. If nothing works, change Focusrite to digital master and Hx to digital slave 

 

BTW: If you are using Mac check which driver you are currently using. If not "downloaded multisample rate driver" you are using Helix Class Compliant. This may create some issues when aggregated.

  • Like 1

Share this post


Link to post
Share on other sites

I know how to set the sample rate on the Helix (in the global settings), but how do I set the Helix SPDIF to internal?

 

I can do this for my 18i20, but I don't know where this setting is for the Helix. (...nothing about this in the Helix manual that I can find so far.)

 

Until now, I have only been using the Apple core audio support (I have not installed the Line 6 driver).

I understood this additional driver was required for USB based synchronization when using rates other than the default 48 kHz.

 

Thanks!

Share this post


Link to post
Share on other sites

It seems there is no info in the Hx FL manual how to make it work on external digital clock. I am owner of Hx LT. It has no digital input (except USB) so I can not use it anyway but as a master it works on any sample rate gobal settings allow.
Have you tried to disconnect Hx USB while using SPDIF? I know SPDIF should work independent but lollipop happens.

Share this post


Link to post
Share on other sites

Yes, I have tested having only my Helix floor connected to the Scarlett 18i20 using S/PDIF.

(I should mention I have the generation 3 of the 18i20.)

This worked fairly well with the 18i20 and Helix set to 44.1 kHz with the clock on the 18i20 set to S/PDIF.

However, I did still get some drop outs and lock synchronization problems.

It would consistently occur when using the Helix 6 button looper, start/stop would often trigger it.

 

After the help you and "rd2rk" provided above, here is what I've done so far...

(...Getting away from the S/PDIF connection and using USB for both the 18u20 and Helix.)

I installed the "Line 6 Helix Driver2".

I set up an aggregate USB device on my Mac…using Apple’s website documentation here:

https://support.apple.com/en-ca/HT202000

With the aggregate USB device set up, I changed my Helix back to use the default 48 kHz and also tried 44.1 kHz… both worked fine.

 

The aggregated USB device is going to be incredibly useful in my DAW (Reaper).

 

After testing this a bit, I disconnected the Helix from my Mac and reconnected it by S/PDIF to the 18i20, set to 48 kHz with the 18i20 set as “Internal”.

So far, this appears to be working well.

 

Thanks for the help! 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...