Jump to content

Helix/HX 3.15 Update


Digital_Igloo
 Share

Recommended Posts

"Per-Snapshot Command Center > HX Snpsht Values"

 

If I am understanding this upgrade correctly.... I could have snapshots as follows

 

1 - Intro

2 - Verse

3 - Chorus

4 - Bridge

5 - Lead

 

Thus I could have 1 button to advance 1>2>3>4>5.....correct?  

 

However if I had a song that followed a Intro > Verse > Chorus > Verse > Chorus >Bridge > Lead > Verse > Chorus pattern... I would need all 8 snapshots, and run one short of a linear song navigation?

 

If I wanted to use a 2nd button to navigate the different parts of a song that the Chorus leads to (verse, lead, outro potentially), I would just assign a second button to get me there?  If that is correct it'd look similar to this?

 

1 - Intro (button 2 - verse/change 1)

2 - Verse (Button 2 - chorus/changes 2, 4, 8)

3 - Chorus (button 2 - Verse/change 3, Button 3 - Bridge/change 5)

4 - Bridge (button 2 - Lead/change 6)

5 - Lead (button 2 - verse/change 7)

 

 

Am I thinking correctly with that?  

 

Link to comment
Share on other sites

6 minutes ago, themetallikid said:

"Per-Snapshot Command Center > HX Snpsht Values"

 

If I am understanding this upgrade correctly.... I could have snapshots as follows

 

1 - Intro

2 - Verse

3 - Chorus

4 - Bridge

5 - Lead

 

Thus I could have 1 button to advance 1>2>3>4>5.....correct?  

 

However if I had a song that followed a Intro > Verse > Chorus > Verse > Chorus >Bridge > Lead > Verse > Chorus pattern... I would need all 8 snapshots, and run one short of a linear song navigation?

 

If I wanted to use a 2nd button to navigate the different parts of a song that the Chorus leads to (verse, lead, outro potentially), I would just assign a second button to get me there?  If that is correct it'd look similar to this?

 

1 - Intro (button 2 - verse/change 1)

2 - Verse (Button 2 - chorus/changes 2, 4, 8)

3 - Chorus (button 2 - Verse/change 3, Button 3 - Bridge/change 5)

4 - Bridge (button 2 - Lead/change 6)

5 - Lead (button 2 - verse/change 7)

 

 

Am I thinking correctly with that?  

 

I would think if you're bouncing back and forth between snapshots as in your second scenario, manually triggering the snapshot changes from an appropriate screen (like, set up 4 stomp 4 snapshot mode) would make more sense.

But otherwise I understand it the way you do. Great little feature. A bit like the "Step" feature in my T.C. Helicon Voicelive3.

 

This update looks DOPE.

  • Upvote 1
Link to comment
Share on other sites

Just now, tjbassoon said:

I would think if you're bouncing back and forth between snapshots as in your second scenario, manually triggering the snapshot changes from an appropriate screen (like, set up 4 stomp 4 snapshot mode) would make more sense.

But otherwise I understand it the way you do. Great little feature. A bit like the "Step" feature in my T.C. Helicon Voicelive3.

Yeah, right now I use the Stomp Mode screen and custom layout my presets on a per song basis.  Very rarely do I have 5 or more snapshots, and very few use a stomp/bypass block as well in addition to it.  I could see it on some songs it'd be cool to have a single button to push for all changes....eliminate the need to look down and read the scribble strips, but thats also why I color code the LED rings...

 

I'm guessing that this doesnt change the idea of jumping from preset to preset and only being able to jump to the pre-saved snapshot the preset was on?  Meaning if I build a handful of presets, but maybe a clean/push/OD/Lead version of each preset using 4 snapshots each....that I could build a performance pedal board that would let me assign choose which preset per button, but additionally which snapshot of that preset is on the button.  So you could have 2 preset buttons referencing the same preset, but each referring to a different snapshot of that.  

 

I know the easy work around would be just to copy/paste the preset elsewhere and save on the other snapshot....but it would eliminate the extra work/storage/maintenance

Link to comment
Share on other sites

I recently bought a Helix Rack and I found this bug in the UI for versions 3.10 and 3.11. I also discovered that it was not fixed in the 3.15 release. The weird thing is: this is not happening on version 3.01. Can any other Helix Rack user confirm that I am not the only person suffering this? Really thanks.

https://www.youtube.com/watch?v=RRBQN3oYjhI

Bug description:
On selecting the effect, when I click an option on the second column, the first column change.

That's why you can see something like this, on where the first column has not relation with the others:
- First column: Amp+Cab
- Second column: Mono/Stereo/Legacy
- Third column: All the reverb effects (Dynamic Hall, Hot Springs...)

Link to comment
Share on other sites

3 minutes ago, lvidarte said:

I recently bought a Helix Rack and I found this bug in the UI for versions 3.10 and 3.11. I also discovered that it was not fixed in the 3.15 release. The weird thing is: this is not happening on version 3.01. Can some other Helix Rack user confirm that I am not the only person suffering this? Really thanks.

https://www.youtube.com/watch?v=RRBQN3oYjhI

Your video has no narration. I can see the button pushing but really don't know what to look for and didn't notice what I presume I should be seeing. Please explain the bug.

Link to comment
Share on other sites

39 minutes ago, silverhead said:

Your video has no narration. I can see the button pushing but really don't know what to look for and didn't notice what I presume I should be seeing. Please explain the bug.


Thanks for the response!
On selecting the effect, when I click an option on the second column, the first column change.
That's why you can see something like this, on where the first column has not relation with the others:
- First column: Amp+Cab
- Second column: Mono/Stereo/Legacy
- Third column: All the reverb effects (Dynamic Hall, Hot Springs...)

Link to comment
Share on other sites

43 minutes ago, lvidarte said:


Thanks for the response!
On selecting the effect, when I click an option on the second column, the first column change.
That's why you can see something like this, on where the first column has not relation with the others:
- First column: Amp+Cab
- Second column: Mono/Stereo/Legacy
- Third column: All the reverb effects (Dynamic Hall, Hot Springs...)

Yes, I am able to reproduce this behaviour. It seems to occur sometimes when you both rotate and move the joystick left/right simultaneously. I think it is a bug. Please open a support ticket to log this with Line 6 Tech Support.

Link to comment
Share on other sites

Thank you for this update !

 

I notice that if you put just 1 amp+cab in the begin of your build , some pitches are not available , but if you put the pitch before you put a Amp block than it's available ?

Link to comment
Share on other sites

To me this could be named the "Finally a true Shimmer!" update XD But of course there is more interesting stuff. I just happen to love shimmer and was waiting to have it in a single block instead of stacking two or three. The same goes for that Heliosphere delay+reverb. This simplifies many blocks I have in some of my presets.

The "Per-Snapshot Command Center" looks interesting too, although a video tutorial would be appreciated. I recently uploaded to ideascale this "snapshot sequence" mode, and this looks like a primitive version I might use (once I undertand it XD)!

Thanks Line6! I'm enjoying this one a lot. 

Link to comment
Share on other sites

Well, I guess after 7 years it was finally my turn to have a problem upgrading...sigh...

No big deal.  The system just got hung up installing the firmware.  When it became obvious it wasn't really going anywhere, I just killed the HX Edit program from the task manager, started HX Edit 3.15 again and went through the update of the firmware again and it all worked perfectly.

Who knows what caused it, but it's nice to know the update process is robust enough that it doesn't get thrown into a tizzy if the update procedure gets interrupted.  Nice solid piece of software.

  • Like 2
  • Thanks 1
  • Upvote 2
Link to comment
Share on other sites

Update went great, did everything according to the instructions, but, When i went into import , to restore my backup, for some reason it wasn’t showing the files, i finally found them, but I cant open them. Anyone having this issue ? 

 

I was going to start from scratch anyway, but there were certain presets i wanted to clone , and of course re importing Ir’s is easy enough, but just curios if this happened to anyone else ? 

Link to comment
Share on other sites

42 minutes ago, jerryratpack said:

Update went great, did everything according to the instructions, but, When i went into import , to restore my backup, for some reason it wasn’t showing the files, i finally found them, but I cant open them. Anyone having this issue ? 

 

I was going to start from scratch anyway, but there were certain presets i wanted to clone , and of course re importing Ir’s is easy enough, but just curios if this happened to anyone else ? 

 

Are you navigating to your backup files via the 'Restore From Backup' command under the 'File' entry in the HX Edit menu? If it is not working, assuming the backup file is not totally corrupt, you can try the 'Extract Files From Backup' command on your backup and at least rescue and restore the presets you most want to retain. Btw, your backup files should have a suffix of ".hxb".

 

Also, are you getting any kind of error message when you try to restore the backup?

  • Upvote 2
Link to comment
Share on other sites

42 minutes ago, HonestOpinion said:

 

Are you navigating to your backup files via the 'Restore From Backup' command under the 'File' entry in the HX Edit menu? If it is not working, assuming the backup file is not totally corrupt, you can try the 'Extract Files From Backup' command on your backup and at least rescue and restore the presets you most want to retain. Btw, your backup files should have a suffix of ".hxb".

 

Also, are you getting any kind of error message when you try to restore the backup?

 

That’s where i am going wrong. I will try the Restore From Backup

 

I really appreciate the reply. Ill let you know if this fixes it

Link to comment
Share on other sites

The "tone stack" on the Ventoux amp is really something, a distinct departure from traditional amps. Props to Line 6 for innovative thinking, and not doing just another model of an existing amp.

 

I'd love to see more of this "re-imagining" in future updates. Sure, the classic amps were great...but maybe Ventoux is the start of the next generation of classic amps that are possible only through modeling.

 

Impressive as "word-I-can't-use-in-a-public-forum" :)

  • Upvote 3
Link to comment
Share on other sites

17 minutes ago, craiganderton said:

The "tone stack" on the Ventoux amp is really something, a distinct departure from traditional amps. Props to Line 6 for innovative thinking, and not doing just another model of an existing amp.

 

I'd love to see more of this "re-imagining" in future updates. Sure, the classic amps were great...but maybe Ventoux is the start of the next generation of classic amps that are possible only through modeling.

 

Impressive as "word-I-can't-use-in-a-public-forum" :)

I couldn't agree more...

 

I haven't really had a chance to dive into much on this update yet, but this is one UNIQUE AMP in the way it functions. Not sure if I'll use it anywhere or not yet... but it's "different", and I like that! 

 

17 minutes ago, craiganderton said:

Props to Line 6 for innovative thinking, and not doing just another model of an existing amp.

 

I would still LOVE to see an Ampeg V4 or it's combo version... a V22.

Link to comment
Share on other sites

7 hours ago, DunedinDragon said:

Well, I guess after 7 years it was finally my turn to have a problem upgrading...sigh...

No big deal.  The system just got hung up installing the firmware.  When it became obvious it wasn't really going anywhere, I just killed the HX Edit program from the task manager, started HX Edit 3.15 again and went through the update of the firmware again and it all worked perfectly.

Who knows what caused it, but it's nice to know the update process is robust enough that it doesn't get thrown into a tizzy if the update procedure gets interrupted.  Nice solid piece of software.

Had same happen here... all good after that

Link to comment
Share on other sites

Seems like a decent update (apart from that there's absolutely nothing in it I was wishing for, but hey...), so I'm sure plenty of people will welcome this (and quite obviously, I will use the new toys as well, even if I don't need them), but uhm:

 

"IMPORTANT! We ran out of reserved Global CCs and unfortunately had to steal five user-assignable CCs for this feature. Any parameters you've assigned to CC77-CC81 will have to be remapped. Sorry 'bout that"

 

These are just the ones I was using for some patches. Not a biggie by any means because external MIDI control is wonky anyway (/cue "what I might have been wishing for"), so I'm not making much use of it, but in case I had made this a serious part of my Helix business, I'd surely be way less than happy. But what's really bugging me is that the feature for which these CCs had to go seems to be something pretty much nobody will use much. I mean, once you control any of those knobs via external MIDI CCs, parameters will jump all over the place all the time - that's not what you usually want when finetuning a patch. Let alone you still have to somehow select the block to be controlled beforehand. And let's also not let alone that generally, external MIDI control could be realized much more elegantly on a whole number of levels (/cue "what I might have been wishing for").

In my book, patch backwards compatibility should always only be compromised in favour of truly great and often asked for new features. Which this isn't.

Anyhow, going to have a look for the other things now.

Link to comment
Share on other sites

First play: The Ventoux amp is quite nice, goes well with pedals.

The Crisscross delay might easily become my standard allround delay as it's offering all I usually need/want.

The Helios delay is quite nice too, I sometimes just like a little bit of additional reverb "wash" on just my delays, something you previously needed to sacrifice an entire path for. Too bad its got no tone controls, I'm making use of these all the time in case they're available.

Shimmer might come in handy occasionally, at least it's sounding decent.

Dynamic Plate and Room are quite nice I think. These will become my defaults now (have been using Legacy verbs so far).

Quite digging the Random S&H, too.

 

So much for now.

 

Link to comment
Share on other sites

13 hours ago, HonestOpinion said:

Just wanted to note there is a 3.15 update to Native available now for download as well.

 

Really pleased with the 3.15 update - looking forward to getting stuck into it, but I can't find where to download the Native update.  The downloads page seems to still show version 1.00 as the latest release.  Grateful for any guidance, thanks.

Link to comment
Share on other sites

Solid update, even if there's not much from my personal wish list. I do want to commend Line6 for streamlining the update process. It has come a long way since the early days!

 

The recommendation to restore a backup means that there are no new or updated Factory Presets?

Link to comment
Share on other sites

2 minutes ago, wicker_man said:

 

I can't find where to download the Native update.  The downloads page seems to still show version 1.00 as the latest release.  Grateful for any guidance, thanks.

 

You need to leave the hardware dropdown blank. Only choose software and OS, and it will appear. The same happened to me this morning :)

  • Upvote 1
Link to comment
Share on other sites

13 minutes ago, Jyda said:

The recommendation to restore a backup means that there are no new or updated Factory Presets?

 

I'm not sure if there are or not but when you restore your backup, if you uncheck the factory banks you'll be left with the latest ones.

  • Like 1
  • Upvote 1
Link to comment
Share on other sites

hi, I recently updated the EX-edit software to 3.15 version. (mac OS X )

unfortunately the app show me ' No update available' 

so I can't update the firmware of my Helix LT .. it's still on 3.11

any help ? thanks

Link to comment
Share on other sites

37 minutes ago, dosiafrank said:

hi, I recently updated the EX-edit software to 3.15 version. (mac OS X )

unfortunately the app show me ' No update available' 

so I can't update the firmware of my Helix LT .. it's still on 3.11

any help ? thanks

 

Did you log into your account from within HX Edit?

And in case that doesn't work, try the Line 6 Updater and the flash file provided in the download section. Had to do so myself as well.

Link to comment
Share on other sites

5 hours ago, CraigGT said:

 

I'm not sure if there are or not but when you restore your backup, if you uncheck the factory banks you'll be left with the latest ones.

 

If you do a full restore, as I did, when you turn Helix off and on again, it rebuilds the factory banks again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...