Jump to content

Helix/HX 3.15 Update


Digital_Igloo
 Share

Recommended Posts

6 hours ago, silverhead said:

 

I expect Line 6 has factored in the (largely unquantifiable) prospect of lost sales due to poor factory presets. Seems they have decided it's not worth the effort to try to 'improve' them further, whatever that means, at least not now. It takes resources to do that and it's not clear it would push any tire-kickers over the line in a retail store. It's like pinning the tail on a donkey. Every user's ears, equipment, and style preferences are different. A change one tire-kicker likes would be hated by another. Like you, any serious buyer (and the $ involved means serious) understands that factory presets need to be tweaked.

 

If Line 6 thought they could drive increased sales by improving factory presets instead of adding new functionality they would do that.

 

New prospective buyers have a lack of experience in dialing in a preset to their personal tastes. Combine this with the fact that you cannot control for what they will be monitoring with, and it makes it difficult to provide "universal" presets that really do a device justice. I suspect that if you took the Helix and loaded the Factory presets with the best of the preset packs being offered by third parties along with the top-rated presets from CustomTone you might still get a similar tepid response to the Factory presets. 

 

Part of the challenge in populating any new device with presets is somewhat the same for the creators of the device as it is for the users. It takes some time to get good at preset design. With competition and the speed of innovation accelerating the time to market for all manufacturers, the time available to surmount that learning curve is getting shorter all the time. We all got better at preset design with time.

 

Creating great presets is inherently an evolutionary process, highly subjective, and acutely dependent on being listened to with the same type of monitoring setup they were created on. The ROI of devoting time and resources to that, as @silverhead alluded to, no doubt figures heavily into how much attention a company dedicates to preset design. Would it be great to have preset packs and the best of CustomTone make their way into the Factory presets. Maybe. But how do you go about compensating those preset designers and is it worth it? We have seen celebrity/pro designed presets on a range of devices, most notably the TC Electronics pedals, and I suppose they sell more devices but there is no doubt a point of diminishing returns. Lastly, some devices just seem to lend themselves to playing better with a wide range of monitor setups right out of the gate. The rub is that they may lack features, functionality, or even the ability to sound great, not just good, when a bit of experience and knowledge is applied to them.

 

Btw, this evolutionary element to a modeler's presets also has a similar impact on amp and effect design. If a product is lucky enough to have the time to mature, the developers tend to get better and better at emulating various amps and effects. The problem is that in many instances, if you were to just swap out older versions of a block with a newer better one, it can easily and adversely impact presets constructed with the earlier version. That is why they tend to issue the amp or effect as a new variation rather than changing them under the covers; with the exception of those occasions where the block had a demonstrable defect to begin with.

  • Like 1
  • Upvote 1
Link to comment
Share on other sites

1 hour ago, SaschaFranck said:

 

Quite a different thing than latency introduced by whatever digital devices (and I'm sure you know that as much as I do, so we really don't need to discuss it here).

 

Maybe I'm missing something, but if I hit a note and hear it 10 ms later, I don't think it matters if that 10 ms delay is from sound traveling through the air, or from sitting in a buffer. 

  • Like 2
Link to comment
Share on other sites

3 hours ago, HonestOpinion said:

Creating great presets is inherently an evolutionary process

 

This is a simple, yet brilliant, statement that I hadn't really considered. You're so right. When I store a preset, it's a framework for what will be tweaked the next time I use it.

  • Thanks 1
Link to comment
Share on other sites

9 hours ago, SaschaFranck said:

But nobody checking a fresh-from-factory model in a shop will.


Mmm… I wonder how this would work ITRW, with a guy walking into a music store, and asking to check out a specific amp and cab?

 

If the staff then plug his guitar into the rig of his choice in the demo room, and he hits a chord, would he expect it to sound perfect without any modification to the dial settings on the front panel that had been left by the last person to try it out with a totally different guitar?

 

That’s what happens in the real world - therefore, consider that Line 6 have given you that exact same scenario inside a digital modeller.

 

This factory preset thing is trivial nonsense - all presets suck!

  • Like 1
Link to comment
Share on other sites

5 minutes ago, datacommando said:


Mmm… I wonder how this would work ITRW, with a guy walking into a music store, and asking to check out a specific amp and cab?

 

What music store salespeople have told me is that customers just want to hear something that blows them away, for one reason or another. That's been true for as long as I remember...like people who called up the Helicopter preset from the Korg Polysix (IIRC), and were amazed that it could make that sound. But I doubt very many people used it in a live set.

 

I could be wrong, but I don't think musicians buy something based on expecting to take it to the gig that night and use it. In a lot of cases, it's about the ecosystem. A $1600 processor is not an impulse item. Any buyer would have done some research and realized that for Helix, there are tons of third-party presets, IRs, YouTube videos, forums, etc. that support their purchase. I think that would mean more to most consumers than factory presets which may or may not align with the needs.

 

I suspect I'm not the only one whose favorite factory preset is "Clear all blocks" so I can make Helix do what I want. :)

 

  • Like 3
Link to comment
Share on other sites

5 minutes ago, craiganderton said:

I suspect I'm not the only one whose favorite factory preset is "Clear all blocks" so I can make Helix do what I want. :)


True, so very true - that gets my vote. I bought my Helix for it’s functions and capabilities - not presets. Roll your own presets.

  • Like 2
Link to comment
Share on other sites

5 hours ago, SaschaFranck said:

Well, the default settings should rather stay in whatever "realistic" realm. Modern 100W amps with their master at 5 aren't anything like that. 

 

On the Helix... an AMP Model that doesn't normally have a master volume is usually set to 10... which is correct for a default setting. 

 

A modern style amp which includes a master volume is often set much lower in the Helix. I don't think 5 is out of line when tone hunting.... in real life people would run it lower for "volume reasons only"... given a chance they would love to open it up more. On the Helix run it where you want... you have the channel volume to control the level. 

 

5 hours ago, SaschaFranck said:

Similar things go for hum, ripple and sag.


My understanding is that 5 on these settings would reflect the "normal" operation of the amp in question. A fixed value is not equal on all amp models.

EG: On a Hiwatt it won't sag at all (at 5), but you can tweak it if you want. On a Tweed Deluxe it would be loaded with SAG (at 5)... but again, adjust as you want. The same would apply to hum, ripple, bias and bias x.   

 

Link to comment
Share on other sites

3 hours ago, codamedia said:

EG: On a Hiwatt it won't sag at all (at 5), but you can tweak it if you want. On a Tweed Deluxe it would be loaded with SAG (at 5)... but again, adjust as you want. The same would apply to hum, ripple, bias and bias x. 

 

Well since you mentioned sag :)  You're right that "normal" for sag is a moving target. I wanted to quantify how sag works, for my own edification, and include it in the 1.1 book update. Here are some representative examples of what sag looks like at maximum. At minimum, there's no sag. 

 

image.thumb.png.9d52558f41ccd264efec6c7734d4bc51.png

 

So basically, you set sag for whatever you want. Sag itself varies depending on level, how hard you're driving the amp, etc. so I think a value of 5 is as good as any - halfway between no sag, and maximum sag. This also shows that generalizations, like "sag makes things more touch-sensitive" or "sag compresses the sound" aren't all that relevant because all the amps react so differently. FWIW the Ventoux sag (at max) is closest to the Essex A30, with about 200 ms duration before it settles down. Interesting stuff...

  • Like 1
  • Thanks 1
  • Upvote 3
Link to comment
Share on other sites

On 2/9/2022 at 5:54 PM, Lajwah said:

My HX STOMP is just Frozen after trying to update. Just seeing the boot screen, nothing else. I tried turning it on and off to do a factory reset, still only get the boot screen. Plugging a USB cable into it, Line 6 Updater doesn't recognize the Stomp is plugged in. I'm just stuck... Anybody have any idea what I can do? 

 

 

I experienced the same problem.  Any solution to solve this?  Tried a reset (holding down button 2+3) and it showed it would reset on the display, but also the reset stalled at the end of the boot screen.

  • Upvote 1
Link to comment
Share on other sites

On 2/9/2022 at 10:43 PM, DGangJ said:

Hi, seems I have ran into a problem... Was updating firmware to 3.15 and it gave out an error mid update. 

Turned the unit off then on, it boots up as 3.15 and I have no notification to update in HX Edit, and all my amp/cab blocks have are not working anymore, they can all be on or off, it just sounds like they aren't there. Already did a factory reset and even the factory effects are messed up. did 2 full restores already and still the same. 

Any ideas on how can I force update to 3.15 or revert back to 3.11 then reupdate to 3.15?

Well I didn't get any replies on this, but just in case anyone was affected as well, the problem I had with my blocks were clearly due to the failed update. 

Managed to enter HX Stomp in update mode (Nxt Page + Power Up) with Line6 Updater opened in offline mode and 3.15 firmware downloaded. All went well this time and its fully working again.

 

On a side note, its great now that you can set 1 stomp button to call or cycle through snapshots (next and previous with press and hold) and also assign individual blocks or functions to the other 2 buttons, really opens up the possibilities on this little box.

Link to comment
Share on other sites

13 hours ago, datacommando said:

Mmm… I wonder how this would work ITRW, with a guy walking into a music store, and asking to check out a specific amp and cab?

 

Well, all required parameters are instantly exposed, so adjusting a real physical amp is a breeze. Not so much when it comes to tweaking the Helix, especially in case you need to go into the cab settings, too.

Link to comment
Share on other sites

12 hours ago, codamedia said:

On the Helix... an AMP Model that doesn't normally have a master volume is usually set to 10... which is correct for a default setting. 

 

I'm perfectly aware of that. Hence my mentioning the amps coming with a master volume in real life.

12 hours ago, codamedia said:

My understanding is that 5 on these settings would reflect the "normal" operation of the amp in question.

 

Not too sure about that. I remember some models (don't remember which ones) to noticably hum at the default settings. Which, in the real world, would usually be an indicator for me to have the amp serviced.

Link to comment
Share on other sites

13 hours ago, craiganderton said:

I suspect I'm not the only one whose favorite factory preset is "Clear all blocks" so I can make Helix do what I want. :)

 

Fwiw, I haven't even scrolled through any factory presets ever since I bought the unit, simply because due to my experiences in shops, I already knew it'd be pointless to start there. Apart from that, I create each and every preset for each and every device I'm using myself since decades already. So I don't care about presets at all. But others with less experience may (the preset aftermarket is a good indicator for that to be a thing).

For me it has been much more about the block defaults, which IMO are far away from what makes sense. I mean, just take most delays and reverbs - the first thing you need to do is to turn down mix (and usually feedback/decay, too), otherwise you'll end up with one big pile of mud.
Now, sure, I welcome the user defaults and I'm using them all the time - but again, someone checking out the unit will not know about them, let alone there won't be any user defaults on a new unit.

Link to comment
Share on other sites

Hello, 

 

I'm getting issues with and aux switch after update my Stomp. It's a Hotone Ampero and the first switch doesn't work... i try with 2 different TRS cable and then, switch the function to the other Switch and works on that... any help is welcome! 

Link to comment
Share on other sites

Sascha Franck said:

"Well, as far as factory presets go, I had an opportunity to check out a whole bunch of Axe FX III factory patches a while ago. And compared to what's coming with the Helix, for me it's night and day." 

 

    AxeFX III is also roughly twice the price. I've been a Boss/Roland user for years ( GT 10, 100, GR55), and while it was a little bit of a learning curve switching to the Helix LT, the one thing I found was that while that presets were not necessarily great out of the box, they were good starting points and I have found it much easier to dial in a tone I like rather quickly. I still miss some of the Boss effects, but have been happy with the Helix offerings, and much prefer the HX editor and UI over the Boss offerings. Point is you get out of a MFX unit what you put into it, whether it's money or time or both.

Link to comment
Share on other sites

I was a Fractal user way back when the Standard was new then got on the waitlist for an Ultra.     I can tell you, everyone bitches about factory presets no matter the manufacturer, there was no shortage of posts then and probably still today.

  • Like 2
Link to comment
Share on other sites

21 hours ago, weily said:

I'm getting issues with and aux switch after update my Stomp. It's a Hotone Ampero and the first switch doesn't work... i try with 2 different TRS cable and then, switch the function to the other Switch and works on that

 

I have an Ampero Switch and it "just works", as it always did.

Make sure that Global Settings > Preferences > EXP/FS Tip & Ring are assigned to FS4/FS5 with Normal polarity, and Global Settings > Footswitches > FS4/5 Functions are assigned to their corresponding Stomp number.

  • Upvote 1
Link to comment
Share on other sites

ROAST ME!

 

I use Mac OSX and I’ve been trying to update my HX stomp to 3.15 for days now, and it’s been nothing but frustrating; I deleted my existing Edit and Updater, downloaded the .dmg files for the recent versions and installed..

 

Editor would not allow me to sign into my account without crashing completely (error message: ‘HX Edit quit unexpectedly’), and additionally indicated to me there are ‘No Updates Available’ whenever I tried that method. I don’t see any other way to do that.

 

When I boot up Line 6 Updater (version 1.23) it only lists 2.92 as the most recent version (I’m running 3.11 now).. am I missing something? This happens with or without Edit being open simultaneously.

 

Before you spit roast me about not performing a factory reset I also want to mention that I haven’t done that, as Edit ALSO will not let me back up my presets. I try to do this, it literally goes to 100%, looks like it worked — but then the program crashes…

 

Please does anyone have some bright or insanely obvious idea I’m not seeing? All of you with the new updates sound so awesome and I’m dying to get there.

Edited by ryanfoster
Left out vital info
Link to comment
Share on other sites

12 minutes ago, ryanfoster said:

When I boot up Line 6 Updater (version 1.23) it only lists 2.92 as the most recent version (I’m running 3.11 now).. am I missing something? This happens with or without Edit being open simultaneously.

 

First of: Don't keep HX Edit opened when dealing with the Line6 Updater, the two don't coexist happily next to each other.

Then, try this: Download the flash files for the 3.15 update. Open the Updater and select "offline mode". Select your unit and the Updater will ask you to choose a file, point it to the flash file you've just downloaded.

Link to comment
Share on other sites

@HonestOpinion thanks for the guidance on the restore. Never had a problem before. - it worked like a charm!  I searched high and low on my machine for the latest  *.hils, finding all the old ones, but not this weeks. Where is it residing? Any idea why can't i see it anywhere on my machine? thanks

Link to comment
Share on other sites

On 2/9/2022 at 9:25 AM, tallinn1 said:

Hi ,I just updated HX Edit - HX Stomp to 3.15 and now I have no sound.

I have Mac OS Catalina version 10.15.7

 

Did you do a factory reset and then restore your backup? My first guess would be that your global settings were reset to default. Restoring the backup will also reset your global settings to your preferences from before the update, as well as ensure your device is ready for prime time. Recheck your physical connections as always.

Link to comment
Share on other sites

Great update. Me and a friend were auditioning all the new effects on our respective machines (Helix and HX Effects). Inspiration for days! I had to do the firmware update twice, but the second time it worked and didn't erase my presets. Thanks, Helix team!

Link to comment
Share on other sites

Hola.

Estoy actualizando mi Helix LT al nuevo firmware 3.15. Mi versión actual es la 2.30

En las instrucciones de instalación indica que se debe hacer a través de HX EDIT 3.15, pero cuando voy a instalar HX EDIT me dice que esta versión es compatible con Helix 3.0 o versiones superiores.

Así que no sé si esto invalida este procedimiento o debo ignorar esta advertencia instalando esta versión y haciendo una copia de seguridad de mis ajustes preestablecidos con esta última versión. 

O realizar un procedimiento diferente.

Agradecería algo de luz sobre este asunto.

 

Gracias.

Link to comment
Share on other sites

11 minutes ago, metalmaniac69 said:

Hola.

Estoy actualizando mi Helix LT al nuevo firmware 3.15. Mi versión actual es la 2.30

En las instrucciones de instalación indica que se debe hacer a través de HX EDIT 3.15, pero cuando voy a instalar HX EDIT me dice que esta versión es compatible con Helix 3.0 o versiones superiores.

Así que no sé si esto invalida este procedimiento o debo ignorar esta advertencia instalando esta versión y haciendo una copia de seguridad de mis ajustes preestablecidos con esta última versión. 

O realizar un procedimiento diferente.

Agradecería algo de luz sobre este asunto.

 

Gracias.


Hola,
De las Notas de la versión 3.15 (en inglés) dice:
“Mi Helix/HX está en la versión X.XX. ¿Puedo ir directamente a 3.15?
Sí, pero tenga en cuenta que si está comenzando desde 2.80 o inferior, la actualización parecerá ocurrir dos veces. Esto es normal.”

Espero que esto ayude/tenga sentido.

 

English:

Hello,
From the 3.15 Release Notes (in English) it states: 
“My Helix/HX is at version X.XX. Can I go straight to 3.15?
Yes, but note that if you're starting from 2.80 or lower, the update will appear to happen twice. This is normal.”

Hope this helps/makes sense.

 

Link to comment
Share on other sites

22 minutes ago, datacommando said:


Hola,
De las Notas de la versión 3.15 (en inglés) dice:
“Mi Helix/HX está en la versión X.XX. ¿Puedo ir directamente a 3.15?
Sí, pero tenga en cuenta que si está comenzando desde 2.80 o inferior, la actualización parecerá ocurrir dos veces. Esto es normal.

Espero que esto ayude/tenga sentido.

 

Inglés:

Hola,
De las notas de la versión 3.15 (en inglés) dice: 
“Mi Helix/HX está en la versión X.XX. ¿Puedo ir directamente a 3.15?
Sí, pero tenga en cuenta que si está comenzando desde 2.80 o inferior, la actualización parecerá ocurrir dos veces. Esto es normal."

Espero que esto ayude/tenga sentido.

 

 

Thanks, I'll try this, my apologies for the error with Google Translate

  • Upvote 1
Link to comment
Share on other sites

7 hours ago, datacommando said:


Hola,
De las Notas de la versión 3.15 (en inglés) dice:
“Mi Helix/HX está en la versión X.XX. ¿Puedo ir directamente a 3.15?
Sí, pero tenga en cuenta que si está comenzando desde 2.80 o inferior, la actualización parecerá ocurrir dos veces. Esto es normal.

Espero que esto ayude/tenga sentido.

 

Inglés:

Hola,
De las notas de la versión 3.15 (en inglés) dice: 
“Mi Helix/HX está en la versión X.XX. ¿Puedo ir directamente a 3.15?
Sí, pero tenga en cuenta que si está comenzando desde 2.80 o inferior, la actualización parecerá ocurrir dos veces. Esto es normal."

Espero que esto ayude/tenga sentido.

 

 

The update seems correct now. To avoid connection problems, I downloaded the 3.15 flash file and updated it offline with Update. I did a factory reset and restored the backup created with HX Edit 3.15
  When everything seemed correct, I plugged in my guitar, but couldn't switch memories and couldn't get the buttons to work. After rebooting several times, everything seems to be fine now. I'm guessing there were still internal update processes running that weren't visible on the LT's screen...or that's what I'd like it to be.
In any case, thanks for the support.

a greeting 
 

  • Upvote 1
Link to comment
Share on other sites

11 hours ago, lance135 said:

...I had to do the firmware update twice, but the second time it worked and didn't erase my presets. Thanks, Helix team!

 

If it "didn't erase your presets" that might mean the factory reset didn't take on your second update. Might not be a terrible idea to backup, do a factory reset, and restore your backup per the update notes' recommendation. 

  • Upvote 1
Link to comment
Share on other sites

1 hour ago, metalmaniac69 said:

I'm guessing there were still internal update processes running


Gracias, me alegra saber que todo está funcionando ahora.


Tenga en cuenta: después de completar la restauración desde la copia de seguridad, notará que la próxima vez que reinicie el hardware, se ejecutará la rutina de "Reconstrucción de ajustes preestablecidos". Esto es perfectamente normal, ya que garantiza que todos los ajustes preestablecidos anteriores estén optimizados para su uso en el nuevo firmware. Además, cada vez que instale un ajuste preestablecido creado con una versión anterior del firmware (por ejemplo, un ajuste preestablecido descargado de CustomTone, etc.), la función de reconstrucción de ajustes preestablecidos se ejecutará nuevamente después del próximo reinicio; esta es una rutina de limpieza esperada para la unidad.

 

English:

Thank you - glad to know it is all working now.


Please note: After you complete the restore from back up, you will notice that the next time you restart the hardware, it will run the “Rebuilding Presets” routine. This is perfectly normal as it ensures that all you older presets are optimised for use in the new firmware. Also, any time you install a preset created with an earlier version of the firmware (e.g. a preset downloaded from CustomTone, etc.), the Rebuilding Presets function will run again after the next restart - this is an expected housekeeping routine for the unit.

Link to comment
Share on other sites

On 2/12/2022 at 5:29 PM, HonestOpinion said:

 

Did you do a factory reset and then restore your backup? My first guess would be that your global settings were reset to default. Restoring the backup will also reset your global settings to your preferences from before the update, as well as ensure your device is ready for prime time. Recheck your physical connections as always.

Thanks,now it's working.

Link to comment
Share on other sites

On 2/12/2022 at 3:14 PM, jkuche said:

@HonestOpinion thanks for the guidance on the restore. Never had a problem before. - it worked like a charm!  I searched high and low on my machine for the latest  *.hils, finding all the old ones, but not this weeks. Where is it residing? Any idea why can't i see it anywhere on my machine? thanks

 

Glad to hear it worked! The backup that is part of the automated update process creates a comprehensive backup file with the extension '.hxb' that includes your presets, IRs, setlist info, global settings, favorites and defaults. The extension for a Helix setlist is '.hls'.  There is no "i".

 

Don't remember if there is a default directory for exported setlists as I long ago created a custom location but if I had to guess it is probably under the "Line 6" directory or subdirectories. I would just search for *.hls on my drives to find it if you lose track of where they are located. Keep in mind that going forward you don't have to export setlists, but it never hurts to have them if a backup file(*.hxb) ends up corrupt.

 

I used to export all my setlists before every update but have gotten lazy about it as the backup/restore process seems to work pretty well these days. Hopefully being slack on that doesn't come back to bite me. One thing I do is manually create an extra backup with the 'Create Backup' command, in addition to the one that is created during the automated update, just for insurance.  I also use the 'Extract Files From Backup' command (under the 'File' heading in HX Edit) to give me all my presets in separate files. 

  • Upvote 1
Link to comment
Share on other sites

On 2/9/2022 at 11:37 PM, SaschaFranck said:

 

Did you restore your global settings and/or check your loop level settings?

 

thank you !

I was about to check mentions of a bug about footswitch 4 which stopped working, but it was the global setting that was reset.

Wasn't aware they were reset after an upgrade

Link to comment
Share on other sites

Hello, 

I have done the 3.15 update for my HX Stomp (with the backup and restore process). 

Everything looks fine except for the access to the Tuner (set to FS3): 

Before I was able to use my external Midi foot controller to access directly the Tuner (on and off) with a "one click". 

Now the access to the HX Stomp Tuner does not work anymore with my external Midi foot controller. 

 

Any idea of the problem and how to fix it? 

 

Thanks

Cedric

Link to comment
Share on other sites

I just wanted to say THANK YOU! To Line6 for the new snapshot commands in 3.15. This is really convenient when singing and/or playing complex stuff. 

 

Now, if it was possible to make more snapshots it would be just perfect :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...