Jump to content

Package in cold weather


siddharthsinha
 Share

Recommended Posts

Hello everyone!

 

New to the community - got my helix in the mail today. I live in the midwest where the temps are in the 20s currently. 

 

The package I received the Helix is pretty cold and so is the unit. Is it okay to use it? or should I let it sit for a while before doing so?

Link to comment
Share on other sites

6 minutes ago, DunedinDragon said:

Unpackage it and let it warm up in the room for an hour or so if you're worried.

 

^^^ this ^^^

 

I'm in Canada... it was minus 49C this morning so I understand COLD.....

If the unit got as cold as you suspect.... let it warm up to room temp (or closer to room temp) before using it. 

  • Upvote 1
Link to comment
Share on other sites

30 minutes ago, SaschaFranck said:

 

Not that I think I did, but it's still likely. If anything was ever cast in stone, it'd be that Germans have no sense of humor.

 

Now now, that's not what I was saying. Your joke was good, the interpretation of "package" just seemed to have been lost in translation... ;-)

  • Haha 1
Link to comment
Share on other sites

21 minutes ago, siddharthsinha said:

My first post here and can see the forum has a few keyboard bullies :) 

 

Not that you would be entirely wrong about that, but your question was legitimate and thank you for the opportunity to see a little humor injected into the forum. There's usually room for a quip or three as well as an informative technical response. I don't think any insult was intended and it made for a more entertaining topic. 

  • Upvote 1
Link to comment
Share on other sites

Fwiw, on topic: It's a pretty decent idea to *always* make sure to not turn on most electronic/electric devices directly after them being exposed to huge temperature differences (as in "from cold to warm" - the other way around is way less of an issue). Anyone wearing glasses surely knows what I'm talking about. Walk into a warm room from outside in winter and there we are - all condensed water. With larger surfaces, of course depending on general humidity and temperature differences, you might even see real drops. Not exactly the kind of thing you'd like to have insde your precious new gadget.
And fwiw, I think it might've been the very reason back in the days for our singers amp to blow up. Traveling for hours in winter, quite late to the gig, so it was amp out of car trunk, straight onto the stage of a pretty warmed up club, immediate soundcheck - *blam*. Not sure it was condensed water, not too unlikely, though.

  • Upvote 2
Link to comment
Share on other sites

The objective is to avoid any condensation from forming on the unit!

 

If it has been extremely cold, do not open the original interior plastic bag until it gradually warms up closer to the interior temperature.

 

This is more of a problem the higher the ambient humidity may be in your home, office, or studio. 

 

A handy humidity indicator is to see if any condensation forms after removing a soda can or beer bottle from your refrigerator and allowing it to rest on your countertop to table for a few minutes. 

Link to comment
Share on other sites

Hilarious. Below is the whole "Shrinkage Factor" clip for Seinfeld fan's

 

@siddharthsinha Please know I wasn't making fun of your question, which is a good one. I was just having some silly fun with the idea of packages shrinking in cold weather (which has probably affected us all at some point in our lives! ). I trust your Helix is warmed up and working nicely by now...

 

https://www.youtube.com/watch?v=85MZ4c1EWkM

  • Haha 1
Link to comment
Share on other sites

Thanks everyone for the responses!

 

I did fire up the helix yesterday - updated to 3.15, factory rest and restored from backup. Then added a couple of presets which were shared by a friend.

 

The next time I started the helix (a day later) it said something on the lines of “resetting the presets” and then the count went from 1 to a big number (not sure how much) 

 

restarted it a couple of times after that as well - but now boots up immediately. 
 

any clue why the reset happened again? 

Link to comment
Share on other sites

29 minutes ago, siddharthsinha said:

Thanks everyone for the responses!

 

I did fire up the helix yesterday - updated to 3.15, factory rest and restored from backup. Then added a couple of presets which were shared by a friend.

 

The next time I started the helix (a day later) it said something on the lines of “resetting the presets” and then the count went from 1 to a big number (not sure how much) 

 

restarted it a couple of times after that as well - but now boots up immediately. 
 

any clue why the reset happened again? 

 

It is a normal part of the upgrade process. No worries. You may see some specific presets rebuild here and there again upon restart if you import or copy them but not the full post-upgrade rebuild.

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...