Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Pod go boot freeze error... help me plz..


Recommended Posts


It worked well until last week, but when I ran it today, it didn't proceed anymore on the first screen, so I searched on Google and tried line 6 update again.

However, as in the last picture, the update continues to fail, leaving a question. What should I do to make it work again?

I updated the latest software and changed both the USB line and USB port location, but only the same screen appears.


when i choose update 1.30 on line6 update, it begins, but soon usb disconnect sound comes out and failure screen comes out.

I've already tried several times as shown in the manual, but it failed. Please help me


more detail pictures: 


Link to comment
Share on other sites

I recently asked Line 6 for instructions to help folk fix frozen Pod Go units.  Hope this is helpful.

From: Customer Service <>
Date: Tue, 18 Jan 2022, 10:26

Hello voxman55. Your Line 6 Support Ticket was updated with the following message:


in case of an update failure:

1. reinstall the latest version of POD Go Edit and Line 6 Updater:

2. boot the unit into "Update Mode": press and hold PAGE > (page right) and then power on POD Go.

3. reconnect the POD Go via USB to the computer. Use another USB cable and try different USB ports, don't connect to an USB hub.

4. shut down all Line 6 software including POD Go Edit, or any programs that use audio, like DAWs, iTunes, Spotify, video games, etc.

5. launch Line 6 Updater only and select "POD Go Unknown version", then (re-)install the latest firmware.

6. perform a factory reset on the POD Go (will delete all user patches, IRs, globals): while holding footswitches C+ D turn on POD Go. Wait for "Will reset Globals and restore stock Presets..." to appear and let go.

7. if this should fail, the same procedure should be tried again offline. For this you have to download the latest POD Go flash memory file, then launch Line 6 Updater, choose "Offline Mode", then choose the downloaded flash memory file for the update.

8. if it still fails, it needs to be tested with another computer.

You can update directly from any version to the latest firmware version. In rare cases a gradual update via previous versions may help but normally that's not necessary.

If none of the above should help, the unit should be checked by a service center. But please note that normally, even when an update attempt fails, the unit can returned to operational state with the above procedure.

Best regards
Line 6 / Ampeg Support Europe
- Line 6 Customer Service
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...