Jump to content

Loading Helix 3.15 Crashes Reaper (ARM) on Silicon Mac


adam79
 Share

Recommended Posts

Anyone having this issue? I'm using the latest version of Helix Native, 3.15, that supports Silicon.

 

I'm trying it from an empty Project...I create one new track, select Helix Native (VST3) from the Plugin Browser and CRASH!

 

However, I also have a template that loads an instance of Helix to one of the tracks, and this works as expected.

From here I can copy the instance to other tracks as well.

 

It's only when I try loading Helix from scratch that it crashes Reaper.

 

I have the latest ARM version of Reaper, 6.41, and I'm opening it natively.

 

Any suggestions?

 

Thanks.

Link to comment
Share on other sites

On 3/16/2022 at 2:29 AM, adam79 said:

Any suggestions?


Hi,

 

I’m not entirely sure how relevant this is, but this is noted on the Reaper download page for Mac: (my bold italics)

 

”Note: the macOS 10.15+ macOS download is notarized and uses the "hardened runtime," which may reduce compatibility with certain plug-ins. You may still run the regular 64-bit macOS download on macOS 10.15 - macOS 12; however, you must shift+right click and choose "Open" when running that version for the first time.

 

Hope this helps/makes sense.

 

  • Upvote 1
Link to comment
Share on other sites

On 3/16/2022 at 6:57 AM, datacommando said:


Hi,

 

I’m not entirely sure how relevant this is, but this is noted on the Reaper download page for Mac: (my bold italics)

 

”Note: the macOS 10.15+ macOS download is notarized and uses the "hardened runtime," which may reduce compatibility with certain plug-ins. You may still run the regular 64-bit macOS download on macOS 10.15 - macOS 12; however, you must shift+right click and choose "Open" when running that version for the first time.

 

Hope this helps/makes sense.

 

 

Oh, rad! Thanks.

 

I've seen this before, but always forget to do it.

  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...
On 3/16/2022 at 6:57 AM, datacommando said:

You must shift+right click and choose "Open" when running that version for the first time.

 

What is this supposed to do? I opened Reaper this way and loading Helix still causes it to crash.

 

Thanks.

Link to comment
Share on other sites

On 3/24/2022 at 5:24 PM, adam79 said:

 

What is this supposed to do? I opened Reaper this way and loading Helix still causes it to crash.

 

Thanks.

 

 

I don't know what it is supposed to do? That information is from the Reaper download page, therefore they must think it is important. Maybe you could ask in the Reaper forums, or tech support why Helix Native causes Reaper to crash on a Silicon Mac. Also, I saw that the current version of Reaper is listed as REAPER 6.52: Banjo Telemark, which seems to indicate that it is been constantly updated. Maybe they are bug squashing over there.
 

According to the info, in the orange banner at the top of this page - "Apple M1, MacOS 11 and 12 Compatibility with Line 6 Software". It states that " Regarding macOS Monterey 12, we continue to test against it. We will provide updates in our Knowledge Base as products are tested.".

 

There are lots of other users with Silicon Macs who have Native running just fine in other DAWs - possibly this is more of an issue in Reaper, as you said that you have had Native working via a template. If it was working, and now it doesn't then you have to ask - "What changed?"

 

Other than that you could raise a ticket with CS to see if they can assist.

 

Hope this helps - makes sense.

  • Upvote 1
Link to comment
Share on other sites

On 3/15/2022 at 10:29 PM, adam79 said:

Anyone having this issue? I'm using the latest version of Helix Native, 3.15, that supports Silicon.

 

I'm trying it from an empty Project...I create one new track, select Helix Native (VST3) from the Plugin Browser and CRASH!

 

However, I also have a template that loads an instance of Helix to one of the tracks, and this works as expected.

From here I can copy the instance to other tracks as well.

 

It's only when I try loading Helix from scratch that it crashes Reaper.

 

I have the latest ARM version of Reaper, 6.41, and I'm opening it natively.

 

Any suggestions?

 

Thanks.

 

Have you rescanned for plugins after installing Native 3.15? After looking for attached peripherals that might be causing an issue, at some point I would probably try reinstalling Native and then Reaper if required. Blunt force approach I realize but without more insight into specifically what is causing the problem this is probably how I would initially try to resolve this. 

  • Upvote 1
Link to comment
Share on other sites

On 3/24/2022 at 8:00 PM, HonestOpinion said:

I would probably try reinstalling Native and then Reaper if required.


Hi Ho, (here we go!)

 

Good point, sir.
 

IIRC, I saw a post over on the Reaper forum about an earlier version of Native and Reaper having issues because, when the VST3 Native plug-in update was installed, some bits from the previous version were not entirely “cleaned out” by the new installation, which caused Reaper to fall over.

 

Might be worth the OP investigating if a little more housekeeping is required .

 

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...