Jump to content

Catalyst LFS2 footswitch makes huge audible popping sound when switching from A-B


davetherrien
 Share

Recommended Posts

I just purchased the 60W catalyst and the LFS2 footswitch. I set up a bank with a clean A and a dirty B setting. When I am in the middle of a song with some chords ringing out, when I swtich channels, the amp doesn't transition smoothly at all - it makes a giant popping sound when I switch from A-B and B-A. I'm not sure if other amps do the same? 

Link to comment
Share on other sites

When you switch from A to B what you're actually doing is switching PRESETS. "A" unloads from memory and then "B" loads.

A radical shift in amp types and/or gain settings will cause a loud noise like a "pop" if there are notes ringing during the switch.

This is true throughout the entire Helix family.

With the full-fat Helix units you can split the Path and put a Clean amp on one and a Hi-Gain amp on the other. With the split block set to A/B you can use a FS or Snapshot to re-route the signal from A to B and that eliminates the "pop".

 

If doing that sort of tone shift is important to your playing you may want to consider adding something like an HX Stomp or, if you can afford it, a used LT will further add an expression pedal..

Yes, I know, two to four times the price of the amp, but also an exponential increase in the amp's capabilities.

Just something to consider.

 

Or you could go "old school" and put a gain pedal of some sort up front... DS-1 and Distortion+ types can be had NEW for <$75 and USED for pennies.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

I’ve haven’t noticed these popping noises on the Cat yet but I’ve had similar problems with a popping noise like that with Blackstar tube amps as well. 
In the digital world though I’d expect that to be something that  can fixed. I personally don’t buy an ‘all-in-one’ amp to then have to stick pedals in the front, although in appreciate that is one solution

Link to comment
Share on other sites

One of the many reasons that I switched to Helix was that I was tired of the popping noises made by the expensive FX I had in front of my expensive tube amps.

Nothing is easy. C'est la vie!

 

The interactions between digital and analog components and the infinite possible combinations and permutations of various digital and analog FX make the pursuit of simple and universally applicable solutions a fool's errand.

 

FWIW - I use my Cat100 in conjunction with my Helix floor configured with a combination of Snapshots and MIDI.

I have NONE of the problems that you continue to encounter.

 

Of course, my looper needs are absolutely basic, and I just put the looper block (would work with a HW looper too) in a parallel path with a separate send to a proper mixer and separate power amp/speaker.

 

Works for me!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...