Jump to content

POD X3 LIVE


chintesolo
 Share

Recommended Posts

Does anybody know where I can get my X3 Live repaired back to it's out-of-box state? I know it may be old but I still love the sound and the sounds I get from it. And the fact that I can have both guitars hooked up and ready to go. The Helix is out of my price range and the Helix LT doesn't have an aux input (unless I missed it). Thanks for any help.

Link to comment
Share on other sites

Do you mean ‘repaired’ or ‘restored’? If you need a repair you should open a support ticket.

 

If you just want to restore the factory presets (as stated in the manual):

Press and hold the Home / Hold for Commands button for 2 seconds to get to the
Commands page. 

You will see the option to restore the presets.

 

If you want to reinstall the firmware, consult the manual section called USB and Computer Software.

Link to comment
Share on other sites

  • 4 weeks later...

I have one of these and use it for personal rehearsal.   Some time back, I noticed a site where they would replace the plunger to pad switch on circuit board with a real footswitch wired to the board.   I know they did the big pedals and the old floorboard I used with my AX2, but I can't seem to find them.  I'd love to have mine redone with the other footswitches.

Link to comment
Share on other sites

  • 2 months later...
On 9/12/2022 at 11:40 PM, chintesolo said:

Hello Silverhead ,

I meant restored to the way it was when it was new with all the footswithches working properly and not just reset.

Sometimes they don't engage when I step on them.

 

That’s a hardware issue. You need to open a support ticket to get advice on where to take it for repair.

Link to comment
Share on other sites

  • 3 months later...

It sounds like the metal plungers are hanging up. The actual switches are under those and are just common $0. 25 micro switches. You can use a little sewing machine oil or maybe WD-40 sparingly to work the switch plungers free.

Link to comment
Share on other sites

I meant to warn you, Gearbox tone builder will not work on anything older than early windows 7 OS. Also, you may expect that you'll have problems with the tone port 2 in that it propagate across the whole pedalboard and fill all tone 2 ports with the same tone. I fixed Gearbox to work and load my tones to the board by getting an old laptop and loading win 7 on it and going from there, but as soon as I unplug the USB cable I start losing number 2 slot tones.

Link to comment
Share on other sites

On 1/1/2023 at 1:36 AM, lewbuckles said:

I meant to warn you, Gearbox tone builder will not work on anything older than early windows 7 OS. Also, you may expect that you'll have problems with the tone port 2 in that it propagate across the whole pedalboard and fill all tone 2 ports with the same tone. I fixed Gearbox to work and load my tones to the board by getting an old laptop and loading win 7 on it and going from there, but as soon as I unplug the USB cable I start losing number 2 slot tones.

There is a feature of the X3 called Lock Tone 2. This feature does result in Tone 2 carrying over to all presets. It is intentional and very convenient for a singing guitarist who wants to use the same vocal tone across all guitar tones. It is easily unlocked to restore full Tone 2 functionality.

 

I don’t know if that’s what’s happening to you but it’s worth investigating.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...