Jump to content

Amplifi 75 turned brick


Canidox
 Share

Recommended Posts

I got a used 75 from a guitar shop which they tested and it was fine. I tried to update it and it got stuck for a very long time, eventually I had to leave and take the phone I was updating it on with me. I came back to find a brick. It won't connect through Bluetooth (I eventually tried to update it via USB, but the amp isn't recognized) and it won't factory reset either. The ABCD lights flash when it's on and while it actually does give out a Bluetooth connection, it's not recognized in the app. It won't produce any sound at all, not even from the guitar. The seller said I could trade it in for another amp, but it's quite a long way and I want to have this one working. Does anyone know how to fix this?

Link to comment
Share on other sites

  • 2 weeks later...

I have the exact same problem with the exact same amp, has anyone been able to re install the software from scratch. Ive tried everything i can think of and think its destined for the skip which is a real shame any help would be fantastic thanx guys

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...